aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/lazperf/Makefile2
-rw-r--r--audio/libmusicxml/Makefile2
-rw-r--r--biology/kallisto/Makefile2
-rw-r--r--databases/xapian-core/Makefile4
-rw-r--r--deskutils/tasksh/Makefile2
-rw-r--r--deskutils/timewarrior/Makefile2
-rw-r--r--devel/courier-unicode/Makefile2
-rw-r--r--devel/easyloggingpp/Makefile2
-rw-r--r--devel/glibmm-reference/Makefile2
-rw-r--r--devel/hexd/Makefile2
-rw-r--r--devel/pecl-swoole/Makefile4
-rw-r--r--devel/poco/Makefile2
-rw-r--r--devel/py-pyicu/Makefile3
-rw-r--r--devel/pybind11/Makefile2
-rw-r--r--ftp/curlpp/Makefile4
-rw-r--r--graphics/feh/Makefile2
-rw-r--r--graphics/pixd/Makefile2
-rw-r--r--graphics/swfmill/Makefile2
-rw-r--r--lang/libobjc2/Makefile6
-rw-r--r--mail/courier-imap/Makefile2
-rw-r--r--mail/maildrop/Makefile8
-rw-r--r--mail/sqwebmail/Makefile2
-rw-r--r--math/glucose/Makefile2
-rw-r--r--net/pktanon/Makefile2
-rw-r--r--security/akmos/Makefile2
-rw-r--r--security/trezord/Makefile2
-rw-r--r--sysutils/fswatch-mon/Makefile4
-rw-r--r--sysutils/usbtop/Makefile2
-rw-r--r--textproc/sdcv/Makefile2
29 files changed, 34 insertions, 43 deletions
diff --git a/archivers/lazperf/Makefile b/archivers/lazperf/Makefile
index a16619bca497..47bb60991cbc 100644
--- a/archivers/lazperf/Makefile
+++ b/archivers/lazperf/Makefile
@@ -11,7 +11,7 @@ COMMENT= Alternative LAZ implementation for C++ and JavaScript
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= hobu
GH_PROJECT= laz-perf
diff --git a/audio/libmusicxml/Makefile b/audio/libmusicxml/Makefile
index 1a45fee65fd1..bdefe5f465c6 100644
--- a/audio/libmusicxml/Makefile
+++ b/audio/libmusicxml/Makefile
@@ -10,7 +10,7 @@ COMMENT= Library and tools for the MusicXML format
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/license.txt
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= grame-cncm
GH_TAGNAME= 91347ae
diff --git a/biology/kallisto/Makefile b/biology/kallisto/Makefile
index 724d4398f0d8..35563bc9bfe6 100644
--- a/biology/kallisto/Makefile
+++ b/biology/kallisto/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/license.txt
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libsz.so:science/szip
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= pachterlab
diff --git a/databases/xapian-core/Makefile b/databases/xapian-core/Makefile
index 23ad56d366d3..7406e5a69f14 100644
--- a/databases/xapian-core/Makefile
+++ b/databases/xapian-core/Makefile
@@ -14,8 +14,6 @@ COMMENT= Probabilistic text search database engine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: A compiler with support for C++11 language features is required
-
CONFLICTS_INSTALL= xapian-core10 xapian-core12
OPTIONS_DEFINE= DOCS SSE2
@@ -25,8 +23,8 @@ PORTSCOUT= limitw:1,even
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+USES= compiler:c++11-lang libtool pathfix tar:xz
USE_LDCONFIG= yes
-USES= libtool pathfix tar:xz
SSE2_CONFIGURE_ENABLE= sse
diff --git a/deskutils/tasksh/Makefile b/deskutils/tasksh/Makefile
index 8f4ed796c45b..0f618c7eb41d 100644
--- a/deskutils/tasksh/Makefile
+++ b/deskutils/tasksh/Makefile
@@ -8,6 +8,6 @@ MASTER_SITES= http://taskwarrior.org/download/
MAINTAINER= swills@FreeBSD.org
COMMENT= Shell command that wraps Taskwarrior commands
-USES= cmake readline
+USES= cmake compiler:c++11-lang readline
.include <bsd.port.mk>
diff --git a/deskutils/timewarrior/Makefile b/deskutils/timewarrior/Makefile
index 06e2af52fcf0..81b7ec87d43e 100644
--- a/deskutils/timewarrior/Makefile
+++ b/deskutils/timewarrior/Makefile
@@ -9,6 +9,6 @@ DISTNAME= timew-${PORTVERSION}
MAINTAINER= swills@FreeBSD.org
COMMENT= Track time from the command line
-USES= cmake
+USES= cmake compiler:c++11-lang
.include <bsd.port.mk>
diff --git a/devel/courier-unicode/Makefile b/devel/courier-unicode/Makefile
index 5b00ebb4d29b..967adcd56f93 100644
--- a/devel/courier-unicode/Makefile
+++ b/devel/courier-unicode/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv3
CONFLICTS= libunicode-[0-9]*
-USES= iconv libtool perl5 tar:bzip2
+USES= compiler:c++11-lang iconv libtool perl5 tar:bzip2
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/easyloggingpp/Makefile b/devel/easyloggingpp/Makefile
index 29faa279c7e7..aa0f29a33ff2 100644
--- a/devel/easyloggingpp/Makefile
+++ b/devel/easyloggingpp/Makefile
@@ -11,7 +11,7 @@ COMMENT= C++ logging library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= muflihun
USE_LDCONFIG= yes
diff --git a/devel/glibmm-reference/Makefile b/devel/glibmm-reference/Makefile
index 2a165da22a13..fd3dda924c84 100644
--- a/devel/glibmm-reference/Makefile
+++ b/devel/glibmm-reference/Makefile
@@ -7,7 +7,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/glibmm-2.4.pc:devel/glibmm \
gm4:devel/m4
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= compiler:c++11-lang gmake pkgconfig
DOCSDIR= ${PREFIX}/share/doc/glibmm-2.4
diff --git a/devel/hexd/Makefile b/devel/hexd/Makefile
index 1433617dc1df..9f80e87f69d6 100644
--- a/devel/hexd/Makefile
+++ b/devel/hexd/Makefile
@@ -11,7 +11,7 @@ COMMENT= Colourful, human-friendly hexdump tool
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake
+USES= compiler:c++11-lang gmake
USE_GITHUB= yes
GH_ACCOUNT= FireyFly
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index c324de3ad1e4..e1f04d104ec3 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -11,9 +11,7 @@ COMMENT= Asynchronous & concurrent & distributed networking framework
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to build: swoole_config.h: error GCC 4.4 or later required
-
-USES= localbase:ldflags php:pecl ssl
+USES= compiler:c11 localbase:ldflags php:pecl ssl
USE_PHP= pcre
OPTIONS_DEFINE= HTTP2 REDIS SOCKETS
diff --git a/devel/poco/Makefile b/devel/poco/Makefile
index 737ac49d4227..233c8dd4ba04 100644
--- a/devel/poco/Makefile
+++ b/devel/poco/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
CONFLICTS= poco-ssl-[0-9]*
-USES= cmake localbase pkgconfig
+USES= cmake compiler:c++11-lang localbase pkgconfig
CMAKE_ARGS= -DPOCO_UNBUNDLED:BOOL=ON
USE_LDCONFIG= yes
diff --git a/devel/py-pyicu/Makefile b/devel/py-pyicu/Makefile
index d67bec5db83c..cc91ec43c0a4 100644
--- a/devel/py-pyicu/Makefile
+++ b/devel/py-pyicu/Makefile
@@ -17,8 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libicudata.so:devel/icu
-USES= python
-USE_CXXSTD= c++11
+USES= compiler:c++11-lang python
USE_PYTHON= distutils autoplist
MAKE_ENV+= PYICU_INCLUDES="${LOCALBASE}/include" \
diff --git a/devel/pybind11/Makefile b/devel/pybind11/Makefile
index d517e831fdd8..d75d093dbf40 100644
--- a/devel/pybind11/Makefile
+++ b/devel/pybind11/Makefile
@@ -11,7 +11,7 @@ COMMENT= Seamless interoperability between C++11 and Python (cmake part)
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= pybind
NO_ARCH= yes
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 224f744aeac4..021190a8b50e 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -12,14 +12,12 @@ COMMENT= C++ wrapper for libcurl
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/doc/LICENSE
-BROKEN_powerpc64= fails to configure: error: A compiler with support for C++11 language features is required
-
LIB_DEPENDS= libcurl.so:ftp/curl
OPTIONS_DEFINE= DOCS EXAMPLES
+USES= compiler:c++11-lang cmake localbase pathfix
USE_LDCONFIG= yes
-USES= cmake localbase pathfix
PORTDOCS= *
PORTEXAMPLES= *
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index 34cfed5a4aef..45dc867b25c3 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libImlib2.so:graphics/imlib2 \
libpng.so:graphics/png
-USES= cpe desktop-file-utils gmake localbase:ldflags \
+USES= compiler:c++11-lang cpe desktop-file-utils gmake localbase:ldflags \
perl5 shebangfix tar:bzip2
SHEBANG_FILES= cam/feh-cam
USE_XORG= x11 xt xinerama
diff --git a/graphics/pixd/Makefile b/graphics/pixd/Makefile
index a15e525da974..967d95a3cce1 100644
--- a/graphics/pixd/Makefile
+++ b/graphics/pixd/Makefile
@@ -11,7 +11,7 @@ COMMENT= Visualize binary data in terminal
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake
+USES= compiler:c++11-lang gmake
USE_GITHUB= yes
GH_ACCOUNT= FireyFly
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index 2164de68f0b4..131936baac19 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
-USES= dos2unix iconv gmake pkgconfig libtool
+USES= compiler:c++11-lang dos2unix iconv gmake pkgconfig libtool
USE_GNOME= libxml2 libxslt
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index f6345ad251f9..94a8f15b1bf0 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -9,15 +9,15 @@ CATEGORIES= lang devel gnustep
MAINTAINER= theraven@FreeBSD.org
COMMENT= Replacement Objective-C runtime supporting modern Objective-C features
-SSP_UNSAFE= yes
-
-USES= cmake objc:compiler
BROKEN_powerpc= Does not compile on powerpc: Unsupported relocation type 10
BROKEN_sparc64= Does not compile on sparc64: Cannot configure clang properly
+USES= cmake compiler:c++11-lang objc:compiler
USE_GITHUB= yes
GH_ACCOUNT= gnustep
+SSP_UNSAFE= yes
+
SHLIB_MAJOR= 4
SHLIB_MINOR= 6
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index ec40cba081e1..cd0b2902f17f 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libcourier-unicode.so:devel/courier-unicode
CONFLICTS= courier-[0-9]* imap-uw-[0-9]* panda-imap-[0-9]*
-USES= gmake localbase:ldflags perl5 ssl tar:bzip2
+USES= compiler:c++11-lang gmake localbase:ldflags perl5 ssl tar:bzip2
GNU_CONFIGURE= yes
USE_RC_SUBR= courier-imap-imapd courier-imap-imapd-ssl \
courier-imap-pop3d courier-imap-pop3d-ssl
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index e1b6b8a4f863..766840238281 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -25,7 +25,10 @@ COMMENT= Mail delivery agent (MDA) with filtering abilities
LICENSE= GPLv3
-USES= iconv localbase:ldflags perl5 tar:bzip2
+LIB_DEPENDS= libpcre.so:devel/pcre \
+ libcourier-unicode.so:devel/courier-unicode
+
+USES= compiler:c++11-lang iconv localbase:ldflags perl5 tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-syslog=1 \
@@ -36,9 +39,6 @@ INSTALL_TARGET= install-strip
CONFLICTS= courier-0.65* libunicode-[0-9]*
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libcourier-unicode.so:devel/courier-unicode
-
MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
FIXDOCPATH= libs/liblock/lockmail.1 libs/maildir/deliverquota.8.in \
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index c1033f0fb8cf..9ec06fdb6b18 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -57,7 +57,7 @@ MAILGRP?= courier
#
# End of user variables
-USES= gettext gmake iconv perl5 tar:bzip2
+USES= compiler:c++11-lang gettext gmake iconv perl5 tar:bzip2
USE_RC_SUBR= sqwebmail-sqwebmaild
GNU_CONFIGURE= yes
diff --git a/math/glucose/Makefile b/math/glucose/Makefile
index eedde938b1f2..38e8f90f57d2 100644
--- a/math/glucose/Makefile
+++ b/math/glucose/Makefile
@@ -12,7 +12,7 @@ COMMENT= Parallel SAT solver based on Minisat, with glue clauses
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE
-USES= gmake tar:tgz
+USES= compiler:c++11-lang gmake tar:tgz
PLIST_FILES= bin/glucose bin/glucose-syrup
diff --git a/net/pktanon/Makefile b/net/pktanon/Makefile
index ae224ba7d3ca..ddaafa1ae2e2 100644
--- a/net/pktanon/Makefile
+++ b/net/pktanon/Makefile
@@ -13,7 +13,7 @@ COMMENT= Network trace anonymizer
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libxerces-c.so.3:textproc/xerces-c3
-USES= dos2unix
+USES= compiler:c++0x dos2unix
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
diff --git a/security/akmos/Makefile b/security/akmos/Makefile
index 118599736ed8..3b2e4147656c 100644
--- a/security/akmos/Makefile
+++ b/security/akmos/Makefile
@@ -10,7 +10,7 @@ COMMENT= Cryptographic library with low footprint
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= melanhit
diff --git a/security/trezord/Makefile b/security/trezord/Makefile
index 7976bfe123e4..62d8314ab1be 100644
--- a/security/trezord/Makefile
+++ b/security/trezord/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libjsoncpp.so:devel/jsoncpp \
libmicrohttpd.so:www/libmicrohttpd
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig
USE_RC_SUBR= ${PORTNAME}
diff --git a/sysutils/fswatch-mon/Makefile b/sysutils/fswatch-mon/Makefile
index 22e7321e670e..6a5a81652ff4 100644
--- a/sysutils/fswatch-mon/Makefile
+++ b/sysutils/fswatch-mon/Makefile
@@ -12,9 +12,7 @@ COMMENT= Cross-platform file change monitor
LICENSE= GPLv3
-BROKEN_powerpc64= fails to configure: A compiler with support for C++11 language features is required
-
-USES= libtool makeinfo
+USES= compiler:c++11-lang libtool makeinfo
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/sysutils/usbtop/Makefile b/sysutils/usbtop/Makefile
index 883b83f74b5d..00c58fc26203 100644
--- a/sysutils/usbtop/Makefile
+++ b/sysutils/usbtop/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= aguinet
diff --git a/textproc/sdcv/Makefile b/textproc/sdcv/Makefile
index 145e23e1f443..12a71ad0039c 100644
--- a/textproc/sdcv/Makefile
+++ b/textproc/sdcv/Makefile
@@ -12,7 +12,7 @@ COMMENT= Text-based utility for work with dictionaries in StarDict's format #'
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource pkgconfig readline
+USES= cmake:outsource compiler:c++11-lang pkgconfig readline
USE_GNOME= glib20
SUB_FILES= pkg-message