aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-omniauth-auth0/Makefile21
-rw-r--r--net/rubygem-omniauth-auth0/distinfo2
-rw-r--r--net/rubygem-omniauth-auth0/pkg-descr8
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 83707ac65bd5..9fc15b60bc00 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1131,6 +1131,7 @@
SUBDIR += rubygem-oauth2
SUBDIR += rubygem-octokit
SUBDIR += rubygem-octopress-deploy
+ SUBDIR += rubygem-omniauth-auth0
SUBDIR += rubygem-omniauth-azure-oauth2
SUBDIR += rubygem-omniauth-facebook
SUBDIR += rubygem-omniauth-github
diff --git a/net/rubygem-omniauth-auth0/Makefile b/net/rubygem-omniauth-auth0/Makefile
new file mode 100644
index 000000000000..27de977e7e7c
--- /dev/null
+++ b/net/rubygem-omniauth-auth0/Makefile
@@ -0,0 +1,21 @@
+# Created by: Torsten Zuehlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= omniauth-auth0
+PORTVERSION= 1.4.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ports@toco-domains.de
+COMMENT= Authentication broker supporting different identity providers
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.1:net/rubygem-omniauth-oauth2
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-auth0/distinfo b/net/rubygem-omniauth-auth0/distinfo
new file mode 100644
index 000000000000..f0027794c2e8
--- /dev/null
+++ b/net/rubygem-omniauth-auth0/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/omniauth-auth0-1.4.1.gem) = da5d6bba47bf419954241d54b5f179053c1664408456c0c96501a75002a00e36
+SIZE (rubygem/omniauth-auth0-1.4.1.gem) = 24576
diff --git a/net/rubygem-omniauth-auth0/pkg-descr b/net/rubygem-omniauth-auth0/pkg-descr
new file mode 100644
index 000000000000..abf028980c28
--- /dev/null
+++ b/net/rubygem-omniauth-auth0/pkg-descr
@@ -0,0 +1,8 @@
+Auth0 is an authentication broker that supports social identity
+providers as well as enterprise identity providers such as Active
+Directory, LDAP, Google Apps, Salesforce. OmniAuth is a library
+that standardizes multi-provider authentication for web applications.
+It was created to be powerful, flexible, and do as little as possible.
+omniauth-auth0 is the omniauth strategy for Auth0.
+
+WWW: https://github.com/auth0/omniauth-auth0