aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/cue2toc/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/cue2toc/Makefile b/audio/cue2toc/Makefile
index f9e3fe2df5ca..2cd62192f1cc 100644
--- a/audio/cue2toc/Makefile
+++ b/audio/cue2toc/Makefile
@@ -12,15 +12,16 @@ COMMENT= Perl script that converts CUE files into TOC files for cdrdao
RUN_DEPENDS= p5-Audio-Wav>=0:${PORTSDIR}/audio/p5-Audio-Wav
-USES= perl5
-NO_STAGE= yes
+USES= perl5 shebangfix
+NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/cue2toc.pl
+SHEBANG_FILES= cue2toc
pre-patch:
@${REINPLACE_CMD} -e 's|use warnings;||' ${WRKDIR}/cue2toc
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/cue2toc ${PREFIX}/bin/cue2toc.pl
+ ${INSTALL_SCRIPT} ${WRKDIR}/cue2toc ${STAGEDIR}${PREFIX}/bin/cue2toc.pl
.include <bsd.port.mk>