aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/octave/Makefile16
-rw-r--r--math/octave/distinfo6
-rw-r--r--math/octave/files/patch-configure.in15
-rw-r--r--math/octave/files/patch-scripts+pkg+pkg.m14
-rw-r--r--math/octave/files/patch-src+Makefile.in13
5 files changed, 34 insertions, 30 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 50671fca7ebc..da50130db9f1 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= octave
-PORTVERSION= 3.0.5
-PORTREVISION= 4
+PORTVERSION= 3.2.2
CATEGORIES= math
MASTER_SITES= ftp://ftp.octave.org/pub/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
@@ -25,13 +24,19 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
glpk.23:${PORTSDIR}/math/glpk \
hdf5:${PORTSDIR}/science/hdf5 \
umfpack.1:${PORTSDIR}/math/suitesparse \
- qhull:${PORTSDIR}/math/qhull
+ qhull:${PORTSDIR}/math/qhull \
+ arpack:${PORTSDIR}/math/arpack \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
+ fftw3:${PORTSDIR}/math/fftw3 \
+ ftgl:${PORTSDIR}/graphics/ftgl \
+ fltk:${PORTSDIR}/x11-toolkits/fltk \
+ GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick
USE_BZIP2= yes
USE_PERL5_BUILD=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:262 autoheader:262
+USE_AUTOTOOLS= autoconf:262
INFO= octave liboctave
MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
@@ -95,9 +100,6 @@ LIB_DEPENDS+= ptmalloc:${PORTSDIR}/devel/ptmalloc
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lptmalloc"
.endif
-pre-configure:
- @cd ${WRKSRC}/scripts ; ${AUTOCONF}
-
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/liboctave/liboctave.info ${PREFIX}/info
${MV} ${PREFIX}/bin/${PORTNAME}-${PORTVERSION} ${PREFIX}/libexec/${PORTNAME}/${PORTVERSION}/exec/${GNU_HOST}
diff --git a/math/octave/distinfo b/math/octave/distinfo
index 6f45ac41cb49..6a24d013f40d 100644
--- a/math/octave/distinfo
+++ b/math/octave/distinfo
@@ -1,3 +1,3 @@
-MD5 (octave-3.0.5.tar.bz2) = bfba44eeda8fa6e29c2bbcd2604c34eb
-SHA256 (octave-3.0.5.tar.bz2) = 40b84071d07e17eafe338638b4f1bfce991bdac07d277f1098cb7e6b0b8f4ad7
-SIZE (octave-3.0.5.tar.bz2) = 10158578
+MD5 (octave-3.2.2.tar.bz2) = 656d0d11bf9cfea7a4cee226ee63fea7
+SHA256 (octave-3.2.2.tar.bz2) = 842e5f6e633f6fe2ff5e5567dc7b4d1bc18fd5435fa5dd3362d290cc9c8df8a5
+SIZE (octave-3.2.2.tar.bz2) = 12085164
diff --git a/math/octave/files/patch-configure.in b/math/octave/files/patch-configure.in
new file mode 100644
index 000000000000..10530030c0da
--- /dev/null
+++ b/math/octave/files/patch-configure.in
@@ -0,0 +1,15 @@
+--- configure.in~ 2008-07-22 10:30:06.000000000 +0900
++++ configure.in 2008-09-22 15:04:07.000000000 +0900
+@@ -855,9 +855,10 @@
+ ### Checks for BLAS and LAPACK libraries:
+ # (Build subdirectories of libcruft if they aren't found on the system.)
+ sinclude(acx_blas.m4)
+-sinclude(acx_blas_f77_func.m4)
++#sinclude(acx_blas_f77_func.m4)
+ sinclude(acx_lapack.m4)
+-ACX_BLAS_WITH_F77_FUNC([], [BLAS_DIR="blas"])
++ACX_BLAS([], [BLAS_DIR="blas"])
++#ACX_BLAS_WITH_F77_FUNC([], [BLAS_DIR="blas"])
+ ACX_LAPACK([BLAS_LIBS="$LAPACK_LIBS $BLAS_LIBS"], [LAPACK_DIR="lapack"])
+ AC_SUBST(BLAS_DIR)
+ AC_SUBST(LAPACK_DIR)
diff --git a/math/octave/files/patch-scripts+pkg+pkg.m b/math/octave/files/patch-scripts+pkg+pkg.m
index 1e46e7eab91d..ec414d29ebf6 100644
--- a/math/octave/files/patch-scripts+pkg+pkg.m
+++ b/math/octave/files/patch-scripts+pkg+pkg.m
@@ -1,11 +1,11 @@
---- scripts/pkg/pkg.m~ 2009-04-09 17:26:54.000000000 +0900
-+++ scripts/pkg/pkg.m 2009-04-09 17:27:14.000000000 +0900
-@@ -1242,7 +1242,7 @@
- ## make
+--- scripts/pkg/pkg.m~ 2009-07-27 18:31:53.000000000 +0900
++++ scripts/pkg/pkg.m 2009-07-27 18:32:52.000000000 +0900
+@@ -1247,7 +1247,7 @@
+ ## Make.
if (exist (fullfile (src, "Makefile"), "file"))
- [status, output] = shell (strcat ("export INSTALLDIR=\"", desc.dir,
-- "\"; make -C '", src, "'"));
-+ "\"; gmake -C '", src, "'"));
+ [status, output] = shell (cstrcat ("export INSTALLDIR=\"", desc.dir,
+- "\"; make -C '", src, "'"));
++ "\"; gmake -C '", src, "'"));
if (status != 0)
rm_rf (desc.dir);
error ("'make' returned the following error: %s", output);
diff --git a/math/octave/files/patch-src+Makefile.in b/math/octave/files/patch-src+Makefile.in
deleted file mode 100644
index 5da6b5d58a88..000000000000
--- a/math/octave/files/patch-src+Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-for gendoc part, http://gcc.gnu.org/bugzilla/show_bug.cgi?id=30423
-
---- src/Makefile.in.orig Sat Sep 30 03:20:15 2006
-+++ src/Makefile.in Wed Jan 10 19:26:54 2007
-@@ -313,7 +313,7 @@
- $(OCTAVE_LIBS) \
- $(LEXLIB) $(UMFPACK_LIBS) $(AMD_LIBS) $(COLAMD_LIBS) \
- $(CHOLMOD_LIBS) $(CCOLAMD_LIBS) $(CXSPARSE_LIBS) $(BLAS_LIBS) \
-- $(FFTW_LIBS) $(LIBS) $(FLIBS)
-+ $(FFTW_LIBS) $(LIBS) $(FLIBS) -lcamd
-
- stmp-pic: pic
- @if [ -f stmp-pic ]; then \