aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/flow-tools/Makefile12
-rw-r--r--net-mgmt/flow-tools/distinfo6
-rw-r--r--net-mgmt/flow-tools/files/patch-lib_ftxlate.c39
-rw-r--r--net-mgmt/flow-tools/files/patch-src_acl2.c11
-rw-r--r--net-mgmt/flow-tools/pkg-plist22
5 files changed, 22 insertions, 68 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 6aa41eead6ea..4c4e44a328cd 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= flow-tools
PORTVERSION= 0.68.6
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt
MAINTAINER= bofh@FreeBSD.org
@@ -13,15 +13,13 @@ COMMENT= Suite of tools and library to work with netflow data
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= docbook-to-man:textproc/docbook-to-man
-
USES= autoreconf libtool:keepla python:patch shebangfix
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_RC_SUBR= flow_capture flow_fanout
GH_ACCOUNT= 5u623l20
-GH_TAGNAME= 6e7c849
+GH_TAGNAME= 2ca53f5
SHEBANG_FILES= bin/flow-*
GNU_CONFIGURE= yes
@@ -59,4 +57,10 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libft.so.0.0.0
+post-stage:
+.for f in asn.sym filter.cfg ip-prot.sym ip-type.sym map.cfg mask.cfg stat.cfg \
+ tag.cfg tag.sym tcp-port.sym xlate.cfg
+ @${MV} ${STAGEDIR}${ETCDIR}/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
+.endfor
+
.include <bsd.port.post.mk>
diff --git a/net-mgmt/flow-tools/distinfo b/net-mgmt/flow-tools/distinfo
index e1003a454a94..9dd57fca5bd4 100644
--- a/net-mgmt/flow-tools/distinfo
+++ b/net-mgmt/flow-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553203482
-SHA256 (5u623l20-flow-tools-v0.68.6-6e7c849_GH0.tar.gz) = cea67317e205d1f52f9b8aeb980a1cda9ebbbb1886489fc4d56a61f948ecd72e
-SIZE (5u623l20-flow-tools-v0.68.6-6e7c849_GH0.tar.gz) = 1078840
+TIMESTAMP = 1613085161
+SHA256 (5u623l20-flow-tools-v0.68.6-2ca53f5_GH0.tar.gz) = db9e92d234911e4ad32744614ea75454601bfe0e7ebced6cdc17c395c36e01fb
+SIZE (5u623l20-flow-tools-v0.68.6-2ca53f5_GH0.tar.gz) = 1092146
diff --git a/net-mgmt/flow-tools/files/patch-lib_ftxlate.c b/net-mgmt/flow-tools/files/patch-lib_ftxlate.c
deleted file mode 100644
index 86d171e79347..000000000000
--- a/net-mgmt/flow-tools/files/patch-lib_ftxlate.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- lib/ftxlate.c.orig 2019-03-21 19:39:03 UTC
-+++ lib/ftxlate.c
-@@ -2040,21 +2040,21 @@ static int cryptopan_init(struct cryptopan *cp, unsign
-
-
- /* init crypto */
-- if (!(cp->cipher_ctx = (EVP_CIPHER_CTX*) malloc(sizeof(EVP_CIPHER_CTX)))) {
-+ cp->cipher_ctx = EVP_CIPHER_CTX_new();
-+ if (cp->cipher_ctx == NULL)
- return -1;
-- }
-
-- EVP_CIPHER_CTX_init(cp->cipher_ctx);
--
- /* disable padding */
- if (!(EVP_CIPHER_CTX_set_padding(cp->cipher_ctx, 0))) {
- cryptopan_free(cp);
-+ EVP_CIPHER_CTX_free(cp->cipher_ctx);
- return -1;
- }
-
- /* init encryption */
- if (!(EVP_EncryptInit(cp->cipher_ctx, EVP_aes_128_ecb(), key, NULL))) {
- cryptopan_free(cp);
-+ EVP_CIPHER_CTX_free(cp->cipher_ctx);
- return -1;
- }
-
-@@ -2062,8 +2062,10 @@ static int cryptopan_init(struct cryptopan *cp, unsign
- i = 16;
- if (!(EVP_EncryptUpdate(cp->cipher_ctx, cp->m_pad, &i, key+16, i))) {
- cryptopan_free(cp);
-+ EVP_CIPHER_CTX_free(cp->cipher_ctx);
- return -1;
- }
-+ EVP_CIPHER_CTX_free(cp->cipher_ctx);
-
- #endif /* HAVE_OPENSSL */
-
diff --git a/net-mgmt/flow-tools/files/patch-src_acl2.c b/net-mgmt/flow-tools/files/patch-src_acl2.c
deleted file mode 100644
index 4a988108617a..000000000000
--- a/net-mgmt/flow-tools/files/patch-src_acl2.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/acl2.c.orig 2020-08-29 06:28:09 UTC
-+++ src/acl2.c
-@@ -46,7 +46,7 @@
-
- #include "acl2.h"
-
--struct acl_list acl_list;
-+// struct acl_list acl_list;
-
- #define E acl_list.acl_ip_ext[index]
-
diff --git a/net-mgmt/flow-tools/pkg-plist b/net-mgmt/flow-tools/pkg-plist
index 604b8c42c83e..23af8c21daee 100644
--- a/net-mgmt/flow-tools/pkg-plist
+++ b/net-mgmt/flow-tools/pkg-plist
@@ -22,17 +22,17 @@ bin/flow-split
bin/flow-stat
bin/flow-tag
bin/flow-xlate
-%%ETCDIR%%/asn.sym
-%%ETCDIR%%/filter.cfg
-%%ETCDIR%%/ip-prot.sym
-%%ETCDIR%%/ip-type.sym
-%%ETCDIR%%/map.cfg
-%%ETCDIR%%/mask.cfg
-%%ETCDIR%%/stat.cfg
-%%ETCDIR%%/tag.cfg
-%%ETCDIR%%/tag.sym
-%%ETCDIR%%/tcp-port.sym
-%%ETCDIR%%/xlate.cfg
+@sample %%ETCDIR%%/asn.sym.sample
+@sample %%ETCDIR%%/filter.cfg.sample
+@sample %%ETCDIR%%/ip-prot.sym.sample
+@sample %%ETCDIR%%/ip-type.sym.sample
+@sample %%ETCDIR%%/map.cfg.sample
+@sample %%ETCDIR%%/mask.cfg.sample
+@sample %%ETCDIR%%/stat.cfg.sample
+@sample %%ETCDIR%%/tag.cfg.sample
+@sample %%ETCDIR%%/tag.sym.sample
+@sample %%ETCDIR%%/tcp-port.sym.sample
+@sample %%ETCDIR%%/xlate.cfg.sample
include/ftlib.h
include/ftqueue.h
lib/libft.a