aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/seed7/distinfo6
-rw-r--r--lang/seed7/files/patch-fwd__x11.c23
3 files changed, 4 insertions, 27 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 1d49c0a1e524..1b5b3961dd2e 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -1,7 +1,7 @@
# Created by: gahr
PORTNAME= seed7
-DISTVERSION= 05_20220130
+DISTVERSION= 05_20220312
PORTREVISION= 0
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index bd9b48620c95..6649070dbe99 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1646141399
-SHA256 (seed7_05_20220130.tgz) = 442dddbf979a5af8784bf8155cd70937f277f10949ce0dec9ebea4d5c1e7f10e
-SIZE (seed7_05_20220130.tgz) = 3712052
+TIMESTAMP = 1648553811
+SHA256 (seed7_05_20220312.tgz) = c0f9507a11b5ae2b261d14c839f1d0289cb33672aea13735b944c94596830760
+SIZE (seed7_05_20220312.tgz) = 3726447
diff --git a/lang/seed7/files/patch-fwd__x11.c b/lang/seed7/files/patch-fwd__x11.c
deleted file mode 100644
index da8e744abbfb..000000000000
--- a/lang/seed7/files/patch-fwd__x11.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- fwd_x11.c.orig 2022-03-01 13:41:18 UTC
-+++ fwd_x11.c
-@@ -398,7 +398,7 @@ static boolType setupX11Dll (const char *dllName)
- (ptr_XSetClipOrigin = (tp_XSetClipOrigin) dllFunc(x11Dll, "XSetClipOrigin")) == NULL ||
- (ptr_XSetForeground = (tp_XSetForeground) dllFunc(x11Dll, "XSetForeground")) == NULL ||
- (ptr_XSetFunction = (tp_XSetFunction) dllFunc(x11Dll, "XSetFunction")) == NULL ||
-- (ptr_XSetLineAttributes = (tp_XSetLineAttributes dllFunc(x11Dll, "XSetLineAttributes")) == NULL ||
-+ (ptr_XSetLineAttributes = (tp_XSetLineAttributes) dllFunc(x11Dll, "XSetLineAttributes")) == NULL ||
- (ptr_XSetStandardProperties = (tp_XSetStandardProperties) dllFunc(x11Dll, "XSetStandardProperties")) == NULL ||
- (ptr_XSetWMHints = (tp_XSetWMHints) dllFunc(x11Dll, "XSetWMHints")) == NULL ||
- (ptr_XSetWMProtocols = (tp_XSetWMProtocols) dllFunc(x11Dll, "XSetWMProtocols")) == NULL ||
-@@ -1609,9 +1609,9 @@ int XSetLineAttributes (Display *display, GC gc, unsig
- logFunction(printf("XSetLineAttributes(" FMT_U_MEM ", " FMT_U_MEM
- ", %u, %d, &d, %d)\n",
- (memSizeType) display, (memSizeType) gc,
-- line_width, line_style, cap_stype, join_style););
-+ line_width, line_style, cap_style, join_style););
- funcResult = ptr_XSetLineAttributes(display, gc, line_width,
-- line_style, cap_stype, join_style);
-+ line_style, cap_style, join_style);
- logFunction(printf("XSetLineAttributes --> %d\n", funcResult););
- return funcResult;
- } /* XSetLineAttributes */