aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/linuxdoc-tools/Makefile42
-rw-r--r--textproc/linuxdoc-tools/distinfo2
-rw-r--r--textproc/linuxdoc-tools/files/patch-Makefile.in36
-rw-r--r--textproc/linuxdoc-tools/files/patch-rtf-fix_rtf2rtf.l11
-rw-r--r--textproc/linuxdoc-tools/pkg-descr5
-rw-r--r--textproc/linuxdoc-tools/pkg-plist166
7 files changed, 263 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 80e085506a92..6e3a60c8071e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -438,6 +438,7 @@
SUBDIR += linux-f10-scim-gtk
SUBDIR += linux-f10-scim-libs
SUBDIR += linuxdoc
+ SUBDIR += linuxdoc-tools
SUBDIR += localize
SUBDIR += loook
SUBDIR += lt-aspell
diff --git a/textproc/linuxdoc-tools/Makefile b/textproc/linuxdoc-tools/Makefile
new file mode 100644
index 000000000000..c2e6a710aefc
--- /dev/null
+++ b/textproc/linuxdoc-tools/Makefile
@@ -0,0 +1,42 @@
+# Created by: Felix Palmen <felix@palmen-it.de>
+# $FreeBSD$
+
+PORTNAME= linuxdoc-tools
+PORTVERSION= 0.9.69
+CATEGORIES= textproc
+MASTER_SITES= DEBIAN
+DISTNAME= ${PORTNAME}_${DISTVERSION}.orig
+
+MAINTAINER= felix@palmen-it.de
+COMMENT= Fork of SGML-tools specially tailored for linuxdoc SGMLs
+
+LICENSE= GPLv3 LinuxdocTools
+LICENSE_COMB= multi
+LICENSE_NAME_LinuxdocTools= The linuxdoc-tools license
+LICENSE_FILE_LinuxdocTools= ${WRKSRC}/COPYING
+LICENSE_PERMS_LinuxdocTools= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
+ nsgmls:${PORTSDIR}/textproc/jade \
+ sgmlsasp:${PORTSDIR}/textproc/sgmls
+RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
+ nsgmls:${PORTSDIR}/textproc/jade \
+ sgmlsasp:${PORTSDIR}/textproc/sgmls
+
+GNU_CONFIGURE= yes
+USES= gmake perl5
+CONFIGURE_ARGS= --with-installed-sgmlsasp
+
+PORTDOCS= *
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+DOCS_MAKE_ENV= LANG=C BUILD_DOCS=true
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^(CC|CFLAGS)/ s|=|?=|' \
+ ${WRKSRC}/rtf-fix/Makefile
+
+.include <bsd.port.mk>
diff --git a/textproc/linuxdoc-tools/distinfo b/textproc/linuxdoc-tools/distinfo
new file mode 100644
index 000000000000..d96a3390eb06
--- /dev/null
+++ b/textproc/linuxdoc-tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (linuxdoc-tools_0.9.69.orig.tar.gz) = 7103facee18a2ea97186ca459d743d22f7f89ad4b5cd1dfd1c34f83d6bfd4101
+SIZE (linuxdoc-tools_0.9.69.orig.tar.gz) = 604379
diff --git a/textproc/linuxdoc-tools/files/patch-Makefile.in b/textproc/linuxdoc-tools/files/patch-Makefile.in
new file mode 100644
index 000000000000..6ea7e14ff9d3
--- /dev/null
+++ b/textproc/linuxdoc-tools/files/patch-Makefile.in
@@ -0,0 +1,36 @@
+--- Makefile.in.orig 2013-04-08 17:11:41 UTC
++++ Makefile.in
+@@ -47,7 +47,7 @@ INCLUDE =
+ OPTIMIZE = -O
+ DEBUG =
+ WARN =
+-CFLAGS = $(DEBUG) $(INCLUDE) $(WARN) $(PROFILE) $(OPTIMIZE)
++CFLAGS += $(DEBUG) $(INCLUDE) $(WARN) $(PROFILE)
+ LDFLAGS = $(DEBUG) $(PROFILE)
+
+ all:
+@@ -113,7 +113,7 @@ ifeq ($(BUILD_ISO_ENTITIES), true)
+ endif
+
+ # -- Install linuxdoc script
+- $(INSTALL_PROGRAM) bin/linuxdoc $(bin_ddir)/linuxdoc
++ $(INSTALL) -m755 bin/linuxdoc $(bin_ddir)/linuxdoc
+
+ # -- Install auxiliary programs
+ mkdir -p $(auxbin_ddir)
+@@ -162,6 +162,7 @@ endif
+ $(INSTALL_DATA) tex/* $(tex_ddir)
+
+ # -- Build and install documentation
++ifeq ($(BUILD_DOCS), true)
+ @echo "Installing documentation in $(doc_ddir) ..."
+ (cd doc; \
+ PATH=${PATH}:$(bin_ddir) \
+@@ -177,6 +178,7 @@ endif
+ rm -f $(doc_ddir)/Makedoc.sh
+ find $(doc_ddir) -type d -print | xargs chmod 755
+ find $(doc_ddir) -type f -print | xargs chmod 644
++endif
+
+ # what dirs do the targets clean and distclean need?
+ DDIRS=
diff --git a/textproc/linuxdoc-tools/files/patch-rtf-fix_rtf2rtf.l b/textproc/linuxdoc-tools/files/patch-rtf-fix_rtf2rtf.l
new file mode 100644
index 000000000000..15c12ccb31e3
--- /dev/null
+++ b/textproc/linuxdoc-tools/files/patch-rtf-fix_rtf2rtf.l
@@ -0,0 +1,11 @@
+--- rtf-fix/rtf2rtf.l.orig 2013-04-08 17:11:41 UTC
++++ rtf-fix/rtf2rtf.l
+@@ -22,7 +22,7 @@
+
+ %{
+
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+
diff --git a/textproc/linuxdoc-tools/pkg-descr b/textproc/linuxdoc-tools/pkg-descr
new file mode 100644
index 000000000000..64a57b0b948e
--- /dev/null
+++ b/textproc/linuxdoc-tools/pkg-descr
@@ -0,0 +1,5 @@
+Linuxdoc-Tools is a fork of SGML-Tools 1.0.9, capable of processing
+LinuxDoc DTD SGML files. Such files are sometimes used as an input
+format for generated documentation.
+
+WWW: https://tracker.debian.org/pkg/linuxdoc-tools
diff --git a/textproc/linuxdoc-tools/pkg-plist b/textproc/linuxdoc-tools/pkg-plist
new file mode 100644
index 000000000000..d04c4d5a22d4
--- /dev/null
+++ b/textproc/linuxdoc-tools/pkg-plist
@@ -0,0 +1,166 @@
+bin/linuxdoc
+bin/rtf2rtf
+bin/sgml2html
+bin/sgml2info
+bin/sgml2latex
+bin/sgml2lyx
+bin/sgml2rtf
+bin/sgml2txt
+bin/sgmlcheck
+bin/sgmlpre
+man/man1/linuxdoc.1.gz
+man/man1/rtf2rtf.1.gz
+man/man1/sgml2html.1.gz
+man/man1/sgml2info.1.gz
+man/man1/sgml2latex.1.gz
+man/man1/sgml2lyx.1.gz
+man/man1/sgml2rtf.1.gz
+man/man1/sgml2txt.1.gz
+man/man1/sgmlcheck.1.gz
+man/man1/sgmlpre.1.gz
+share/entity-map/0.1.0/GFextra.2ab
+share/entity-map/0.1.0/GFextra.2as
+share/entity-map/0.1.0/GFextra.2l1b
+share/entity-map/0.1.0/GFextra.2l1s
+share/entity-map/0.1.0/GFextra.2rtf
+share/entity-map/0.1.0/GFextra.2tex
+share/entity-map/0.1.0/GFextra.2texi
+share/entity-map/0.1.0/ISOdia
+share/entity-map/0.1.0/ISOdia.2ab
+share/entity-map/0.1.0/ISOdia.2as
+share/entity-map/0.1.0/ISOdia.2html
+share/entity-map/0.1.0/ISOdia.2l1b
+share/entity-map/0.1.0/ISOdia.2l1s
+share/entity-map/0.1.0/ISOdia.2l1tr
+share/entity-map/0.1.0/ISOdia.2rtf
+share/entity-map/0.1.0/ISOdia.2tex
+share/entity-map/0.1.0/ISOdia.2texi
+share/entity-map/0.1.0/ISOdia.2tr
+share/entity-map/0.1.0/ISOlat1
+share/entity-map/0.1.0/ISOlat1.2ab
+share/entity-map/0.1.0/ISOlat1.2as
+share/entity-map/0.1.0/ISOlat1.2html
+share/entity-map/0.1.0/ISOlat1.2l1b
+share/entity-map/0.1.0/ISOlat1.2l1s
+share/entity-map/0.1.0/ISOlat1.2l1tr
+share/entity-map/0.1.0/ISOlat1.2rtf
+share/entity-map/0.1.0/ISOlat1.2tex
+share/entity-map/0.1.0/ISOlat1.2texi
+share/entity-map/0.1.0/ISOlat1.2tr
+share/entity-map/0.1.0/ISOlat2
+share/entity-map/0.1.0/ISOlat2.2ab
+share/entity-map/0.1.0/ISOlat2.2as
+share/entity-map/0.1.0/ISOlat2.2l1b
+share/entity-map/0.1.0/ISOlat2.2l1s
+share/entity-map/0.1.0/ISOlat2.2rtf
+share/entity-map/0.1.0/ISOlat2.2tex
+share/entity-map/0.1.0/ISOlat2.2texi
+share/entity-map/0.1.0/ISOnum
+share/entity-map/0.1.0/ISOnum.2ab
+share/entity-map/0.1.0/ISOnum.2as
+share/entity-map/0.1.0/ISOnum.2html
+share/entity-map/0.1.0/ISOnum.2l1b
+share/entity-map/0.1.0/ISOnum.2l1s
+share/entity-map/0.1.0/ISOnum.2l1tr
+share/entity-map/0.1.0/ISOnum.2rtf
+share/entity-map/0.1.0/ISOnum.2tex
+share/entity-map/0.1.0/ISOnum.2texi
+share/entity-map/0.1.0/ISOnum.2tr
+share/entity-map/0.1.0/ISOpub
+share/entity-map/0.1.0/ISOpub.2ab
+share/entity-map/0.1.0/ISOpub.2as
+share/entity-map/0.1.0/ISOpub.2html
+share/entity-map/0.1.0/ISOpub.2l1b
+share/entity-map/0.1.0/ISOpub.2l1s
+share/entity-map/0.1.0/ISOpub.2l1tr
+share/entity-map/0.1.0/ISOpub.2rtf
+share/entity-map/0.1.0/ISOpub.2tex
+share/entity-map/0.1.0/ISOpub.2texi
+share/entity-map/0.1.0/ISOpub.2tr
+share/entity-map/0.1.0/ISOtech
+share/entity-map/0.1.0/ISOtech.2ab
+share/entity-map/0.1.0/ISOtech.2as
+share/entity-map/0.1.0/ISOtech.2html
+share/entity-map/0.1.0/ISOtech.2l1b
+share/entity-map/0.1.0/ISOtech.2l1s
+share/entity-map/0.1.0/ISOtech.2l1tr
+share/entity-map/0.1.0/ISOtech.2rtf
+share/entity-map/0.1.0/ISOtech.2tex
+share/entity-map/0.1.0/ISOtech.2texi
+share/entity-map/0.1.0/ISOtech.2tr
+share/entity-map/0.1.0/LDextra.2html
+share/entity-map/0.1.0/LDextra.2l1tr
+share/entity-map/0.1.0/LDextra.2tex
+share/entity-map/0.1.0/LDextra.2tr
+share/entity-map/0.1.0/greek.2html
+share/entity-map/0.1.0/lat1.2sdata
+%%DATADIR%%/LinuxDocTools.pm
+%%DATADIR%%/LinuxDocTools/BackEnd.pm
+%%DATADIR%%/LinuxDocTools/CharEnts.pm
+%%DATADIR%%/LinuxDocTools/FixRef.pm
+%%DATADIR%%/LinuxDocTools/Html2Html.pm
+%%DATADIR%%/LinuxDocTools/InfoUtils.pm
+%%DATADIR%%/LinuxDocTools/Lang.pm
+%%DATADIR%%/LinuxDocTools/Utils.pm
+%%DATADIR%%/LinuxDocTools/Vars.pm
+%%DATADIR%%/Text/EntityMap.pm
+%%DATADIR%%/VERSION
+%%DATADIR%%/dtd/common
+%%DATADIR%%/dtd/deprec96
+%%DATADIR%%/dtd/html32.dtd
+%%DATADIR%%/dtd/isoent
+%%DATADIR%%/dtd/linuxdoc.dtd
+%%DATADIR%%/dtd/linuxdoc96.dtd
+%%DATADIR%%/dtd/linuxdoc97.dtd
+%%DATADIR%%/dtd/linuxdoctr.dtd
+%%DATADIR%%/dtd/linuxdoctr96.dtd
+%%DATADIR%%/dtd/qwertz.dtd
+%%DATADIR%%/filters/lyx-preNSGMLS.pl
+%%DATADIR%%/fmt/fmt_html.pl
+%%DATADIR%%/fmt/fmt_info.pl
+%%DATADIR%%/fmt/fmt_latex2e.pl
+%%DATADIR%%/fmt/fmt_lyx.pl
+%%DATADIR%%/fmt/fmt_rtf.pl
+%%DATADIR%%/fmt/fmt_txt.pl
+%%DATADIR%%/icons/next.gif
+%%DATADIR%%/icons/prev.gif
+%%DATADIR%%/icons/toc.gif
+%%DATADIR%%/linuxdoc-sgml.sty
+%%DATADIR%%/linuxdoc-tools.catalog
+%%DATADIR%%/linuxdoctr-sgml.sty
+%%DATADIR%%/mappings/groff/mapping
+%%DATADIR%%/mappings/groff/math.README
+%%DATADIR%%/mappings/groff/tr-mapping
+%%DATADIR%%/mappings/html/mapping
+%%DATADIR%%/mappings/info/mapping
+%%DATADIR%%/mappings/latex2e/mapping
+%%DATADIR%%/mappings/latin1/README
+%%DATADIR%%/mappings/latin1/mapping
+%%DATADIR%%/mappings/lyx/mapping
+%%DATADIR%%/mappings/man/mapping
+%%DATADIR%%/mappings/nippon/README
+%%DATADIR%%/mappings/nippon/mapping
+%%DATADIR%%/mappings/rtf/mapping
+%%DATADIR%%/null.sty
+%%DATADIR%%/qwertz.sty
+%%DATADIR%%/sgml.dcl
+share/sgml/iso-entities-8879.1986/ISOamsa
+share/sgml/iso-entities-8879.1986/ISOamsb
+share/sgml/iso-entities-8879.1986/ISOamsc
+share/sgml/iso-entities-8879.1986/ISOamsn
+share/sgml/iso-entities-8879.1986/ISOamso
+share/sgml/iso-entities-8879.1986/ISOamsr
+share/sgml/iso-entities-8879.1986/ISObox
+share/sgml/iso-entities-8879.1986/ISOcyr1
+share/sgml/iso-entities-8879.1986/ISOcyr2
+share/sgml/iso-entities-8879.1986/ISOdia
+share/sgml/iso-entities-8879.1986/ISOgrk1
+share/sgml/iso-entities-8879.1986/ISOgrk2
+share/sgml/iso-entities-8879.1986/ISOgrk3
+share/sgml/iso-entities-8879.1986/ISOgrk4
+share/sgml/iso-entities-8879.1986/ISOlat1
+share/sgml/iso-entities-8879.1986/ISOlat2
+share/sgml/iso-entities-8879.1986/ISOnum
+share/sgml/iso-entities-8879.1986/ISOpub
+share/sgml/iso-entities-8879.1986/ISOtech
+share/sgml/iso-entities-8879.1986/iso-entities.cat