aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/olive/Makefile23
-rw-r--r--multimedia/olive/distinfo3
-rw-r--r--multimedia/olive/pkg-descr4
-rw-r--r--multimedia/olive/pkg-plist82
5 files changed, 113 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 582026727c63..091b3a4c7463 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -291,6 +291,7 @@
SUBDIR += oggvideotools
SUBDIR += ogmrip
SUBDIR += ogmtools
+ SUBDIR += olive
SUBDIR += omxplayer
SUBDIR += openh264
SUBDIR += openshot
diff --git a/multimedia/olive/Makefile b/multimedia/olive/Makefile
new file mode 100644
index 000000000000..3afa906163a1
--- /dev/null
+++ b/multimedia/olive/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= olive
+PORTVERSION= g20190414
+CATEGORIES= multimedia
+PKGNAMESUFFIX= -video-editor
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= NLE (nonlinear) video editor
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+
+USES= cmake compiler:c++11-lang desktop-file-utils gl qt:5 shared-mime-info
+USE_GITHUB= yes
+GH_ACCOUNT= olive-editor
+GH_TAGNAME= continuous
+USE_QT= core gui multimedia network opengl svg widgets qmake_build buildtools_build linguisttools_build
+USE_GL= gl
+
+.include <bsd.port.mk>
diff --git a/multimedia/olive/distinfo b/multimedia/olive/distinfo
new file mode 100644
index 000000000000..c1ade404c4f7
--- /dev/null
+++ b/multimedia/olive/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555295763
+SHA256 (olive-editor-olive-g20190414-continuous_GH0.tar.gz) = e336b105f1f3deca591078f2b891b0e6c10a506940b6c92975c31da7e91842a2
+SIZE (olive-editor-olive-g20190414-continuous_GH0.tar.gz) = 1931825
diff --git a/multimedia/olive/pkg-descr b/multimedia/olive/pkg-descr
new file mode 100644
index 000000000000..2dd96a5f6d60
--- /dev/null
+++ b/multimedia/olive/pkg-descr
@@ -0,0 +1,4 @@
+Olive is a free non-linear video editor aiming to provide a fully-featured
+alternative to high-end professional video editing software.
+
+WWW: https://www.olivevideoeditor.org/
diff --git a/multimedia/olive/pkg-plist b/multimedia/olive/pkg-plist
new file mode 100644
index 000000000000..fb6f7b9d64de
--- /dev/null
+++ b/multimedia/olive/pkg-plist
@@ -0,0 +1,82 @@
+bin/olive-editor
+share/applications/org.olivevideoeditor.Olive.desktop
+share/icons/hicolor/128x128/apps/org.olivevideoeditor.Olive.png
+share/icons/hicolor/16x16/apps/org.olivevideoeditor.Olive.png
+share/icons/hicolor/256x256/apps/org.olivevideoeditor.Olive.png
+share/icons/hicolor/32x32/apps/org.olivevideoeditor.Olive.png
+share/icons/hicolor/48x48/apps/org.olivevideoeditor.Olive.png
+share/icons/hicolor/512x512/apps/org.olivevideoeditor.Olive.png
+share/icons/hicolor/64x64/apps/org.olivevideoeditor.Olive.png
+share/metainfo/org.olivevideoeditor.Olive.appdata.xml
+share/mime/packages/org.olivevideoeditor.Olive.xml
+%%DATADIR%%-editor/effects/boxblur.frag
+%%DATADIR%%-editor/effects/boxblur.xml
+%%DATADIR%%-editor/effects/bulge.frag
+%%DATADIR%%-editor/effects/bulge.xml
+%%DATADIR%%-editor/effects/chromakey.frag
+%%DATADIR%%-editor/effects/chromakey.xml
+%%DATADIR%%-editor/effects/chromaticaberration.frag
+%%DATADIR%%-editor/effects/chromaticaberration.xml
+%%DATADIR%%-editor/effects/colorcorrection.frag
+%%DATADIR%%-editor/effects/colorcorrection.xml
+%%DATADIR%%-editor/effects/colorsel.frag
+%%DATADIR%%-editor/effects/colorsel.xml
+%%DATADIR%%-editor/effects/common.frag
+%%DATADIR%%-editor/effects/common.vert
+%%DATADIR%%-editor/effects/crop.frag
+%%DATADIR%%-editor/effects/crop.xml
+%%DATADIR%%-editor/effects/crossstitch.frag
+%%DATADIR%%-editor/effects/crossstitch.xml
+%%DATADIR%%-editor/effects/directionalblur.frag
+%%DATADIR%%-editor/effects/directionalblur.xml
+%%DATADIR%%-editor/effects/dropshadow.xml.disabled
+%%DATADIR%%-editor/effects/emboss.frag
+%%DATADIR%%-editor/effects/emboss.xml
+%%DATADIR%%-editor/effects/findedges.frag
+%%DATADIR%%-editor/effects/findedges.xml.disabled
+%%DATADIR%%-editor/effects/fisheye.frag
+%%DATADIR%%-editor/effects/fisheye.xml
+%%DATADIR%%-editor/effects/flip.frag
+%%DATADIR%%-editor/effects/flip.xml
+%%DATADIR%%-editor/effects/gaussianblur.frag
+%%DATADIR%%-editor/effects/gaussianblur.xml
+%%DATADIR%%-editor/effects/huesatbri.frag
+%%DATADIR%%-editor/effects/huesatbri.xml
+%%DATADIR%%-editor/effects/invert.frag
+%%DATADIR%%-editor/effects/invert.xml
+%%DATADIR%%-editor/effects/lumakey.frag
+%%DATADIR%%-editor/effects/lumakey.xml
+%%DATADIR%%-editor/effects/noise.frag
+%%DATADIR%%-editor/effects/noise.xml
+%%DATADIR%%-editor/effects/pixelate.frag
+%%DATADIR%%-editor/effects/pixelate.xml
+%%DATADIR%%-editor/effects/posterize.frag
+%%DATADIR%%-editor/effects/posterize.xml
+%%DATADIR%%-editor/effects/radialblur.frag
+%%DATADIR%%-editor/effects/radialblur.xml
+%%DATADIR%%-editor/effects/ripple.frag
+%%DATADIR%%-editor/effects/ripple.xml
+%%DATADIR%%-editor/effects/sphere.frag
+%%DATADIR%%-editor/effects/sphere.xml
+%%DATADIR%%-editor/effects/swirl.frag
+%%DATADIR%%-editor/effects/swirl.xml
+%%DATADIR%%-editor/effects/tile.frag
+%%DATADIR%%-editor/effects/tile.xml
+%%DATADIR%%-editor/effects/toonify.frag
+%%DATADIR%%-editor/effects/toonify.xml
+%%DATADIR%%-editor/effects/vignette.frag
+%%DATADIR%%-editor/effects/vignette.xml
+%%DATADIR%%-editor/effects/volumetriclight.frag
+%%DATADIR%%-editor/effects/volumetriclight.xml
+%%DATADIR%%-editor/effects/wave.frag
+%%DATADIR%%-editor/effects/wave.xml
+%%DATADIR%%-editor/ts/olive_ar.qm
+%%DATADIR%%-editor/ts/olive_bs.qm
+%%DATADIR%%-editor/ts/olive_cs.qm
+%%DATADIR%%-editor/ts/olive_de.qm
+%%DATADIR%%-editor/ts/olive_es.qm
+%%DATADIR%%-editor/ts/olive_fr.qm
+%%DATADIR%%-editor/ts/olive_id.qm
+%%DATADIR%%-editor/ts/olive_it.qm
+%%DATADIR%%-editor/ts/olive_ru.qm
+%%DATADIR%%-editor/ts/olive_sr.qm