aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-Forecast/Makefile23
-rw-r--r--math/p5-Statistics-Forecast/distinfo3
-rw-r--r--math/p5-Statistics-Forecast/pkg-descr4
-rw-r--r--math/p5-Statistics-Forecast/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bfbc6f8f177b..780e1982bacf 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -254,6 +254,7 @@
SUBDIR += p5-Statistics-Descriptive
SUBDIR += p5-Statistics-Descriptive-Discrete
SUBDIR += p5-Statistics-Distributions
+ SUBDIR += p5-Statistics-Forecast
SUBDIR += p5-Statistics-LTU
SUBDIR += p5-Statistics-LineFit
SUBDIR += p5-Statistics-Lite
diff --git a/math/p5-Statistics-Forecast/Makefile b/math/p5-Statistics-Forecast/Makefile
new file mode 100644
index 000000000000..832844519aae
--- /dev/null
+++ b/math/p5-Statistics-Forecast/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Statistics-Forecast
+# Date created: 2006/12/23
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Forecast
+PORTVERSION= 0.2
+CATEGORIES= math
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Calculates a future value
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
+
+MAN3= Statistics::Forecast.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Forecast/distinfo b/math/p5-Statistics-Forecast/distinfo
new file mode 100644
index 000000000000..0cfe53a94fa5
--- /dev/null
+++ b/math/p5-Statistics-Forecast/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-Forecast-0.2.tar.gz) = 4b3901e1595014963bb0df067faceb1e
+SHA256 (Statistics-Forecast-0.2.tar.gz) = 15043e35bb3bcb450fe11b3ce9b1afebefca3cf9b9cad81328d78512dc78d45f
+SIZE (Statistics-Forecast-0.2.tar.gz) = 3540
diff --git a/math/p5-Statistics-Forecast/pkg-descr b/math/p5-Statistics-Forecast/pkg-descr
new file mode 100644
index 000000000000..0b6d3afcfcca
--- /dev/null
+++ b/math/p5-Statistics-Forecast/pkg-descr
@@ -0,0 +1,4 @@
+This is an Oriented Object module that calculates a future value by using
+existing values. The new value is calculated by using linear regression.
+
+WWW: http://search.cpan.org/dist/Statistics-Forecast/
diff --git a/math/p5-Statistics-Forecast/pkg-plist b/math/p5-Statistics-Forecast/pkg-plist
new file mode 100644
index 000000000000..5d20d3d833cf
--- /dev/null
+++ b/math/p5-Statistics-Forecast/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Forecast/.packlist
+%%SITE_PERL%%/Statistics/Forecast.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Forecast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics
+@dirrmtry %%SITE_PERL%%/Statistics