aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/wmScoreBoard/Makefile32
-rw-r--r--misc/wmScoreBoard/distinfo1
-rw-r--r--misc/wmScoreBoard/files/patch-wmScoreBoard::Makefile17
-rw-r--r--misc/wmScoreBoard/pkg-comment1
-rw-r--r--misc/wmScoreBoard/pkg-descr8
-rw-r--r--misc/wmScoreBoard/pkg-plist7
7 files changed, 67 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 9922664b5436..56417ec91ec2 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -179,6 +179,7 @@
SUBDIR += videotext
SUBDIR += viz
SUBDIR += whichman
+ SUBDIR += wmScoreBoard
SUBDIR += wmcp
SUBDIR += wmmand
SUBDIR += wmpal
diff --git a/misc/wmScoreBoard/Makefile b/misc/wmScoreBoard/Makefile
new file mode 100644
index 000000000000..51ffa4734401
--- /dev/null
+++ b/misc/wmScoreBoard/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: wmScoreBoard
+# Date created: Sun Jun 24 17:08:15 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmScoreBoard
+PORTVERSION= 0.30
+CATEGORIES= misc windowmaker
+MASTER_SITES= http://home.att.net/~takuper/wmscoreboard/
+
+MAINTAINER= pat@databits.net
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 \
+ ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/../BUGS ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/../CHANGES ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/../HINTS ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/../README ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/wmScoreBoard/distinfo b/misc/wmScoreBoard/distinfo
new file mode 100644
index 000000000000..01adf4ae2e27
--- /dev/null
+++ b/misc/wmScoreBoard/distinfo
@@ -0,0 +1 @@
+MD5 (wmScoreBoard-0.30.tar.gz) = 410b27ef95c2e46e8d1b06c191ec59a0
diff --git a/misc/wmScoreBoard/files/patch-wmScoreBoard::Makefile b/misc/wmScoreBoard/files/patch-wmScoreBoard::Makefile
new file mode 100644
index 000000000000..e4978168a07c
--- /dev/null
+++ b/misc/wmScoreBoard/files/patch-wmScoreBoard::Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Sat Apr 8 00:51:27 2000
++++ Makefile Mon Jul 2 21:51:07 2001
+@@ -1,10 +1,9 @@
+ # Makefile for wmScoreBoard
+
+-CC = gcc
+-CFLAGS = -g -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
+-LIBDIR = -L/usr/X11R6/lib
+-DESTDIR = /usr/X11R6
++CFLAGS += -g -Wall
++INCDIR = -I${X11BASE}/include/X11 -I${X11BASE}/include
++LIBDIR = -L${X11BASE}/lib
++DESTDIR = $(PREFIX)
+
+ # for linux
+ LIBS = -lXpm -lX11 -lXext
diff --git a/misc/wmScoreBoard/pkg-comment b/misc/wmScoreBoard/pkg-comment
new file mode 100644
index 000000000000..ab125748f306
--- /dev/null
+++ b/misc/wmScoreBoard/pkg-comment
@@ -0,0 +1 @@
+Window Maker dockapp that display game scores from excite
diff --git a/misc/wmScoreBoard/pkg-descr b/misc/wmScoreBoard/pkg-descr
new file mode 100644
index 000000000000..19d8aff4885f
--- /dev/null
+++ b/misc/wmScoreBoard/pkg-descr
@@ -0,0 +1,8 @@
+wmScoreBoard is a Window Maker Dock App that shows the current (or
+final) score to a game that a specified team is playing in. The
+app currently gets its scores from Excite.
+
+WWW: http://home.att.net/~takuper/wmscoreboard/
+Author: Todd Kuper <takuper@worldnet.att.net>
+
+- Patrick Li <pat@databits.net>
diff --git a/misc/wmScoreBoard/pkg-plist b/misc/wmScoreBoard/pkg-plist
new file mode 100644
index 000000000000..671738c78b34
--- /dev/null
+++ b/misc/wmScoreBoard/pkg-plist
@@ -0,0 +1,7 @@
+bin/GrabScores.excite
+bin/wmScoreBoard
+%%PORTDOCS%%share/doc/wmScoreBoard/BUGS
+%%PORTDOCS%%share/doc/wmScoreBoard/CHANGES
+%%PORTDOCS%%share/doc/wmScoreBoard/HINTS
+%%PORTDOCS%%share/doc/wmScoreBoard/README
+%%PORTDOCS%%@dirrm share/doc/wmScoreBoard