aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/traingame/Makefile75
-rw-r--r--games/traingame/distinfo4
-rw-r--r--games/traingame/files/pkg-message.in18
-rw-r--r--games/traingame/files/traingame-map.in13
-rw-r--r--games/traingame/files/traingame.in7
-rw-r--r--games/traingame/pkg-descr8
-rw-r--r--games/traingame/pkg-plist147
8 files changed, 273 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9d6ef5eaab31..9d4718aa5905 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -944,6 +944,7 @@
SUBDIR += trackballs
SUBDIR += tractorgen
SUBDIR += traindirector
+ SUBDIR += traingame
SUBDIR += tremulous
SUBDIR += trigger
SUBDIR += trimines
diff --git a/games/traingame/Makefile b/games/traingame/Makefile
new file mode 100644
index 000000000000..6eec3e39372d
--- /dev/null
+++ b/games/traingame/Makefile
@@ -0,0 +1,75 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= traingame
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= http://www.nickg.me.uk/files/:game \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= TrainGame-${DISTVERSION}${EXTRACT_SUFX}:game \
+ ${PORTNAME}_icons.tar.gz:icons
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Game about Trains
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libxerces-c.so:${PORTSDIR}/textproc/xerces-c3 \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS= xterm:${PORTSDIR}/x11/xterm
+
+WRKSRC= ${WRKDIR}/TrainGame-${PORTVERSION}
+
+USES= cmake pkgconfig
+USE_SDL= sdl image
+USE_GL= glew
+USE_GCC= 4.6+
+
+PORTDOCS= model_notes.txt models.gnuplot
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
+SUB_FILES= ${PORTNAME} \
+ ${PORTNAME}-map \
+ pkg-message
+
+DESKTOP_ENTRIES="Train Game" "${COMMENT}" ${PORTNAME} \
+ "xterm -e ${PORTNAME}-map" "Game;ArcadeGame;" false
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|shared_ptr|std::shared_ptr|' \
+ ${WRKSRC}/src/Mesh.cpp
+
+do-install:
+.for d in ${PORTNAME} ${PORTNAME}-map
+ ${INSTALL_SCRIPT} ${WRKDIR}/${d} ${STAGEDIR}${PREFIX}/bin/
+.endfor
+.for d in buildings engines fonts images layouts maps schemas trees waggons
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/TrainGame ${STAGEDIR}${DATADIR}/${PORTNAME}
+
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+ @${ECHO_CMD}
+ @${ECHO_CMD} ===============================================================================
+ @${ECHO_CMD}
+ @${ECHO_CMD} "These Maps you can use:"
+ @${ECHO_CMD}
+ @${LS} ${STAGEDIR}${DATADIR}/maps
+ @${ECHO_CMD}
+ @${ECHO_CMD} ===============================================================================
+
+.include <bsd.port.mk>
diff --git a/games/traingame/distinfo b/games/traingame/distinfo
new file mode 100644
index 000000000000..10144044818d
--- /dev/null
+++ b/games/traingame/distinfo
@@ -0,0 +1,4 @@
+SHA256 (traingame/TrainGame-0.2.2.tar.gz) = d25fdda2bdfe27543debb64f901911534006538ad5f7dbf40da5622e177436e7
+SIZE (traingame/TrainGame-0.2.2.tar.gz) = 1057361
+SHA256 (traingame/traingame_icons.tar.gz) = f35937ac4893a4d803888fc2d8d3890a769bda77548a1dc45c09b95738f3dbb7
+SIZE (traingame/traingame_icons.tar.gz) = 25088
diff --git a/games/traingame/files/pkg-message.in b/games/traingame/files/pkg-message.in
new file mode 100644
index 000000000000..09a5de6bfbc4
--- /dev/null
+++ b/games/traingame/files/pkg-message.in
@@ -0,0 +1,18 @@
+===============================================================================
+
+Train Game has been installed.
+
+Now you can play the game by running:
+
+ %%PREFIX%%/bin/traingame-map
+
+or manually with
+
+ %%PREFIX%%/bin/traingame play <map_name_here>
+
+
+To use the editor, run:
+
+ %%PREFIX%%/bin/traingame edit <map_name_here>
+
+===============================================================================
diff --git a/games/traingame/files/traingame-map.in b/games/traingame/files/traingame-map.in
new file mode 100644
index 000000000000..833b65f4f1a3
--- /dev/null
+++ b/games/traingame/files/traingame-map.in
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+echo ""
+echo -n "Which Train Game Map would You use?"
+echo ""
+ls %%DATADIR%%/maps
+echo ""
+read MAP
+
+traingame play $MAP
diff --git a/games/traingame/files/traingame.in b/games/traingame/files/traingame.in
new file mode 100644
index 000000000000..2dbeb68da761
--- /dev/null
+++ b/games/traingame/files/traingame.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec ./traingame "${@}"
diff --git a/games/traingame/pkg-descr b/games/traingame/pkg-descr
new file mode 100644
index 000000000000..c86cf9516099
--- /dev/null
+++ b/games/traingame/pkg-descr
@@ -0,0 +1,8 @@
+Train Game (working title) is a game about trains! Woo! You control a train
+which you drive around a 3D world picking up cargo, trundle it about,
+and deliver it for PROFIT; whilst avoiding disasters like falling off the rails,
+hitting other trains, bad weather, or privatisation.
+Imagine Elite but with trains instead of space craft.
+Cant believe no ones thought of it before.
+
+WWW: http://www.doof.me.uk/train-game/
diff --git a/games/traingame/pkg-plist b/games/traingame/pkg-plist
new file mode 100644
index 000000000000..d0644b14c3ac
--- /dev/null
+++ b/games/traingame/pkg-plist
@@ -0,0 +1,147 @@
+bin/traingame
+bin/traingame-map
+share/icons/hicolor/32x32/apps/traingame.png
+share/icons/hicolor/48x48/apps/traingame.png
+share/icons/hicolor/64x64/apps/traingame.png
+share/icons/hicolor/72x72/apps/traingame.png
+share/icons/hicolor/96x96/apps/traingame.png
+share/pixmaps/traingame.png
+%%DATADIR%%/buildings/coal_mine/coal_mine.mtl
+%%DATADIR%%/buildings/coal_mine/coal_mine.obj
+%%DATADIR%%/buildings/coal_mine/coal_mine.wings
+%%DATADIR%%/buildings/coal_mine/coal_mine.xml
+%%DATADIR%%/buildings/house2/house2.mtl
+%%DATADIR%%/buildings/house2/house2.obj
+%%DATADIR%%/buildings/house2/house2.wings
+%%DATADIR%%/buildings/house2/house2.xml
+%%DATADIR%%/buildings/platform_end/platform_end.mtl
+%%DATADIR%%/buildings/platform_end/platform_end.obj
+%%DATADIR%%/buildings/platform_end/platform_end.wings
+%%DATADIR%%/buildings/platform_end/platform_end.xml
+%%DATADIR%%/buildings/platform_middle/platform_middle.mtl
+%%DATADIR%%/buildings/platform_middle/platform_middle.obj
+%%DATADIR%%/buildings/platform_middle/platform_middle.wings
+%%DATADIR%%/buildings/platform_middle/platform_middle.xml
+%%DATADIR%%/buildings/power_plant/power_plant.mtl
+%%DATADIR%%/buildings/power_plant/power_plant.obj
+%%DATADIR%%/buildings/power_plant/power_plant.wings
+%%DATADIR%%/buildings/power_plant/power_plant.xml
+%%DATADIR%%/buildings/white_house/cube2_auv.png
+%%DATADIR%%/buildings/white_house/house.mtl
+%%DATADIR%%/buildings/white_house/house.obj
+%%DATADIR%%/buildings/white_house/house.wings
+%%DATADIR%%/buildings/white_house/white_house.xml
+%%DATADIR%%/engines/base.wings
+%%DATADIR%%/engines/red/red.xml
+%%DATADIR%%/engines/red/train.mtl
+%%DATADIR%%/engines/red/train.obj
+%%DATADIR%%/engines/red/train.wings
+%%DATADIR%%/engines/saddle/saddle.mtl
+%%DATADIR%%/engines/saddle/saddle.obj
+%%DATADIR%%/engines/saddle/saddle.wings
+%%DATADIR%%/engines/saddle/saddle.xml
+%%DATADIR%%/engines/tank/tank.mtl
+%%DATADIR%%/engines/tank/tank.obj
+%%DATADIR%%/engines/tank/tank.wings
+%%DATADIR%%/engines/tank/tank.xml
+%%DATADIR%%/fonts/DejaVuSans.ttf
+%%DATADIR%%/fonts/DejaVuSansMono.ttf
+%%DATADIR%%/fonts/Vera.ttf
+%%DATADIR%%/images/buildings_icon.png
+%%DATADIR%%/images/button_active.png
+%%DATADIR%%/images/button_base.png
+%%DATADIR%%/images/delete_icon.png
+%%DATADIR%%/images/icons/next.png
+%%DATADIR%%/images/icons/prev.png
+%%DATADIR%%/images/icons/rotate.png
+%%DATADIR%%/images/icons/save.png
+%%DATADIR%%/images/icons/smooth.png
+%%DATADIR%%/images/icons/tree.png
+%%DATADIR%%/images/level_icon.png
+%%DATADIR%%/images/lower_icon.png
+%%DATADIR%%/images/raise_icon.png
+%%DATADIR%%/images/smoke_particle.png
+%%DATADIR%%/images/start_icon.png
+%%DATADIR%%/images/start_icon2.png
+%%DATADIR%%/images/station_icon.png
+%%DATADIR%%/images/track_icon.png
+%%DATADIR%%/layouts/demo.xml
+%%DATADIR%%/layouts/editor.xml
+%%DATADIR%%/layouts/game.xml
+%%DATADIR%%/maps/coal_mine/coal_mine.bin
+%%DATADIR%%/maps/coal_mine/coal_mine.xml
+%%DATADIR%%/maps/demo/demo.bin
+%%DATADIR%%/maps/demo/demo.xml
+%%DATADIR%%/maps/figure8/figure8.bin
+%%DATADIR%%/maps/figure8/figure8.xml
+%%DATADIR%%/maps/gen_track/gen_track.bin
+%%DATADIR%%/maps/gen_track/gen_track.xml
+%%DATADIR%%/maps/goods_demo/goods_demo.bin
+%%DATADIR%%/maps/goods_demo/goods_demo.xml
+%%DATADIR%%/maps/long_map/long_map.bin
+%%DATADIR%%/maps/long_map/long_map.xml
+%%DATADIR%%/maps/points/points.bin
+%%DATADIR%%/maps/points/points.xml
+%%DATADIR%%/maps/power_plant/power_plant.bin
+%%DATADIR%%/maps/power_plant/power_plant.xml
+%%DATADIR%%/maps/sbends/sbends.bin
+%%DATADIR%%/maps/sbends/sbends.xml
+%%DATADIR%%/maps/uphill/uphill.bin
+%%DATADIR%%/maps/uphill/uphill.xml
+%%DATADIR%%/maps/villages/villages.bin
+%%DATADIR%%/maps/villages/villages.xml
+%%DATADIR%%/schemas/building.xsd
+%%DATADIR%%/schemas/config.xsd
+%%DATADIR%%/schemas/engine.xsd
+%%DATADIR%%/schemas/layout.xsd
+%%DATADIR%%/schemas/map.xsd
+%%DATADIR%%/schemas/tree.xsd
+%%DATADIR%%/schemas/waggon.xsd
+%%DATADIR%%/traingame
+%%DATADIR%%/trees/apple/apple.mtl
+%%DATADIR%%/trees/apple/apple.obj
+%%DATADIR%%/trees/apple/apple.wings
+%%DATADIR%%/trees/apple/apple.xml
+%%DATADIR%%/trees/pine/pine.mtl
+%%DATADIR%%/trees/pine/pine.obj
+%%DATADIR%%/trees/pine/pine.wings
+%%DATADIR%%/trees/pine/pine.xml
+%%DATADIR%%/waggons/coal_truck/coal_truck.mtl
+%%DATADIR%%/waggons/coal_truck/coal_truck.obj
+%%DATADIR%%/waggons/coal_truck/coal_truck.wings
+%%DATADIR%%/waggons/coal_truck/coal_truck.xml
+%%DATADIR%%/waggons/waggon_base.wings
+@dirrm %%DATADIR%%/waggons/coal_truck
+@dirrm %%DATADIR%%/waggons
+@dirrm %%DATADIR%%/trees/pine
+@dirrm %%DATADIR%%/trees/apple
+@dirrm %%DATADIR%%/trees
+@dirrm %%DATADIR%%/schemas
+@dirrm %%DATADIR%%/maps/villages
+@dirrm %%DATADIR%%/maps/uphill
+@dirrm %%DATADIR%%/maps/sbends
+@dirrm %%DATADIR%%/maps/power_plant
+@dirrm %%DATADIR%%/maps/points
+@dirrm %%DATADIR%%/maps/long_map
+@dirrm %%DATADIR%%/maps/goods_demo
+@dirrm %%DATADIR%%/maps/gen_track
+@dirrm %%DATADIR%%/maps/figure8
+@dirrm %%DATADIR%%/maps/demo
+@dirrm %%DATADIR%%/maps/coal_mine
+@dirrm %%DATADIR%%/maps
+@dirrm %%DATADIR%%/layouts
+@dirrm %%DATADIR%%/images/icons
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/engines/tank
+@dirrm %%DATADIR%%/engines/saddle
+@dirrm %%DATADIR%%/engines/red
+@dirrm %%DATADIR%%/engines
+@dirrm %%DATADIR%%/buildings/white_house
+@dirrm %%DATADIR%%/buildings/power_plant
+@dirrm %%DATADIR%%/buildings/platform_middle
+@dirrm %%DATADIR%%/buildings/platform_end
+@dirrm %%DATADIR%%/buildings/house2
+@dirrm %%DATADIR%%/buildings/coal_mine
+@dirrm %%DATADIR%%/buildings
+@dirrm %%DATADIR%%