aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Balanced/Makefile22
-rw-r--r--textproc/p5-Text-Balanced/distinfo1
-rw-r--r--textproc/p5-Text-Balanced/pkg-comment1
-rw-r--r--textproc/p5-Text-Balanced/pkg-descr10
-rw-r--r--textproc/p5-Text-Balanced/pkg-plist5
6 files changed, 40 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index dfa1610b3c89..4812a197e808 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -106,6 +106,7 @@
SUBDIR += p5-String-ShellQuote
SUBDIR += p5-String-Strip
SUBDIR += p5-Text-Autoformat
+ SUBDIR += p5-Text-Balanced
SUBDIR += p5-Text-Bind
SUBDIR += p5-Text-CSV
SUBDIR += p5-Text-CSV_XS
diff --git a/textproc/p5-Text-Balanced/Makefile b/textproc/p5-Text-Balanced/Makefile
new file mode 100644
index 000000000000..e9b29ee328da
--- /dev/null
+++ b/textproc/p5-Text-Balanced/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Text-Balanced
+# Date created: 16 Sep 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Balanced
+PORTVERSION= 1.86
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Balanced.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Balanced/distinfo b/textproc/p5-Text-Balanced/distinfo
new file mode 100644
index 000000000000..0016fce54e0c
--- /dev/null
+++ b/textproc/p5-Text-Balanced/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Balanced-1.86.tar.gz) = 829ff34113d61cf8b976b297cf0dead8
diff --git a/textproc/p5-Text-Balanced/pkg-comment b/textproc/p5-Text-Balanced/pkg-comment
new file mode 100644
index 000000000000..7fd92b05adc6
--- /dev/null
+++ b/textproc/p5-Text-Balanced/pkg-comment
@@ -0,0 +1 @@
+Text::Balanced - extract delimited text sequences from strings
diff --git a/textproc/p5-Text-Balanced/pkg-descr b/textproc/p5-Text-Balanced/pkg-descr
new file mode 100644
index 000000000000..d71124a5e29a
--- /dev/null
+++ b/textproc/p5-Text-Balanced/pkg-descr
@@ -0,0 +1,10 @@
+Text::Balanced - Extract delimited text sequences from strings.
+
+The various extract_... subroutines may be used to extract a delimited
+string (possibly after skipping a specified prefix string). The search
+for the string always begins at the current pos location of the string's
+variable (or at index zero, if no pos position is defined).
+
+WWW: http://search.cpan.org/search?dist=Text-Balanced
+
+-Anton
diff --git a/textproc/p5-Text-Balanced/pkg-plist b/textproc/p5-Text-Balanced/pkg-plist
new file mode 100644
index 000000000000..25c84efa7aba
--- /dev/null
+++ b/textproc/p5-Text-Balanced/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Balanced/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Text/Balanced.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Balanced
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Text 2>/dev/null || true