aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/clickheat/Makefile36
-rw-r--r--www/clickheat/distinfo3
-rw-r--r--www/clickheat/files/pkg-deinstall.in12
-rw-r--r--www/clickheat/files/pkg-message.in15
-rw-r--r--www/clickheat/pkg-descr8
-rw-r--r--www/clickheat/pkg-plist81
7 files changed, 156 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 89ba9a03d9e8..355af7c85cf6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -92,6 +92,7 @@
SUBDIR += claroline
SUBDIR += clearsilver
SUBDIR += clearsilver-python
+ SUBDIR += clickheat
SUBDIR += cocoon
SUBDIR += codeigniter
SUBDIR += comclear
diff --git a/www/clickheat/Makefile b/www/clickheat/Makefile
new file mode 100644
index 000000000000..4e2eb981d1e5
--- /dev/null
+++ b/www/clickheat/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: clickheat
+# Date created: 27 June 2008
+# Whom: Philippe Audeoud <jadawin@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= clickheat
+PORTVERSION= 1.7
+CATEGORIES= www
+MASTER_SITES= SF
+
+MAINTAINER= jadawin@FreeBSD.org
+COMMENT= ClickHeat is a visual heatmap of clicks on a HTML page
+
+USE_PHP= gd session
+WANT_PHP_WEB= yes
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= PORTNAME=${PORTNAME} \
+ WWWDIR=${WWWDIR}
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WWWDIR} \
+ "! -name README ! -name INSTALL ! -name LICENSE ! -name LISEZMOI ")
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/clickheat/distinfo b/www/clickheat/distinfo
new file mode 100644
index 000000000000..f86d62f56502
--- /dev/null
+++ b/www/clickheat/distinfo
@@ -0,0 +1,3 @@
+MD5 (clickheat-1.7.tar.gz) = e8934e86061d8ac7b8e264262365a3cd
+SHA256 (clickheat-1.7.tar.gz) = 509e0d8e50b817263822672e4380257a266d20ff1ae33e4ea130a7e1ca351d8c
+SIZE (clickheat-1.7.tar.gz) = 95852
diff --git a/www/clickheat/files/pkg-deinstall.in b/www/clickheat/files/pkg-deinstall.in
new file mode 100644
index 000000000000..c9fd930d194e
--- /dev/null
+++ b/www/clickheat/files/pkg-deinstall.in
@@ -0,0 +1,12 @@
+#! /bin/sh
+# $FreeBSD$
+#
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+if [ -d %%WWWDIR%% ]; then
+ echo "===> You may delete '%%WWWDIR%%' if you want to really delete your clickheat."
+fi
diff --git a/www/clickheat/files/pkg-message.in b/www/clickheat/files/pkg-message.in
new file mode 100644
index 000000000000..74456049f116
--- /dev/null
+++ b/www/clickheat/files/pkg-message.in
@@ -0,0 +1,15 @@
+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
+Browse http://your.host.tld/%%PORTNAME%%/ to configure your clickheat
+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
+To make clickheat available through your web site, I suggest
+that you add something like the following to httpd.conf:
+
+ Alias /clickheat/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options none
+ AllowOverride Limit
+ Order Deny,Allow
+ Allow from all
+ </Directory>
+
diff --git a/www/clickheat/pkg-descr b/www/clickheat/pkg-descr
new file mode 100644
index 000000000000..09d1233d2bab
--- /dev/null
+++ b/www/clickheat/pkg-descr
@@ -0,0 +1,8 @@
+ClickHeat is a visual heatmap of clicks on a HTML page, showing hot and
+ cold click zones.
+Features:
+- Few function calls to log a click, no server load rise should be noticed
+- A keyword is used to define the page upon Javascript code load
+- Screen sizes and browsers are logged
+
+WWW: http://www.labsmedia.com/clickheat/index.html
diff --git a/www/clickheat/pkg-plist b/www/clickheat/pkg-plist
new file mode 100644
index 000000000000..232aa4b7096d
--- /dev/null
+++ b/www/clickheat/pkg-plist
@@ -0,0 +1,81 @@
+%%WWWDIR%%/VERSION
+%%WWWDIR%%/cache/.htaccess
+%%WWWDIR%%/check.php
+%%WWWDIR%%/classes/Heatmap.class.php
+%%WWWDIR%%/classes/HeatmapFromClicks.class.php
+%%WWWDIR%%/classes/HeatmapFromDatabase.class.php
+%%WWWDIR%%/classes/HeatmapFromFile.class.php
+%%WWWDIR%%/cleaner.php
+%%WWWDIR%%/click.php
+%%WWWDIR%%/clickempty.html
+%%WWWDIR%%/clickpmv.php
+%%WWWDIR%%/config.php
+%%WWWDIR%%/config/.htaccess
+%%WWWDIR%%/examples/coords.txt
+%%WWWDIR%%/examples/fromdatabase.php
+%%WWWDIR%%/examples/fromfile.php
+%%WWWDIR%%/footer.php
+%%WWWDIR%%/generate.php
+%%WWWDIR%%/header.php
+%%WWWDIR%%/images/arrow-down.png
+%%WWWDIR%%/images/arrow-up.png
+%%WWWDIR%%/images/flags/_flags.txt
+%%WWWDIR%%/images/flags/en.png
+%%WWWDIR%%/images/flags/es.png
+%%WWWDIR%%/images/flags/fr.png
+%%WWWDIR%%/images/flags/ja.png
+%%WWWDIR%%/images/flags/ro.png
+%%WWWDIR%%/images/flags/ru.png
+%%WWWDIR%%/images/flags/uk.png
+%%WWWDIR%%/images/flags/zh.png
+%%WWWDIR%%/images/ko.png
+%%WWWDIR%%/images/layout.png
+%%WWWDIR%%/images/logo.big.png
+%%WWWDIR%%/images/logo.png
+%%WWWDIR%%/images/logo170.png
+%%WWWDIR%%/images/next.png
+%%WWWDIR%%/images/ok.png
+%%WWWDIR%%/images/previous.png
+%%WWWDIR%%/images/reload.png
+%%WWWDIR%%/images/save.png
+%%WWWDIR%%/images/warning.png
+%%WWWDIR%%/index.php
+%%WWWDIR%%/javascript.php
+%%WWWDIR%%/js/admin.js
+%%WWWDIR%%/js/clickheat-original.js
+%%WWWDIR%%/js/clickheat.js
+%%WWWDIR%%/languages/__de.php
+%%WWWDIR%%/languages/__readme.txt
+%%WWWDIR%%/languages/en.php
+%%WWWDIR%%/languages/es.php
+%%WWWDIR%%/languages/fr.php
+%%WWWDIR%%/languages/ja.php
+%%WWWDIR%%/languages/ro.php
+%%WWWDIR%%/languages/ru.php
+%%WWWDIR%%/languages/uk.php
+%%WWWDIR%%/languages/zh.php
+%%WWWDIR%%/latest.php
+%%WWWDIR%%/layout.php
+%%WWWDIR%%/login.php
+%%WWWDIR%%/logo.big.png.php
+%%WWWDIR%%/logo.png.php
+%%WWWDIR%%/logo170.png.php
+%%WWWDIR%%/logs/.htaccess
+%%WWWDIR%%/scripts/compressJs.php
+%%WWWDIR%%/scripts/parseClickLogs.pl
+%%WWWDIR%%/scripts/upgrade-1.1.php
+%%WWWDIR%%/styles/clickheat.css
+%%WWWDIR%%/version.php
+%%WWWDIR%%/view.php
+@dirrm %%WWWDIR%%/styles
+@dirrm %%WWWDIR%%/scripts
+@dirrm %%WWWDIR%%/languages
+@dirrm %%WWWDIR%%/js
+@dirrm %%WWWDIR%%/images/flags
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/examples
+@dirrm %%WWWDIR%%/classes
+@dirrmtry %%WWWDIR%%/cache
+@dirrmtry %%WWWDIR%%/logs
+@dirrmtry %%WWWDIR%%/config
+@dirrm %%WWWDIR%%