aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/boinc-astropulse/Makefile3
-rw-r--r--astro/boinc-setiathome-v7/Makefile3
-rw-r--r--astro/pp3/Makefile10
-rw-r--r--astro/wcslib/Makefile3
-rw-r--r--astro/xearth/Makefile2
-rw-r--r--benchmarks/blogbench/Makefile2
-rw-r--r--benchmarks/dkftpbench/Makefile1
-rw-r--r--benchmarks/expedite/Makefile5
-rw-r--r--benchmarks/flowgrind/Makefile2
-rw-r--r--benchmarks/hs-criterion/Makefile2
-rw-r--r--benchmarks/interbench/Makefile3
-rw-r--r--benchmarks/nosqlbench/Makefile3
-rw-r--r--benchmarks/nuttcp/Makefile3
-rw-r--r--benchmarks/randomio/Makefile3
14 files changed, 16 insertions, 29 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 5c8b60e63566..1200ee9974ca 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -21,8 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
-USES= gmake pkgconfig
-USE_XZ= yes
+USES= tar:xz gmake pkgconfig
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/client
diff --git a/astro/boinc-setiathome-v7/Makefile b/astro/boinc-setiathome-v7/Makefile
index daf0f32f3d8d..d3655e0fdb63 100644
--- a/astro/boinc-setiathome-v7/Makefile
+++ b/astro/boinc-setiathome-v7/Makefile
@@ -20,8 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
-USES= gmake pkgconfig
-USE_XZ= yes
+USES= tar:xz gmake pkgconfig
USE_AUTOTOOLS= autoconf:env automake:env
GNU_CONFIGURE= yes
diff --git a/astro/pp3/Makefile b/astro/pp3/Makefile
index e808555f6f84..7d53b844b43e 100644
--- a/astro/pp3/Makefile
+++ b/astro/pp3/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/PP3/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Creates celestial charts
-USE_BZIP2= yes
+USES= tar:bzip2
USE_TEX= latex
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -18,21 +18,17 @@ OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
do-build:
- cd ${WRKSRC} \
- && ${CXX} ${CXXFLAGS} -DPP3DATA=\"${DATADIR}\" pp3.cc -o pp3
+ (cd ${WRKSRC} \
+ && ${CXX} ${CXXFLAGS} -DPP3DATA=\"${DATADIR}\" pp3.cc -o pp3)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pp3 ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.dat ${STAGEDIR}${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/WHATSNEW ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index 473aae0040cb..300744513ed0 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
MAINTAINER= tonymaher@optusnet.com.au
COMMENT= Library for parsing/generating FITS headers
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= gmake
+USES= tar:bzip2 gmake
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
diff --git a/astro/xearth/Makefile b/astro/xearth/Makefile
index a69855722b92..95bb96b54dcd 100644
--- a/astro/xearth/Makefile
+++ b/astro/xearth/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= mexas@bris.ac.uk
COMMENT= Set the root window to the image of earth
USE_XORG= x11 xext sm ice xt
-USE_XZ= yes
+USES= tar:xz
PLIST_FILES= bin/xearth \
man/man1/xearth.1.gz \
lib/X11/xearth/freebsd.committers.markers \
diff --git a/benchmarks/blogbench/Makefile b/benchmarks/blogbench/Makefile
index 2acfcc737b7e..1efd8eb75e93 100644
--- a/benchmarks/blogbench/Makefile
+++ b/benchmarks/blogbench/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= jmohacsi@bsd.hu
COMMENT= Performance Test of Filesystem I/O
GNU_CONFIGURE= yes
-USE_BZIP2= yes
+USES= tar:bzip2
PLIST_FILES= bin/blogbench man/man8/blogbench.8.gz
PORTDOCS= README
diff --git a/benchmarks/dkftpbench/Makefile b/benchmarks/dkftpbench/Makefile
index efabbb27b8ea..d23e5e25efc6 100644
--- a/benchmarks/dkftpbench/Makefile
+++ b/benchmarks/dkftpbench/Makefile
@@ -16,5 +16,4 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake14 autoconf
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/benchmarks/expedite/Makefile b/benchmarks/expedite/Makefile
index 1aeb9808d622..8096eb890014 100644
--- a/benchmarks/expedite/Makefile
+++ b/benchmarks/expedite/Makefile
@@ -10,12 +10,11 @@ MASTER_SITES= http://download.enlightenment.org/releases/ \
MAINTAINER= gblach@FreeBSD.org
COMMENT= Expedite is a benchmark suite for Evas
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
DIST_SUBDIR= e17
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= tar:bzip2 pkgconfig
USE_EFL= evas
USE_EFL_EVAS_ENGINES= buffer
USE_LDCONFIG= yes
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index ffb80ab6802d..a2d557562858 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libxmlrpc++.so:${PORTSDIR}/net/xmlrpc-c \
libgsl.so:${PORTSDIR}/math/gsl \
libpcap.so.1:${PORTSDIR}/net/libpcap
-USE_BZIP2= yes
+USES= tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-debug
diff --git a/benchmarks/hs-criterion/Makefile b/benchmarks/hs-criterion/Makefile
index cb3ef603565f..76448002120c 100644
--- a/benchmarks/hs-criterion/Makefile
+++ b/benchmarks/hs-criterion/Makefile
@@ -9,7 +9,7 @@ CATEGORIES= benchmarks haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Robust, reliable performance measurement and analysis
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
USE_CABAL= aeson>=0.3.2.12 hastache>=0.5.0 mtl>=2 mwc-random>=0.8.0.3 \
parsec>=3.1.0 statistics>=0.10.0.0 transformers \
diff --git a/benchmarks/interbench/Makefile b/benchmarks/interbench/Makefile
index 13193bbc9ef9..ee07747a20f8 100644
--- a/benchmarks/interbench/Makefile
+++ b/benchmarks/interbench/Makefile
@@ -11,8 +11,7 @@ COMMENT= Interactivity benchmark for Unix-like systems
LICENSE= GPLv2
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
ALL_TARGET= ${PORTNAME}
diff --git a/benchmarks/nosqlbench/Makefile b/benchmarks/nosqlbench/Makefile
index f94c91d3560a..eba841563aca 100644
--- a/benchmarks/nosqlbench/Makefile
+++ b/benchmarks/nosqlbench/Makefile
@@ -12,8 +12,7 @@ COMMENT= Micro-benchmarking NoSQL storage
LIB_DEPENDS= libtarantool.so:${PORTSDIR}/databases/tarantool
DATE= 20120802
-USE_BZIP2= yes
-USES= cmake
+USES= tar:bzip2 cmake
CMAKE_ARGS= -DLIBTNT_INCLUDE=${LOCALBASE}/include \
-DLIBTNT_LIB=${LOCALBASE}/lib
diff --git a/benchmarks/nuttcp/Makefile b/benchmarks/nuttcp/Makefile
index 3267b6dd6ac8..ab87f2d235f6 100644
--- a/benchmarks/nuttcp/Makefile
+++ b/benchmarks/nuttcp/Makefile
@@ -13,9 +13,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= andrewclarkii@gmail.com
COMMENT= TCP/UDP network testing tool
-USES= shebangfix
+USES= tar:bzip2 shebangfix
SHEBANG_FILES= ../nuttscp
-USE_BZIP2= yes
MAKEFILE= /dev/null
ALL_TARGET= ${PORTNAME}
diff --git a/benchmarks/randomio/Makefile b/benchmarks/randomio/Makefile
index 4eb7781825f6..74900ea33f86 100644
--- a/benchmarks/randomio/Makefile
+++ b/benchmarks/randomio/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= http://www.arctic.org/~dean/randomio/
MAINTAINER= pluknet@gmail.com
COMMENT= Multithreaded disk i/o microbenchmark
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake
PLIST_FILES= bin/${PORTNAME}
do-install: