aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-polyamorous/Makefile22
-rw-r--r--devel/rubygem-polyamorous/distinfo2
-rw-r--r--devel/rubygem-polyamorous/pkg-descr9
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d20507eaceb9..8c69e0da8977 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4937,6 +4937,7 @@
SUBDIR += rubygem-pkg-config
SUBDIR += rubygem-platform
SUBDIR += rubygem-plist
+ SUBDIR += rubygem-polyamorous
SUBDIR += rubygem-polyglot
SUBDIR += rubygem-popen4
SUBDIR += rubygem-posix-spawn
diff --git a/devel/rubygem-polyamorous/Makefile b/devel/rubygem-polyamorous/Makefile
new file mode 100644
index 000000000000..308b3f0b4d87
--- /dev/null
+++ b/devel/rubygem-polyamorous/Makefile
@@ -0,0 +1,22 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= polyamorous
+PORTVERSION= 1.3.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extraction of shared code from the Active Record Hackery gems
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activerecord4>=3.0:${PORTSDIR}/databases/rubygem-activerecord4
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-polyamorous/distinfo b/devel/rubygem-polyamorous/distinfo
new file mode 100644
index 000000000000..5123ffb1c403
--- /dev/null
+++ b/devel/rubygem-polyamorous/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/polyamorous-1.3.0.gem) = 4fdb214bee8f74b256a606f8f3311b3f28ed38dc16cba9e605376f88448e153c
+SIZE (rubygem/polyamorous-1.3.0.gem) = 13824
diff --git a/devel/rubygem-polyamorous/pkg-descr b/devel/rubygem-polyamorous/pkg-descr
new file mode 100644
index 000000000000..708a09e9f164
--- /dev/null
+++ b/devel/rubygem-polyamorous/pkg-descr
@@ -0,0 +1,9 @@
+Polyamorous is an extraction of shared code from the Active Record Hackery gems
+Ransack, Squeel and MetaSearch by Ernie Miller and maintained by Ryan Bigg,
+Xiang Li, Jon Atack and a great little group of contributors.
+
+It is an internal library for extending various versions of Active Record with
+polymorphism. There is no public API, so it's :nodoc:. Move along. Nothing to
+see here.
+
+WWW: https://github.com/activerecord-hackery/polyamorous