aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/msbuild/Makefile3
-rw-r--r--devel/py-tox/Makefile3
-rw-r--r--graphics/natron/Makefile7
-rw-r--r--mail/mailutils/Makefile2
-rw-r--r--net/google-cloud-sdk/Makefile4
5 files changed, 9 insertions, 10 deletions
diff --git a/devel/msbuild/Makefile b/devel/msbuild/Makefile
index 8bccb8766265..8661c0b27c2a 100644
--- a/devel/msbuild/Makefile
+++ b/devel/msbuild/Makefile
@@ -14,8 +14,7 @@ COMMENT= Build platform for .NET and Visual Studio
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= bash:shells/bash \
- python:lang/python
+BUILD_DEPENDS= bash:shells/bash
NUGET_FEEDS= DOTNET_CORE NUGET ROSLYN ROSLYN_TOOLS SYMREADER_CONVERTER
NUGET_LAYOUT= dotnet
diff --git a/devel/py-tox/Makefile b/devel/py-tox/Makefile
index e83b4ea7fc80..53830654c5b3 100644
--- a/devel/py-tox/Makefile
+++ b/devel/py-tox/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py>=1.4.17:devel/py-py@${PY_FLAVOR} \
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-timeout>0:devel/py-pytest-timeout@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
- python:lang/python
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
diff --git a/graphics/natron/Makefile b/graphics/natron/Makefile
index b9fa95f216cb..c0c776d8932d 100644
--- a/graphics/natron/Makefile
+++ b/graphics/natron/Makefile
@@ -10,8 +10,7 @@ COMMENT= Video compositing software
LICENSE= GPLv2
ONLY_FOR_ARCHS= amd64
-BUILD_DEPENDS= python-config:lang/python \
- pyside${PYTHON_PKGNAMESUFFIX}>0:devel/pyside
+BUILD_DEPENDS= pyside${PYTHON_PKGNAMESUFFIX}>0:devel/pyside
RUN_DEPENDS= ${LOCALBASE}/OFX/Plugins/IO.ofx.bundle/Contents/Info.plist:graphics/openfx-io \
${LOCALBASE}/OFX/Plugins/Shadertoy.ofx.bundle/Contents/Info.plist:graphics/openfx-misc \
${LOCALBASE}/OFX/Plugins/Arena.ofx.bundle/Contents/Info.plist:graphics/openfx-arena
@@ -24,7 +23,7 @@ LIB_DEPENDS= libcairo.so:graphics/cairo \
libpyside-${PYTHON_VERSION}.so:devel/pyside \
libfreetype.so:print/freetype2
-USES= pkgconfig python qmake qt:4 shebangfix desktop-file-utils shared-mime-info \
+USES= pkgconfig python:2.7 qmake qt:4 shebangfix desktop-file-utils shared-mime-info \
gettext-runtime desktop-file-utils
USE_GITHUB= yes
GH_ACCOUNT= NatronGitHub
@@ -43,6 +42,8 @@ USE_GL= gl
SHEBANG_FILES= OpenColorIO-Configs/nuke-default/make.py
+BINARY_ALIAS= python2-config=python${PYTHON_VER}-config
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/OFX/Plugins|${PREFIX}/OFX/Plugins|g' \
${WRKSRC}/libs/OpenFX/Examples/Makefile.master \
diff --git a/mail/mailutils/Makefile b/mail/mailutils/Makefile
index 7aee5d6825e1..85ef74e42c3c 100644
--- a/mail/mailutils/Makefile
+++ b/mail/mailutils/Makefile
@@ -62,7 +62,7 @@ NLS_CONFIGURE_ENABLE= nls
PAM_CONFIGURE_ENABLE= pam
-PYTHON_BUILD_DEPENDS= python-config:lang/python
+PYTHON_BINARY_ALIAS= python-config=python${PYTHON_VER}-config
PYTHON_USES= python:2.7
PYTHON_CONFIGURE_ENABLE=python
diff --git a/net/google-cloud-sdk/Makefile b/net/google-cloud-sdk/Makefile
index 51e5740c9448..fc8967ef4658 100644
--- a/net/google-cloud-sdk/Makefile
+++ b/net/google-cloud-sdk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= google-cloud-sdk
PORTVERSION= 208.0.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://dl.google.com/dl/cloudsdk/channels/rapid/downloads/
DISTNAME= google-cloud-sdk-${PORTVERSION}-linux-x86_64
@@ -15,8 +16,7 @@ WRKSRC= ${WRKDIR}/google-cloud-sdk
PLIST_FILES= bin/bq bin/gcloud bin/git-credential-gcloud.sh bin/gsutil
-RUN_DEPENDS= python:lang/python \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
post-extract:
@${RM} -r \