aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Sockets/Makefile2
-rw-r--r--net/gfbgraph/Makefile2
-rw-r--r--net/glusterfs/Makefile4
-rw-r--r--net/gnet2/Makefile2
-rw-r--r--net/gnome-nettool/Makefile3
-rw-r--r--net/gnome-online-miners/Makefile3
-rw-r--r--net/gq/Makefile3
-rw-r--r--net/gsk/Makefile2
-rw-r--r--net/gspoof/Makefile2
-rw-r--r--net/gtknetcat/Makefile2
-rw-r--r--net/guacamole-server/Makefile3
-rw-r--r--net/kio-gdrive/Makefile2
-rw-r--r--net/libgnetwork/Makefile2
-rw-r--r--net/libmateweather/Makefile2
-rw-r--r--net/libnids/Makefile1
-rw-r--r--net/libproxy-gnome2/Makefile1
-rw-r--r--net/libproxy-gnome3/Makefile1
-rw-r--r--net/libproxy-webkit3/Makefile2
-rw-r--r--net/libzapojit/Makefile2
-rw-r--r--net/netatalk3/Makefile2
-rw-r--r--net/netembryo/Makefile2
-rw-r--r--net/ns3/Makefile3
-rw-r--r--net/pacemaker1/Makefile.common3
-rw-r--r--net/packter-agent/Makefile2
-rw-r--r--net/pear-Horde_Kolab_Server/Makefile2
-rw-r--r--net/pear-Horde_Ldap/Makefile2
-rw-r--r--net/pear-Net_LDAP2/Makefile2
-rw-r--r--net/pear-Services_Twitter/Makefile3
-rw-r--r--net/pear-XML_RPC2/Makefile2
-rw-r--r--net/pecl-yaz/Makefile2
-rw-r--r--net/phamm/Makefile2
-rw-r--r--net/pynids/Makefile2
-rw-r--r--net/remmina-plugins/bsd.plugin.mk2
-rw-r--r--net/sdl2_net/Makefile2
-rw-r--r--net/sdl_net/Makefile2
-rw-r--r--net/sobby/Makefile2
-rw-r--r--net/sofia-sip/Makefile2
-rw-r--r--net/tapidbus/Makefile2
-rw-r--r--net/tsclient/Makefile2
-rw-r--r--net/tucan/Makefile2
-rw-r--r--net/uget/Makefile2
-rw-r--r--net/uhttpmock/Makefile2
-rw-r--r--net/unison/Makefile2
-rw-r--r--net/unison232/Makefile2
-rw-r--r--net/unison240/Makefile2
-rw-r--r--net/unison248/Makefile2
-rw-r--r--net/vortex/Makefile4
-rw-r--r--net/wireshark/Makefile6
-rw-r--r--net/yaz/Makefile2
49 files changed, 58 insertions, 52 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index bfda5a5933e3..eaca4a5bc373 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://www.alhem.net/Sockets/ \
MAINTAINER= ml@netfence.it
COMMENT= C++ wrapper for BSD-style sockets
-USES+= gmake ssl
+USES+= gmake gnome ssl
USE_GNOME= libxml2
USE_LDCONFIG= yes
CFLAGS+= -I${OPENSSLINC}
diff --git a/net/gfbgraph/Makefile b/net/gfbgraph/Makefile
index 64aad2c7918e..536be5ca6468 100644
--- a/net/gfbgraph/Makefile
+++ b/net/gfbgraph/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= librest-0.7.so:devel/librest \
libgoa-1.0.so:net/gnome-online-accounts \
libjson-glib-1.0.so:devel/json-glib
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
USE_GNOME= glib20 intlhack introspection:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net/glusterfs/Makefile b/net/glusterfs/Makefile
index 88ec5f81eb59..4ddaa60e68e1 100644
--- a/net/glusterfs/Makefile
+++ b/net/glusterfs/Makefile
@@ -14,8 +14,8 @@ LICENSE_COMB= dual
LIB_DEPENDS= libargp.so:devel/argp-standalone liburcu-bp.so:sysutils/liburcu
-USES= bison gettext libtool pkgconfig python:2.7 readline shebangfix \
- sqlite ssl
+USES= bison gettext gnome libtool pkgconfig python:2.7 readline \
+ shebangfix sqlite ssl
BROKEN_SSL= libressl
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
index d176f54f2634..fc34064c13c0 100644
--- a/net/gnet2/Makefile
+++ b/net/gnet2/Makefile
@@ -11,7 +11,7 @@ PKGNAMESUFFIX= 2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Simple network library built upon Glib-2
-USES= libtool pathfix pkgconfig
+USES= gnome libtool pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 9c32c7849905..14501dc83ef5 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libgtop-2.0.so:devel/libgtop
RUN_DEPENDS= ${LOCALBASE}/bin/dig:dns/bind-tools
USE_GNOME= gtk30 intlhack libxml2:build
-USES= gettext gmake libtool localbase:ldflags pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool localbase:ldflags pathfix pkgconfig \
+ tar:xz
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/net/gnome-online-miners/Makefile b/net/gnome-online-miners/Makefile
index 7c91bdd36052..2f96c48e7667 100644
--- a/net/gnome-online-miners/Makefile
+++ b/net/gnome-online-miners/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= libgdata.so:devel/libgdata \
libzapojit-0.0.so:net/libzapojit \
libgrilo-0.3.so:net/grilo
-USES= gettext gmake libtool localbase pathfix \
- pkgconfig tar:xz
+USES= gettext gmake gnome libtool localbase pathfix pkgconfig tar:xz
USE_GNOME= libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 19423658fe05..d632d5809d3f 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
USE_GNOME= intltool libglade2 gnomedocutils
USE_OPENLDAP= yes
-USES= desktop-file-utils gettext pkgconfig gmake shared-mime-info ssl
+USES= desktop-file-utils gettext gmake gnome pkgconfig \
+ shared-mime-info ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE} --disable-update-mimedb
INSTALLS_ICONS= yes
diff --git a/net/gsk/Makefile b/net/gsk/Makefile
index 11bb2fab81ac..5521c374f500 100644
--- a/net/gsk/Makefile
+++ b/net/gsk/Makefile
@@ -13,7 +13,7 @@ COMMENT= C library for writing servers
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool pathfix perl5 pkgconfig ssl
+USES= gnome libtool pathfix perl5 pkgconfig ssl
USE_PERL5= build
USE_GNOME= glib20
GNU_CONFIGURE= yes
diff --git a/net/gspoof/Makefile b/net/gspoof/Makefile
index cd684c9352b8..4a6b81e0eaf1 100644
--- a/net/gspoof/Makefile
+++ b/net/gspoof/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libnet.so:net/libnet
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet-prefix=${LOCALBASE}
-USES= gmake
+USES= gmake gnome
OPTIONS_DEFINE= DOCS
diff --git a/net/gtknetcat/Makefile b/net/gtknetcat/Makefile
index 4b781a907b81..6e508bcb8df8 100644
--- a/net/gtknetcat/Makefile
+++ b/net/gtknetcat/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
-USES= gmake localbase python:2.7 shebangfix
+USES= gmake gnome localbase python:2.7 shebangfix
SHEBANG_FILES= src/gtknetcat.in src/gtknetcat.py
USE_GNOME= intlhack pygtk2
GNU_CONFIGURE= yes
diff --git a/net/guacamole-server/Makefile b/net/guacamole-server/Makefile
index e3cec1d0ddb2..1d60a39e9b9e 100644
--- a/net/guacamole-server/Makefile
+++ b/net/guacamole-server/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= libossp-uuid.so:misc/ossp-uuid \
CONFLICTS_BUILD=pulseaudio-*+jack_* ffmpeg-*+jack_*
-USES= autoreconf jpeg libtool localbase \
- pkgconfig shebangfix
+USES= autoreconf gnome jpeg libtool localbase pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= apache
diff --git a/net/kio-gdrive/Makefile b/net/kio-gdrive/Makefile
index 00bbec58350f..cf8cb24ce691 100644
--- a/net/kio-gdrive/Makefile
+++ b/net/kio-gdrive/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libqt5keychain.so:security/qtkeychain \
libkaccounts.so:net-im/kaccounts-integration
RUN_DEPENDS= kaccounts-providers>=0:net-im/kaccounts-providers
-USES= cmake gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake gettext gnome kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= intltool
USE_KDE= completion config coreaddons ecm i18n jobwidgets kio \
notifications service widgetsaddons \
diff --git a/net/libgnetwork/Makefile b/net/libgnetwork/Makefile
index 021910c9721e..71fdc0527988 100644
--- a/net/libgnetwork/Makefile
+++ b/net/libgnetwork/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GLib-based networking wrapper
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= gettext gmake gnome libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix intlhack gconf2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/libmateweather/Makefile b/net/libmateweather/Makefile
index 2b7344993c55..f2080c380e9f 100644
--- a/net/libmateweather/Makefile
+++ b/net/libmateweather/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libsoup-2.4.so:devel/libsoup
PORTSCOUT= limitw:1,even
-USES= gettext gmake libtool localbase pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool localbase pathfix pkgconfig tar:xz
USE_GNOME= cairo gnomeprefix gtk30 intltool libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index f102ded97872..3fb5c7fd5220 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -19,6 +19,7 @@ OPTIONS_DEFAULT=GLIB2
GLIB2_DESC= Use GLIB2 for multiprocessing support
OPTIONS_SUB= yes
+GLIB2_USES= gnome
GLIB2_USE= gnome=glib20
GLIB2_CONFIGURE_ENABLE= libglib
diff --git a/net/libproxy-gnome2/Makefile b/net/libproxy-gnome2/Makefile
index de42cac0541b..b1263b9da738 100644
--- a/net/libproxy-gnome2/Makefile
+++ b/net/libproxy-gnome2/Makefile
@@ -7,6 +7,7 @@ PKGNAMESUFFIX= -${LIBPROXY_SLAVE}
COMMENT= GConf-based plug-in for libproxy
+USES= gnome
USE_GNOME= gconf2 glib20
LIBPROXY_SLAVE= gnome2
diff --git a/net/libproxy-gnome3/Makefile b/net/libproxy-gnome3/Makefile
index 0aedfda8e29d..413e94308a88 100644
--- a/net/libproxy-gnome3/Makefile
+++ b/net/libproxy-gnome3/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -${LIBPROXY_SLAVE}
COMMENT= GSettings-based configuration plug-in for libproxy
+USES= gnome
USE_GNOME= glib20
LIBPROXY_SLAVE= gnome3
diff --git a/net/libproxy-webkit3/Makefile b/net/libproxy-webkit3/Makefile
index 610b082df145..2ca9339d67d8 100644
--- a/net/libproxy-webkit3/Makefile
+++ b/net/libproxy-webkit3/Makefile
@@ -9,7 +9,7 @@ COMMENT= WebKit JavaScript plug-in for libproxy
LIB_DEPENDS= libjavascriptcoregtk-4.0.so:www/webkit2-gtk3
-USES= gettext-runtime
+USES= gettext-runtime gnome
USE_GNOME= glib20
LIBPROXY_SLAVE= webkit3
diff --git a/net/libzapojit/Makefile b/net/libzapojit/Makefile
index 312ca76b4794..904e8234b3d8 100644
--- a/net/libzapojit/Makefile
+++ b/net/libzapojit/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libgoa-1.0.so:net/gnome-online-accounts \
libjson-glib-1.0.so:devel/json-glib \
librest-0.7.so:devel/librest
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
USE_GNOME= gnomeprefix intltool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index ba051d976c1f..aa41e090f59a 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -62,7 +62,7 @@ LDAP_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_OFF= --without-ldap
SENDFILE_CONFIGURE_ENABLE=sendfile
-DBUS_USES= python:2.7
+DBUS_USES= gnome python:2.7
DBUS_USE= GNOME=glib20
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libdbus-1.so:devel/dbus
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index db3164b7abd9..3f4ecb1e2074 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -23,7 +23,7 @@ OPTIONS_EXCLUDE_DragonFly= SCTP
IPV6_CONFIGURE_ENABLE= ipv6
SCTP_CONFIGURE_ENABLE= sctp
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake gnome libtool pathfix pkgconfig tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/ns3/Makefile b/net/ns3/Makefile
index a3477bb1d690..8eacab6287db 100644
--- a/net/ns3/Makefile
+++ b/net/ns3/Makefile
@@ -11,7 +11,8 @@ COMMENT= Network simulator for Internet systems
LICENSE= GPLv2
-USES= compiler:c++11-lib gettext pkgconfig python sqlite tar:bzip2 waf
+USES= compiler:c++11-lib gettext gnome pkgconfig python sqlite \
+ tar:bzip2 waf
USE_GNOME= libxml2
USE_LDCONFIG= yes
WRKSRC_SUBDIR= ns-${DISTVERSION}
diff --git a/net/pacemaker1/Makefile.common b/net/pacemaker1/Makefile.common
index 0dcbc384a733..a95aeb966e66 100644
--- a/net/pacemaker1/Makefile.common
+++ b/net/pacemaker1/Makefile.common
@@ -31,7 +31,8 @@ USE_GITHUB= yes
GH_ACCOUNT= ClusterLabs
GH_PROJECT= pacemaker
-USES= autoreconf corosync gmake libtool ncurses:port pathfix pkgconfig python shebangfix
+USES= autoreconf corosync gmake gnome libtool ncurses:port pathfix \
+ pkgconfig python shebangfix
USE_BINUTILS= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/net/packter-agent/Makefile b/net/packter-agent/Makefile
index 28030df46b2e..1dd765355627 100644
--- a/net/packter-agent/Makefile
+++ b/net/packter-agent/Makefile
@@ -14,7 +14,7 @@ COMMENT= Agent of the tool for graphical Internet traffic visualization
LICENSE= BSD2CLAUSE
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= glib20
CFLAGS+= -Wno-return-type
diff --git a/net/pear-Horde_Kolab_Server/Makefile b/net/pear-Horde_Kolab_Server/Makefile
index 49f4cf25545f..a960b31d1677 100644
--- a/net/pear-Horde_Kolab_Server/Makefile
+++ b/net/pear-Horde_Kolab_Server/Makefile
@@ -9,7 +9,7 @@ PKGNAMEPREFIX= ${PEAR_PKGNAMEPREFIX}
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for manipulating the Kolab user database
-USES= horde
+USES= horde php
USE_PHP= hash
USE_HORDE_RUN= Horde_Auth \
Horde_Exception
diff --git a/net/pear-Horde_Ldap/Makefile b/net/pear-Horde_Ldap/Makefile
index 8a01e6e5fcc7..0f3b06a4efc7 100644
--- a/net/pear-Horde_Ldap/Makefile
+++ b/net/pear-Horde_Ldap/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde LDAP libraries
-USES= horde
+USES= horde php
USE_PHP= ldap
USE_HORDE_RUN= Horde_Exception \
Horde_Util
diff --git a/net/pear-Net_LDAP2/Makefile b/net/pear-Net_LDAP2/Makefile
index d66a68647755..baa64b38f0b9 100644
--- a/net/pear-Net_LDAP2/Makefile
+++ b/net/pear-Net_LDAP2/Makefile
@@ -9,7 +9,7 @@ CATEGORIES= net pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= OO interface for searching and manipulating LDAP-entries
-USES= pear
+USES= pear php
USE_PHP= ldap
.include <bsd.port.mk>
diff --git a/net/pear-Services_Twitter/Makefile b/net/pear-Services_Twitter/Makefile
index bea94f052e45..7336aef6dd48 100644
--- a/net/pear-Services_Twitter/Makefile
+++ b/net/pear-Services_Twitter/Makefile
@@ -11,8 +11,7 @@ COMMENT= PHP interface to Twitter's API
BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
+USES= pear php
USE_PHP= json simplexml mbstring
-USES= pear
-
.include <bsd.port.mk>
diff --git a/net/pear-XML_RPC2/Makefile b/net/pear-XML_RPC2/Makefile
index 60854ecb1363..29816c6cf29c 100644
--- a/net/pear-XML_RPC2/Makefile
+++ b/net/pear-XML_RPC2/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
+USES= pear php
USE_PHP= curl
-USES= pear
.include <bsd.port.mk>
diff --git a/net/pecl-yaz/Makefile b/net/pecl-yaz/Makefile
index f90f8a40f7a1..82f3655ca9d1 100644
--- a/net/pecl-yaz/Makefile
+++ b/net/pecl-yaz/Makefile
@@ -12,7 +12,7 @@ LICENSE= PHP301
LIB_DEPENDS= libyaz.so:net/yaz
-USES= php:pecl
+USES= gnome php:pecl
USE_GNOME+= libxslt
IGNORE_WITH_PHP= 73 74
diff --git a/net/phamm/Makefile b/net/phamm/Makefile
index 2763801d022a..380fbd5eeec5 100644
--- a/net/phamm/Makefile
+++ b/net/phamm/Makefile
@@ -15,7 +15,7 @@ BROKEN= unfetchable
NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session
-USES= gettext shebangfix
+USES= gettext php shebangfix
SHEBANG_FILES= po/update-all-mo.sh \
tools/*.sh tools/*.pl \
tools/ldap-schema-manage
diff --git a/net/pynids/Makefile b/net/pynids/Makefile
index 98bf2a1f5ba6..139def672ddd 100644
--- a/net/pynids/Makefile
+++ b/net/pynids/Makefile
@@ -14,7 +14,7 @@ COMMENT= Python interface to libnids
LIB_DEPENDS= libnet.so:net/libnet
-USES= pkgconfig python:2.7
+USES= gnome pkgconfig python:2.7
USE_GNOME= glib20
USE_PYTHON= distutils autoplist pythonprefix
diff --git a/net/remmina-plugins/bsd.plugin.mk b/net/remmina-plugins/bsd.plugin.mk
index a4f23e73d5b8..98c8e1164133 100644
--- a/net/remmina-plugins/bsd.plugin.mk
+++ b/net/remmina-plugins/bsd.plugin.mk
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS+= remmina>=${PORTVERSION}:net/remmina
RUN_DEPENDS+= remmina>=${PORTVERSION}:net/remmina
-USES+= cmake localbase:ldflags pkgconfig
+USES+= cmake gnome localbase:ldflags pkgconfig
USE_GNOME+= atk gdkpixbuf2 glib20 gtk30 pango
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
diff --git a/net/sdl2_net/Makefile b/net/sdl2_net/Makefile
index 3a35abeaf38e..199491bcb06d 100644
--- a/net/sdl2_net/Makefile
+++ b/net/sdl2_net/Makefile
@@ -13,7 +13,7 @@ LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/COPYING.txt
USE_SDL= sdl2
-USES= gmake libtool pathfix pkgconfig:build
+USES= gmake libtool pathfix pkgconfig:build sdl
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index 488f21d784bd..e8773cab9bdf 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig
+USES= gmake libtool pathfix pkgconfig sdl
USE_LDCONFIG= yes
USE_SDL= sdl
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index b895d98b79d4..258ab76fe2ea 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libnet6.so:net/net6 \
libxml++-2.6.so:textproc/libxml++26
-USES= localbase pkgconfig compiler:c++11-lang
+USES= compiler:c++11-lang gnome localbase pkgconfig
USE_CXXSTD= c++11
USE_GNOME= glibmm
GNU_CONFIGURE= yes
diff --git a/net/sofia-sip/Makefile b/net/sofia-sip/Makefile
index 1d2d7ed870ff..57ed70a228a9 100644
--- a/net/sofia-sip/Makefile
+++ b/net/sofia-sip/Makefile
@@ -14,7 +14,7 @@ LICENSE= LGPL21
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
# Looks like GNU make(1) is needed for parallel (-jX) builds to work
-USES= gmake libtool pathfix pkgconfig ssl
+USES= gmake gnome libtool pathfix pkgconfig ssl
USE_GNOME= glib20
.include <bsd.port.mk>
diff --git a/net/tapidbus/Makefile b/net/tapidbus/Makefile
index 0228d18b6097..88bae31f6409 100644
--- a/net/tapidbus/Makefile
+++ b/net/tapidbus/Makefile
@@ -12,7 +12,7 @@ COMMENT= Abstraction layer for interprocess communication
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
-USES= pathfix pkgconfig gmake libtool
+USES= gmake gnome libtool pathfix pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20
INSTALL_TARGET= install-strip
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index 594bbd4f4fb4..d49a10a0ac8a 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -13,7 +13,7 @@ COMMENT= GNOME 2 frontend for rdesktop and vncviewer
RUN_DEPENDS= rdesktop:net/rdesktop
USE_GNOME= gtk20 intltool
-USES= gettext gmake libtool pathfix pkgconfig
+USES= gettext gmake gnome libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gnome
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
diff --git a/net/tucan/Makefile b/net/tucan/Makefile
index b26a342c3ab6..4aa524f24335 100644
--- a/net/tucan/Makefile
+++ b/net/tucan/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
NO_BUILD= yes
USE_GNOME= pygtk2 librsvg2
-USES= gettext python:2.7
+USES= gettext gnome python:2.7
post-patch:
${REINPLACE_CMD} -Ee 's|#! /usr/bin/env python|#! ${PYTHON_CMD}|' ${WRKSRC}/tucan.py
diff --git a/net/uget/Makefile b/net/uget/Makefile
index e64a27ef0d46..db13ab5bd42f 100644
--- a/net/uget/Makefile
+++ b/net/uget/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl
RUN_DEPENDS= aria2c:www/aria2
-USES= compiler:c11 gettext-tools gmake pkgconfig
+USES= compiler:c11 gettext-tools gmake gnome pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 intltool cairo
INSTALLS_ICONS= yes
diff --git a/net/uhttpmock/Makefile b/net/uhttpmock/Makefile
index c85cd4a0a7da..c97942ef65db 100644
--- a/net/uhttpmock/Makefile
+++ b/net/uhttpmock/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common \
gtkdoc-rebase:textproc/gtk-doc
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
USE_GNOME= gnomeprefix gtk20 introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/unison/Makefile b/net/unison/Makefile
index edcae5cc302d..fad2d0f69652 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -56,7 +56,7 @@ PLIST_SUB+= X11="@comment "
MAKE_ARGS= UISTYLE=gtk2
SUB_FILES= ${PORTNAME}.desktop
USE_GNOME+= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USES+= gettext-runtime
+USES+= gettext-runtime gnome
PLIST_SUB+= X11=""
.endif
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index 936b8faef92a..05c2bb864cba 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -54,7 +54,7 @@ PLIST_SUB+= X11="@comment "
MAKE_ARGS+= UISTYLE=gtk2
SUB_FILES= ${PORTNAME}.desktop
USE_GNOME+= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USES+= gettext-runtime
+USES+= gettext-runtime gnome
PLIST_SUB+= X11=""
.endif
diff --git a/net/unison240/Makefile b/net/unison240/Makefile
index 4a304452c7c3..d501667cbbb4 100644
--- a/net/unison240/Makefile
+++ b/net/unison240/Makefile
@@ -54,7 +54,7 @@ PLIST_SUB+= X11="@comment "
MAKE_ARGS+= UISTYLE=gtk2
SUB_FILES= ${PORTNAME}.desktop
USE_GNOME+= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USES+= gettext-runtime
+USES+= gettext-runtime gnome
PLIST_SUB+= X11=""
.endif
diff --git a/net/unison248/Makefile b/net/unison248/Makefile
index 8dcedd1e95c1..0d29bcf05d33 100644
--- a/net/unison248/Makefile
+++ b/net/unison248/Makefile
@@ -63,7 +63,7 @@ MAKE_ARGS= UISTYLE=gtk2
SUB_FILES= ${PORTNAME}.desktop
SUB_LIST= PORTVERSION=${PORTVERSION} VERSIONSUFFIX=${VERSIONSUFFIX}
USE_GNOME+= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USES+= gettext-runtime
+USES+= gettext-runtime gnome
PLIST_SUB+= X11=""
.endif
diff --git a/net/vortex/Makefile b/net/vortex/Makefile
index bfbc639b002d..67ba4a3c6dc8 100644
--- a/net/vortex/Makefile
+++ b/net/vortex/Makefile
@@ -15,9 +15,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
LIB_DEPENDS= libnet.so:net/libnet
-WRKSRC= ${WRKDIR}/${PORTNAME}-2.9.0
+USES= gnome
USE_GNOME= glib20
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.9.0
+
do-build:
cd ${WRKSRC} && ${CC} -c vortex.c -I${LOCALBASE}/include
cd ${WRKSRC} && ${CC} -v -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a -lnet -lglib-2.0 -lgthread-2.0 -lpcap -pthread
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 6363d1329f0d..34f37e1e824e 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -26,9 +26,9 @@ CONFLICTS_INSTALL?= wireshark-lite-[0-9]* tshark-[0-9]* tshark-lite-[0-9]*
DATADIR_NAME= wireshark
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
-USES= alias cmake cpe compiler:c++11-lang gettext-runtime \
- libtool localbase pathfix localbase:ldflags \
- perl5 pkgconfig python:3.4+ ssl tar:xz
+USES= alias cmake compiler:c++11-lang cpe gettext-runtime gnome \
+ libtool localbase pathfix perl5 pkgconfig python:3.4+ ssl \
+ tar:xz
USE_PERL5= build
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index d65efb1c49bd..18236f27d536 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libicuuc.so:devel/icu \
libgnutls.so:security/gnutls
-USES= iconv libtool ncurses pathfix pkgconfig readline \
+USES= gnome iconv libtool ncurses pathfix pkgconfig readline \
shebangfix tcl
SHEBANG_FILES= util/yaz-asncomp
GNU_CONFIGURE= yes