aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/efl/Makefile1
-rw-r--r--devel/efl/files/patch-src_Makefile.am2
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index 187b0ed22237..6fc022714852 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -86,6 +86,7 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
WAYLAND_BROKEN= WAYLAND option is broken: https://phab.enlightenment.org/T7116
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.7:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libxkbcommon.so:x11/libxkbcommon \
libwayland-client.so:graphics/wayland \
diff --git a/devel/efl/files/patch-src_Makefile.am b/devel/efl/files/patch-src_Makefile.am
index 5a2b6e4290d2..8317f683db41 100644
--- a/devel/efl/files/patch-src_Makefile.am
+++ b/devel/efl/files/patch-src_Makefile.am
@@ -5,7 +5,7 @@
define protoname
-$(shell echo $1 | sed 's/\([a-z\-]\+\)-[a-z]\+-v[0-9]\+/\1/')
-+$(shell echo $1 | gsed 's/\([a-z\-]\+\)-[a-z]\+-v[0-9]\+/\1/')
++$(shell echo $1 | sed -E 's/([a-z\-]+)-[a-z]+-v[0-9]+/\1/')
endef
#rules for generating protocol from wayland_protocols