aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lldb38/Makefile24
-rw-r--r--devel/lldb38/pkg-descr9
-rw-r--r--lang/Makefile1
-rw-r--r--lang/clang38/Makefile18
-rw-r--r--lang/clang38/pkg-descr7
6 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1fc389c8e057..1e3225d7979a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1392,6 +1392,7 @@
SUBDIR += linux_libusb
SUBDIR += lion
SUBDIR += lldb37
+ SUBDIR += lldb38
SUBDIR += llnextgen
SUBDIR += llvm-cheri
SUBDIR += llvm-devel
diff --git a/devel/lldb38/Makefile b/devel/lldb38/Makefile
new file mode 100644
index 000000000000..ec0705e12e51
--- /dev/null
+++ b/devel/lldb38/Makefile
@@ -0,0 +1,24 @@
+# Created by: Brooks Davis
+# $FreeBSD$
+
+PORTNAME= lldb
+PORTVERSION= 3.8
+CATEGORIES= devel
+PKGNAMESUFFIX= ${LLVM_SUFFIX}
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= LLVM Debugger (use devel/llvm${LLVM_SUFFIX})
+
+RUN_DEPENDS+= lldb${LLVM_SUFFIX}:${PORTSDIR}/devel/llvm${LLVM_SUFFIX}
+
+LLVM_SUFFIX= 38
+
+USES= metaport compiler:c++11-lib
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
+IGNORE= The devel/llvm${LLVM_SUFFIX} port does not build lldb on this platform
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/lldb38/pkg-descr b/devel/lldb38/pkg-descr
new file mode 100644
index 000000000000..d9243da27903
--- /dev/null
+++ b/devel/lldb38/pkg-descr
@@ -0,0 +1,9 @@
+LLDB is a next generation, high-performance debugger. It is built as a
+set of reusable components which highly leverage existing libraries in
+the larger LLVM Project, such as the Clang expression parser and LLVM
+disassembler.
+
+This is a meta port. The Clang compiler is installed by the
+devel/llvm-devel port.
+
+WWW: http://lldb.llvm.org/
diff --git a/lang/Makefile b/lang/Makefile
index 9671d401c9f3..2be488d1e592 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -39,6 +39,7 @@
SUBDIR += clang35
SUBDIR += clang36
SUBDIR += clang37
+ SUBDIR += clang38
SUBDIR += clojure
SUBDIR += clojure-mode.el
SUBDIR += cloudabi-clang
diff --git a/lang/clang38/Makefile b/lang/clang38/Makefile
new file mode 100644
index 000000000000..4bee753b615f
--- /dev/null
+++ b/lang/clang38/Makefile
@@ -0,0 +1,18 @@
+# Created by: Brooks Davis
+# $FreeBSD$
+
+PORTNAME= clang
+PORTVERSION= 3.8
+CATEGORIES= lang devel
+PKGNAMESUFFIX= ${LLVM_SUFFIX}
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= C, Objective-C, and C++ compiler (use devel/llvm${LLVM_SUFFIX})
+
+RUN_DEPENDS+= ${LOCALBASE}/bin/clang${LLVM_SUFFIX}:${PORTSDIR}/devel/llvm${LLVM_SUFFIX}
+
+LLVM_SUFFIX= 38
+
+USES= metaport
+
+.include <bsd.port.mk>
diff --git a/lang/clang38/pkg-descr b/lang/clang38/pkg-descr
new file mode 100644
index 000000000000..1df07184406d
--- /dev/null
+++ b/lang/clang38/pkg-descr
@@ -0,0 +1,7 @@
+The goal of the Clang project is to create a new C, C++, Objective C and
+Objective C++ front-end for the LLVM compiler.
+
+This is a meta port. The Clang compiler is installed by the
+devel/llvm-devel port.
+
+WWW: http://clang.llvm.org/