aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/suitesparse-klu/Makefile11
-rw-r--r--math/suitesparse-klu/files/patch-KLU_Demo_Makefile18
-rw-r--r--math/suitesparse-klu/pkg-plist12
3 files changed, 19 insertions, 22 deletions
diff --git a/math/suitesparse-klu/Makefile b/math/suitesparse-klu/Makefile
index 99c6354a0b5f..b871a217f1b4 100644
--- a/math/suitesparse-klu/Makefile
+++ b/math/suitesparse-klu/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ${MPORTNAME:tl}
-PORTVERSION= 1.3.9
+PORTVERSION= 2.0.0
CATEGORIES= math
COMMENT= Sparse LU factorization, for circuit simulation
@@ -16,10 +16,17 @@ LIB_DEPENDS= libmetis.so:math/metis \
libcholmod.so:math/suitesparse-cholmod
USES= localbase:ldflags
-OMP_NEEDED= yes
MPORTNAME= KLU
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+
+post-stage-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/README.txt \
+ ${STAGEDIR}${DOCSDIR}/${MPORTNAME}_README.txt
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/Doc/${MPORTNAME}_UserGuide.pdf \
+ ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.post.mk>
diff --git a/math/suitesparse-klu/files/patch-KLU_Demo_Makefile b/math/suitesparse-klu/files/patch-KLU_Demo_Makefile
deleted file mode 100644
index a8e5fa35797b..000000000000
--- a/math/suitesparse-klu/files/patch-KLU_Demo_Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- KLU/Demo/Makefile.orig 2021-05-17 01:04:52 UTC
-+++ KLU/Demo/Makefile
-@@ -32,15 +32,7 @@ all: library klu_simple kludemo kluldemo
- - ./kluldemo < ../Matrix/ctina.mtx
-
- library:
-- ( cd ../../SuiteSparse_config ; $(MAKE) )
- ( cd ../Lib ; $(MAKE) )
-- ( cd ../../BTF ; $(MAKE) library )
-- ( cd ../../AMD ; $(MAKE) library )
-- ( cd ../../COLAMD ; $(MAKE) library )
-- ( cd ../../CHOLMOD ; $(MAKE) library )
-- - ( cd ../../CAMD ; $(MAKE) )
-- - ( cd ../../CCOLAMD ; $(MAKE) )
-- - ( cd ../.. ; $(MAKE) metis )
-
- purge: distclean
-
diff --git a/math/suitesparse-klu/pkg-plist b/math/suitesparse-klu/pkg-plist
index be3e628039a5..114e475a4888 100644
--- a/math/suitesparse-klu/pkg-plist
+++ b/math/suitesparse-klu/pkg-plist
@@ -1,6 +1,14 @@
+include/suitesparse/klu_cholmod.h
include/suitesparse/klu.h
+lib/cmake/SuiteSparse/FindKLU_CHOLMOD.cmake
+lib/cmake/SuiteSparse/FindKLU.cmake
+lib/libklu_cholmod.a
+lib/libklu_cholmod.so
+lib/libklu_cholmod.so.2
+lib/libklu_cholmod.so.2.0.0
+lib/libklu.a
lib/libklu.so
-lib/libklu.so.1
-lib/libklu.so.1.3.8
+lib/libklu.so.2
+lib/libklu.so.2.0.0
%%PORTDOCS%%%%DOCSDIR%%/KLU_README.txt
%%PORTDOCS%%%%DOCSDIR%%/KLU_UserGuide.pdf