aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/smstools3/Makefile11
-rw-r--r--devel/allegro/Makefile39
-rw-r--r--devel/pear-PhpDocumentor/Makefile5
-rw-r--r--devel/urjtag/Makefile19
4 files changed, 35 insertions, 39 deletions
diff --git a/comms/smstools3/Makefile b/comms/smstools3/Makefile
index a1f4a7018ba8..4387c7ace094 100644
--- a/comms/smstools3/Makefile
+++ b/comms/smstools3/Makefile
@@ -15,7 +15,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SMS Gateway software for GSM modems and mobile phones
CONFLICTS= gnokii-[0-9]* smstools-2.* sendsms-[0-9]*
-OPTIONS= STATS "Build status and statistics support" on
+
+OPTIONS_DEFINE= STATS EXAMPLES DOCS
+OPTIONS_DEFAULT= STATS
+STATS_DESC= Build status and statistics support
WRKSRC= ${WRKDIR}/smstools3
@@ -40,7 +43,7 @@ PORTEXAMPLES= .procmailrc .qmailrc *
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_STATS)
+.if ${PORT_OPTIONS:MSTATS}
LIB_DEPENDS+= mm.14:${PORTSDIR}/devel/mm
CFLAGS+= -I${LOCALBASE}/include
.else
@@ -76,12 +79,12 @@ post-install:
fi
@${MKDIR} ${SPOOLDIR} ${LOGDIR} ${PIDDIR}
@${CHOWN} -R ${SMSD_USER}:${SMSD_GROUP} ${SPOOLDIR} ${LOGDIR} ${PIDDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/slideshow
@${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/doc/slideshow/* ${DOCSDIR}/slideshow
.endif
-.if !defined(NOPORTEXAMPLES)
+,if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@for file in `${FIND} ${WRKSRC}/examples -type f ! -name 'README'`; do \
${INSTALL_SCRIPT} $$file ${EXAMPLESDIR}/; \
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 88d2b891e21c..b48d5cdcd171 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: allegro
-# Date created: 23-Feb-2001
-# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
-#
+# Created by: Jimmy Olgeni <olgeni@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= allegro
DISTVERSION= 4.2.2
@@ -20,14 +16,9 @@ USE_XORG= x11 xpm xext xcursor xxf86vm xxf86dga
USE_LDCONFIG= yes
WANT_GNOME= yes
-OPTIONS= ARTS "Enable Arts support" off \
- DEBUG "Build debugging library" off \
- DEVEL "Build development utilities" on \
- ESOUND "Enable Esound support" off \
- JACK "Enable JACK support" off \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- PROFILE "Build profiling library" off \
- THREADS "Enable threads" on
+OPTIONS_DEFINE= ARTS DEBUG DEVEL ESOUND JACK OPTIMIZED_CFLAGS PROFILE THREADS
+OPTIONS_DEFAULT= DEVEL OPTIMIZED_CFLAGS THREADS
+DEVEL_DESC= Install development utilities
MAKEFILE= makefile
ALL_TARGET= full-build
@@ -48,8 +39,8 @@ PORTSCOUT= limitw:1,even
.include <bsd.port.pre.mk>
-.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+.if ${PORT_OPTIONS:MARTS}
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+=--enable-artsdigi
PLIST_SUB+= ARTS=""
.else
@@ -57,7 +48,7 @@ CONFIGURE_ARGS+=--disable-artsdigi
PLIST_SUB+= ARTS="@comment "
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-dbglib
PLIST_SUB+= DEBUG=""
.else
@@ -65,7 +56,7 @@ CONFIGURE_ARGS+=--disable-dbglib
PLIST_SUB+= DEBUG="@comment "
.endif
-.if !defined(WITHOUT_DEVEL)
+.if ${PORT_OPTIONS:MDEVEL}
INSTALL_TARGET= full-install install-man install-info
PLIST_SUB+= DEVEL=""
.else
@@ -73,7 +64,7 @@ INSTALL_TARGET= mini-install install-man install-info
PLIST_SUB+= DEVEL="@comment "
.endif
-.if defined(WITH_ESOUND)
+.if ${PORT_OPTIONS:MESOUNS}
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-esddigi
PLIST_SUB+= ESOUND=""
@@ -82,8 +73,8 @@ CONFIGURE_ARGS+=--disable-esddigi
PLIST_SUB+= ESOUND="@comment "
.endif
-.if defined(WITH_JACK)
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+.if ${PORT_OPTIONS:MJACK}
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
CONFIGURE_ARGS+=--enable-jackdigi
PLIST_SUB+= JACK=""
.else
@@ -91,7 +82,7 @@ CONFIGURE_ARGS+=--disable-jackdigi
PLIST_SUB+= JACK="@comment "
.endif
-.if defined(WITH_PROFILE)
+.if ${PORT_OPTIONS:MPROFILE}
CONFIGURE_ARGS+=--enable-proflib
PLIST_SUB+= PROFILE=""
.else
@@ -99,7 +90,7 @@ CONFIGURE_ARGS+=--disable-proflib
PLIST_SUB+= PROFILE="@comment "
.endif
-.if !defined(WITHOUT_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+=--enable-pthreads
CPPFLAGS+= ${PTHREAD_CFLAGS} -DHAVE_LIBPTHREAD
LDFLAGS+= ${PTHREAD_LIBS}
@@ -123,7 +114,7 @@ post-patch:
.endif
# Enable/disable compilation optimizations.
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
@${REINPLACE_CMD} -e 's|-O2||g ; \
s|-ffast-math||g ; \
s|-fomit-frame-pointer||g ; \
@@ -133,7 +124,7 @@ post-patch:
post-install:
# Documentation.
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/html/*.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/html/*.css ${DOCSDIR}
diff --git a/devel/pear-PhpDocumentor/Makefile b/devel/pear-PhpDocumentor/Makefile
index 1a89a078bcfa..d5705b3bccfd 100644
--- a/devel/pear-PhpDocumentor/Makefile
+++ b/devel/pear-PhpDocumentor/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= pear-PHPDoc-[0-9]*
LATEST_LINK= pear-${PORTNAME}
-OPTIONS= XML_BEAUTIFIER "XML_Beautifier support" off
+OPTIONS_DEFINE= XML_BEAUTIFIER
+XML_BEAUTIFIER_DESC= XML_Beautifier support
CATEGORY= PhpDocumentor
FILES= HTML_TreeMenu-1.1.2/TreeMenu.php \
@@ -1250,7 +1251,7 @@ SUBFILES= phpDocumentor/Converter.inc \
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.if defined(WITH_XML_BEAUTIFIER)
+.if ${PORT_OPTIONS:MXML_BEAUTIFIER}
RUN_DEPENDS+= ${PEARDIR}/XML/Beautifier.php:${PORTSDIR}/textproc/pear-XML_Beautifier
.endif
diff --git a/devel/urjtag/Makefile b/devel/urjtag/Makefile
index 9f217005448d..e73bee605bd2 100644
--- a/devel/urjtag/Makefile
+++ b/devel/urjtag/Makefile
@@ -23,18 +23,19 @@ CFLAGS+= --std=c99
MAN1= jtag.1 bsdl2jtag.1
-OPTIONS= \
- USB "Build support for USB JTAG adapters" On \
- FTDI "Build support for FTDI-based USB JTAG adapters" On \
- JEDEC "Enable experimental JEDEC flash detection" Off
+OPTIONS_DEFINE= USB FTDI JEDEC NLS
+OPTIONS_DEFAULT= USB FTDI
+USB_DESC= Build support for USB JTAG adapters
+FTDI_DESC= Build support for FTDI-based USB JTAG adapters
+JEDEC_DESC= Enable experimental JEDEC flash detection
.include <bsd.port.pre.mk>
-.if defined(WITH_JEDEC)
+.if ${PORT_OPTIONS:MJEDEC}
CONFIGURE_ARGS+= --enable-jedec
.endif
-.if !defined(WITHOUT_USB)
+.if ${PORT_OPTIONS:MUSB}
CONFIGURE_ARGS+= --with-libusb
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
@@ -43,16 +44,16 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-usb
. endif
.endif
-.if !defined(WITHOUT_FTDI)
+.if ${PORT_OPTIONS:MFTDI}
CONFIGURE_ARGS+= --with-libftdi
-LIB_DEPENDS+= ftdi.19:${PORTSDIR}/devel/libftdi
+LIB_DEPENDS+= ftdi:${PORTSDIR}/devel/libftdi
.endif
.if exists(${LOCALBASE}/lib/libreadline.so.6)
LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else