aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/vifm/Makefile9
-rw-r--r--multimedia/dvbsnoop/Makefile5
-rw-r--r--print/openprinting/Makefile9
3 files changed, 9 insertions, 14 deletions
diff --git a/misc/vifm/Makefile b/misc/vifm/Makefile
index 4afb02007a1a..fec00768fab7 100644
--- a/misc/vifm/Makefile
+++ b/misc/vifm/Makefile
@@ -19,15 +19,14 @@ CONFIGURE_ARGS= --without-gtk
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
-MAN1= vifm.1 \
- vifm-pause.1 \
- vifmrc-converter.1
PLIST_FILES= bin/vifm \
bin/vifmrc-converter \
bin/vifm-pause \
%%DATADIR%%/vifm-help.txt \
- %%DATADIR%%/vifmrc
+ %%DATADIR%%/vifmrc \
+ man/man1/vifm-pause.1.gz \
+ man/man1/vifm.1.gz \
+ man/man1/vifmrc-converter.1.gz
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/multimedia/dvbsnoop/Makefile b/multimedia/dvbsnoop/Makefile
index 89cbfab3b566..6f23aad2338f 100644
--- a/multimedia/dvbsnoop/Makefile
+++ b/multimedia/dvbsnoop/Makefile
@@ -15,10 +15,9 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}
USE_GMAKE= yes
-PLIST_FILES= bin/${PORTNAME}
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/dvbsnoop.1.gz
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
diff --git a/print/openprinting/Makefile b/print/openprinting/Makefile
index 5828b1573b6b..7fb009041e40 100644
--- a/print/openprinting/Makefile
+++ b/print/openprinting/Makefile
@@ -17,8 +17,7 @@ COMMENT= Sun's implementation of the OpenPrinting API (PAPI)
WRKSRC= ${WRKDIR}/papi-${PORTVERSION}_beta
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext iconv
+USES= gettext iconv gmake
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/libexec
@@ -44,7 +43,6 @@ MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
# MOD_IPP "Build example mod_ipp.so for Apache" Off
# PSM_CUPS "Build psm_cups.so for printing to CUPS" Off
-NO_STAGE= yes
.include <bsd.port.options.mk>
# NOTE: hard dependency on gettext() in distfiles.
@@ -69,8 +67,6 @@ CONFIGURE_ARGS+=--with-cups=${LOCALBASE}
CONFIGURE_ARGS+=--without-cups
.endif
-MANCOMPRESSED= no
-MAN5= psm-ipp.5
PLIST_DIRS+= man/mani
@@ -97,7 +93,8 @@ PLIST_FILES+=\
libexec/psm-lpd.la \
libexec/psm-ipp.so \
libexec/psm-ipp.la \
- libexec/lpd-port
+ libexec/lpd-port \
+ man/man5/psm-ipp.5.gz
.if defined(WITH_PSM_CUPS)
PLIST_FILES+=\