aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/installwatch/Makefile16
-rw-r--r--sysutils/installwatch/distinfo1
-rw-r--r--sysutils/installwatch/files/patch-aa40
-rw-r--r--sysutils/installwatch/pkg-comment1
-rw-r--r--sysutils/installwatch/pkg-descr11
-rw-r--r--sysutils/installwatch/pkg-plist3
7 files changed, 73 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index e814b4348666..46cd3fcf52fb 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -53,6 +53,7 @@
SUBDIR += healthd
SUBDIR += heat
SUBDIR += idled
+ SUBDIR += installwatch
SUBDIR += ipa
SUBDIR += ipsc
SUBDIR += lavaps
diff --git a/sysutils/installwatch/Makefile b/sysutils/installwatch/Makefile
new file mode 100644
index 000000000000..c7640f5e70f1
--- /dev/null
+++ b/sysutils/installwatch/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: installwatch
+# Date created: 03 March 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= installwatch
+PORTVERSION= 0.5.6
+CATEGORIES= sysutils
+MASTER_SITES= http://mayams.net/~izto/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+.include <bsd.port.mk>
diff --git a/sysutils/installwatch/distinfo b/sysutils/installwatch/distinfo
new file mode 100644
index 000000000000..8d8b602d1472
--- /dev/null
+++ b/sysutils/installwatch/distinfo
@@ -0,0 +1 @@
+MD5 (installwatch-0.5.6.tgz) = 678077bad78ff57d9b63141fb73be84e
diff --git a/sysutils/installwatch/files/patch-aa b/sysutils/installwatch/files/patch-aa
new file mode 100644
index 000000000000..87d52810c07e
--- /dev/null
+++ b/sysutils/installwatch/files/patch-aa
@@ -0,0 +1,40 @@
+--- Makefile.orig Fri Mar 2 02:45:41 2001
++++ Makefile Sat Mar 3 02:17:12 2001
+@@ -3,7 +3,7 @@
+ # Well, the only configurable part is the following variable.
+ # Make sure the directory you specify exists.
+
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # End of configurable part
+
+@@ -15,10 +15,10 @@
+ all: installwatch.so
+
+ installwatch.so: installwatch.o
+- ld -shared -o installwatch.so installwatch.o -ldl
++ ld -shared -o installwatch.so installwatch.o
+
+ installwatch.o: installwatch.c localdecls.h
+- gcc -Wall -c -DPIC -fPIC -D_REENTRANT -DVERSION=\"$(VERSION)\" installwatch.c
++ $(CC) -Wall -c $(CFLAGS) -DPIC -fPIC -D_REENTRANT -DVERSION=\"$(VERSION)\" installwatch.c
+
+ localdecls.h:
+ ./create-localdecls
+@@ -28,8 +28,6 @@
+
+ sed -e "s|#PREFIX#|$(PREFIX)|" < installwatch > $(BINDIR)/installwatch
+ chmod 755 $(BINDIR)/installwatch
+- cp contrib/inst2rpm $(BINDIR)/inst2rpm
+- chmod 755 $(BINDIR)/inst2rpm
+
+ uninstall:
+ rm $(LIBDIR)/installwatch.so
+@@ -43,7 +41,7 @@
+ tar -czvC .. -f ../installwatch-$(VERSION).tar.gz installwatch-$(VERSION)
+
+ test: install
+- gcc -Wall -DVERSION=\"$(VERSION)\" -o test-installwatch test-installwatch.c -ldl
++ gcc -Wall -DVERSION=\"$(VERSION)\" -o test-installwatch test-installwatch.c
+ $(PREFIX)/bin/installwatch ./test-installwatch
diff --git a/sysutils/installwatch/pkg-comment b/sysutils/installwatch/pkg-comment
new file mode 100644
index 000000000000..6bebe48e5f88
--- /dev/null
+++ b/sysutils/installwatch/pkg-comment
@@ -0,0 +1 @@
+A file creation/modification logger
diff --git a/sysutils/installwatch/pkg-descr b/sysutils/installwatch/pkg-descr
new file mode 100644
index 000000000000..137a0317e635
--- /dev/null
+++ b/sysutils/installwatch/pkg-descr
@@ -0,0 +1,11 @@
+Installwatch is a simple utility which keeps track of which files are
+created and modified during the installation of a new program. It's
+fast and easy to use. It doesn't require a "pre-install" phase because
+it monitors processes while they run. Installwatch works with every
+dynamically linked ELF program, by intercepting system calls that
+cause file system alterations.
+
+WWW: http://mayams.net/~izto/installwatch.html
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/sysutils/installwatch/pkg-plist b/sysutils/installwatch/pkg-plist
new file mode 100644
index 000000000000..786a0a02a879
--- /dev/null
+++ b/sysutils/installwatch/pkg-plist
@@ -0,0 +1,3 @@
+bin/installwatch
+lib/installwatch.so
+