aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-prometheus-client-mmap/Makefile19
-rw-r--r--devel/rubygem-prometheus-client-mmap/distinfo3
-rw-r--r--devel/rubygem-prometheus-client-mmap/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3628a198ac8f..66038d33d672 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5628,6 +5628,7 @@
SUBDIR += rubygem-pqueue
SUBDIR += rubygem-progressbar
SUBDIR += rubygem-progressbar09
+ SUBDIR += rubygem-prometheus-client-mmap
SUBDIR += rubygem-protected_attributes
SUBDIR += rubygem-protocol
SUBDIR += rubygem-pry
diff --git a/devel/rubygem-prometheus-client-mmap/Makefile b/devel/rubygem-prometheus-client-mmap/Makefile
new file mode 100644
index 000000000000..0e083f068532
--- /dev/null
+++ b/devel/rubygem-prometheus-client-mmap/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= prometheus-client-mmap
+DISTVERSION= 0.7.0.beta5
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Suite of instrumentation metric primitives
+
+LICENSE= RUBY
+
+RUN_DEPENDS= rubygem-mmap2>=2.2.6:devel/rubygem-mmap2
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-prometheus-client-mmap/distinfo b/devel/rubygem-prometheus-client-mmap/distinfo
new file mode 100644
index 000000000000..08f5c8758e8c
--- /dev/null
+++ b/devel/rubygem-prometheus-client-mmap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504198010
+SHA256 (rubygem/prometheus-client-mmap-0.7.0.beta5.gem) = 1f2b1ef008b7c7d9d100cf31636bad74bbd5cfbf5f737e1b70be17a2347a8485
+SIZE (rubygem/prometheus-client-mmap-0.7.0.beta5.gem) = 14336
diff --git a/devel/rubygem-prometheus-client-mmap/pkg-descr b/devel/rubygem-prometheus-client-mmap/pkg-descr
new file mode 100644
index 000000000000..f09363771934
--- /dev/null
+++ b/devel/rubygem-prometheus-client-mmap/pkg-descr
@@ -0,0 +1,8 @@
+This Prometheus library is fork of Prometheus Ruby Client that uses mmap'ed
+files to share metrics from multiple processes. This allows efficient metrics
+processing for Ruby web apps running in multiprocess setups like Unicorn.
+
+A suite of instrumentation metric primitives for Ruby that can be exposed
+through a HTTP interface. Intended to be used together with a Prometheus server.
+
+WWW: https://gitlab.com/gitlab-org/prometheus-client-mmap