aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-hdfs/Makefile23
-rw-r--r--www/py-hdfs/distinfo3
-rw-r--r--www/py-hdfs/pkg-descr1
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bba73d24a9ec..b1c6c7134da2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1647,6 +1647,7 @@
SUBDIR += py-gunicorn
SUBDIR += py-h2
SUBDIR += py-habanero
+ SUBDIR += py-hdfs
SUBDIR += py-horizon
SUBDIR += py-hpack
SUBDIR += py-hstspreload
diff --git a/www/py-hdfs/Makefile b/www/py-hdfs/Makefile
new file mode 100644
index 000000000000..b02eb0606f65
--- /dev/null
+++ b/www/py-hdfs/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= hdfs
+DISTVERSION= 2.7.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= HdfsCLI: API and command line interface for HDFS
+WWW= https://hdfscli.readthedocs.io/en/latest/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docopt>0:devel/py-docopt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.7.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist # tests require nose which is unmaintained and abandoned, see https://github.com/mtth/hdfs/issues/190
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-hdfs/distinfo b/www/py-hdfs/distinfo
new file mode 100644
index 000000000000..8797aea71909
--- /dev/null
+++ b/www/py-hdfs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1665349475
+SHA256 (hdfs-2.7.0.tar.gz) = ecd4650c39bb4f9421641320f4931edd81cf7126ae4e5ec880215adf6435df3d
+SIZE (hdfs-2.7.0.tar.gz) = 43407
diff --git a/www/py-hdfs/pkg-descr b/www/py-hdfs/pkg-descr
new file mode 100644
index 000000000000..e8f27852db0e
--- /dev/null
+++ b/www/py-hdfs/pkg-descr
@@ -0,0 +1 @@
+API and command line interface for HDFS.