aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/ftpcopy/Makefile3
-rw-r--r--ftp/ftpsync/Makefile2
-rw-r--r--ftp/mirror/Makefile2
-rw-r--r--ftp/p5-Net-FTP-Common/Makefile3
-rw-r--r--ftp/p5-Net-FTP-Recursive/Makefile3
-rw-r--r--misc/cloc/Makefile3
-rw-r--r--misc/ipbt/Makefile2
-rw-r--r--misc/lesspipe/Makefile2
-rw-r--r--misc/p5-Asterisk-FastAGI/Makefile3
-rw-r--r--misc/p5-Bot-Training-StarCraft/Makefile3
-rw-r--r--misc/p5-Bot-Training/Makefile3
-rw-r--r--misc/p5-Business-ISBN-Data/Makefile3
-rw-r--r--misc/p5-I18N-Charset/Makefile3
-rw-r--r--misc/p5-Locale-Codes/Makefile3
-rw-r--r--misc/p5-Test-Dir/Makefile3
-rw-r--r--misc/sloccount/Makefile2
-rw-r--r--misc/translate/Makefile2
-rw-r--r--news/c-nocem/Makefile2
-rw-r--r--news/cleanfeed/Makefile2
-rw-r--r--news/fidogate-ds/Makefile2
-rw-r--r--news/husky-hpt-devel/Makefile2
-rw-r--r--news/husky-hpt/Makefile2
-rw-r--r--news/newsgrab/Makefile2
-rw-r--r--news/p5-NNML/Makefile3
-rw-r--r--news/p5-NNTPClient/Makefile3
-rw-r--r--news/p5-News-Article-NoCeM/Makefile3
-rw-r--r--news/slrnconf/Makefile2
-rw-r--r--news/ubh/Makefile2
28 files changed, 42 insertions, 28 deletions
diff --git a/ftp/ftpcopy/Makefile b/ftp/ftpcopy/Makefile
index dfb9e4584e1d..d46649b982a9 100644
--- a/ftp/ftpcopy/Makefile
+++ b/ftp/ftpcopy/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://www.ohse.de/uwe/ftpcopy/
MAINTAINER= mandree@FreeBSD.org
COMMENT= Command line ftp tools for listing and mirroring
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
WRKSRC= ${WRKDIR}/web/${DISTNAME}
diff --git a/ftp/ftpsync/Makefile b/ftp/ftpsync/Makefile
index ebdd9393feaf..11013a18d92f 100644
--- a/ftp/ftpsync/Makefile
+++ b/ftp/ftpsync/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/${PORTNAME}.pl
PORTDOCS= README
diff --git a/ftp/mirror/Makefile b/ftp/mirror/Makefile
index e91da6bf9a0f..b642a5838101 100644
--- a/ftp/mirror/Makefile
+++ b/ftp/mirror/Makefile
@@ -31,7 +31,7 @@ PLIST_FILES= bin/mirror \
PLIST_DIRS= lib/mirror
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
MAKEFILE= makefile
MAN1= mirror.1 mirror-master.1
diff --git a/ftp/p5-Net-FTP-Common/Makefile b/ftp/p5-Net-FTP-Common/Makefile
index 388a0ba0bf24..258d20b56f48 100644
--- a/ftp/p5-Net-FTP-Common/Makefile
+++ b/ftp/p5-Net-FTP-Common/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl module to provide simplify common usages of Net::FTP
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTP::Common.3
diff --git a/ftp/p5-Net-FTP-Recursive/Makefile b/ftp/p5-Net-FTP-Recursive/Makefile
index 304302a89e3b..38c9435e7ca8 100644
--- a/ftp/p5-Net-FTP-Recursive/Makefile
+++ b/ftp/p5-Net-FTP-Recursive/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTP::Recursive.3
diff --git a/misc/cloc/Makefile b/misc/cloc/Makefile
index 8d0e2298af4a..27e22ccf66aa 100644
--- a/misc/cloc/Makefile
+++ b/misc/cloc/Makefile
@@ -12,7 +12,8 @@ COMMENT= Counts lines of code
RUN_DEPENDS= p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ./${PORTNAME}
diff --git a/misc/ipbt/Makefile b/misc/ipbt/Makefile
index 53fe338e0216..a8979aa39b2d 100644
--- a/misc/ipbt/Makefile
+++ b/misc/ipbt/Makefile
@@ -17,7 +17,7 @@ COMMENT= A high-tech ttyrec player with improvements over ttyplay
MAN1= ipbt.1
-USE_PERL5= yes
+USES= perl5
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/ipbt bin/ttygrep bin/ttydump
diff --git a/misc/lesspipe/Makefile b/misc/lesspipe/Makefile
index dc2d938541ad..79d736b742dd 100644
--- a/misc/lesspipe/Makefile
+++ b/misc/lesspipe/Makefile
@@ -26,7 +26,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
cdrecord:${PORTSDIR}/sysutils/cdrtools
.endif
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
HAS_CONFIGURE= yes
diff --git a/misc/p5-Asterisk-FastAGI/Makefile b/misc/p5-Asterisk-FastAGI/Makefile
index 0002cb4387e1..2ecc3243e5a8 100644
--- a/misc/p5-Asterisk-FastAGI/Makefile
+++ b/misc/p5-Asterisk-FastAGI/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install \
RUN_DEPENDS= p5-Asterisk>=0:${PORTSDIR}/misc/p5-Asterisk \
p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Asterisk::FastAGI.3
diff --git a/misc/p5-Bot-Training-StarCraft/Makefile b/misc/p5-Bot-Training-StarCraft/Makefile
index 6ce3dd3993de..300a721c087a 100644
--- a/misc/p5-Bot-Training-StarCraft/Makefile
+++ b/misc/p5-Bot-Training-StarCraft/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-File-ShareDir-Install>=0.03:${PORTSDIR}/devel/p5-File-ShareDir
RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-Bot-Training>=0:${PORTSDIR}/misc/p5-Bot-Training
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Bot::Training::StarCraft.3
diff --git a/misc/p5-Bot-Training/Makefile b/misc/p5-Bot-Training/Makefile
index 174a90a7962d..54ae00a589ca 100644
--- a/misc/p5-Bot-Training/Makefile
+++ b/misc/p5-Bot-Training/Makefile
@@ -30,7 +30,8 @@ BUILD_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= bot-training.1
MAN3= Bot::Training.3
diff --git a/misc/p5-Business-ISBN-Data/Makefile b/misc/p5-Business-ISBN-Data/Makefile
index e4e8bd2ea7b7..4e07a9de63ea 100644
--- a/misc/p5-Business-ISBN-Data/Makefile
+++ b/misc/p5-Business-ISBN-Data/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= leeym@FreeBSD.org
COMMENT= Data pack for Business::ISBN
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::ISBN::Data.3
diff --git a/misc/p5-I18N-Charset/Makefile b/misc/p5-I18N-Charset/Makefile
index f67f3ae33006..b5d2ea514b5c 100644
--- a/misc/p5-I18N-Charset/Makefile
+++ b/misc/p5-I18N-Charset/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-IO-Capture>=0:${PORTSDIR}/devel/p5-IO-Capture
RUN_DEPENDS= p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
p5-Unicode-MapUTF8>=0:${PORTSDIR}/converters/p5-Unicode-MapUTF8
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= I18N::Charset.3
diff --git a/misc/p5-Locale-Codes/Makefile b/misc/p5-Locale-Codes/Makefile
index e39e809c2897..756d0309392f 100644
--- a/misc/p5-Locale-Codes/Makefile
+++ b/misc/p5-Locale-Codes/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl5 module providing access to ISO3166 and ISO639 Country Codes
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Locale::Codes.3 Locale::Codes::API.3 Locale::Codes::Changes.3 \
Locale::Codes::Constants.3 Locale::Codes::Country.3 \
diff --git a/misc/p5-Test-Dir/Makefile b/misc/p5-Test-Dir/Makefile
index 4f1f6f61d7a1..2b129cb538c3 100644
--- a/misc/p5-Test-Dir/Makefile
+++ b/misc/p5-Test-Dir/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kiwi@oav.net
COMMENT= Test directory attributes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Dir.3 \
Test::Dir::Base.3 \
diff --git a/misc/sloccount/Makefile b/misc/sloccount/Makefile
index 5c7bedc50a0b..af2eaa213b95 100644
--- a/misc/sloccount/Makefile
+++ b/misc/sloccount/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.dwheeler.com/sloccount/
MAINTAINER= freaky@aagh.net
COMMENT= Counts physical Source Lines of Code (SLOC)
-USE_PERL5= yes
+USES= perl5
MAKEFILE= makefile
INSTALL_TARGET= install_programs install_man
diff --git a/misc/translate/Makefile b/misc/translate/Makefile
index acfeb8eafd0d..13d8a640d948 100644
--- a/misc/translate/Makefile
+++ b/misc/translate/Makefile
@@ -16,7 +16,7 @@ COMMENT= Translates string using Babelfish
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/news/c-nocem/Makefile b/news/c-nocem/Makefile
index 74e2de54b904..a812041b30bb 100644
--- a/news/c-nocem/Makefile
+++ b/news/c-nocem/Makefile
@@ -22,7 +22,7 @@ CNEWS_PORT?= news/cnews
CNEWSWRK?= ${WRKDIRPREFIX}${.CURDIR}/../../${CNEWS_PORT}/work
NEWSBIN?= ${PREFIX}/libexec/cnews
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-cnews=${CNEWSWRK}
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
diff --git a/news/cleanfeed/Makefile b/news/cleanfeed/Makefile
index cfc092feb466..f83962c2d43e 100644
--- a/news/cleanfeed/Makefile
+++ b/news/cleanfeed/Makefile
@@ -16,7 +16,7 @@ COMMENT= Spam filter for Usenet news servers
RUN_DEPENDS= ${LOCALBASE}/news/bin/innd:${PORTSDIR}/news/inn
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
BINOWN= news
BINGRP= news
SHAREOWN= news
diff --git a/news/fidogate-ds/Makefile b/news/fidogate-ds/Makefile
index 9fb772c3fe1e..1ca6b3d2abb6 100644
--- a/news/fidogate-ds/Makefile
+++ b/news/fidogate-ds/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/news/bin/innconfval:${PORTSDIR}/news/inn
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
MAKE_JOBS_UNSAFE= yes
SPOOLDIR?=/var/spool/fido/gate
diff --git a/news/husky-hpt-devel/Makefile b/news/husky-hpt-devel/Makefile
index 80ec7f0a24b2..28ce59a84fd1 100644
--- a/news/husky-hpt-devel/Makefile
+++ b/news/husky-hpt-devel/Makefile
@@ -15,7 +15,7 @@ CONFLICTS= husky-hpt-[0-9]*
.if !defined(WITHOUT_PERL)
MAKE_ARGS+= PERL=1
-USE_PERL5= yes
+USES= perl5
.else
MAKE_ARGS+= PERL=0
.endif
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
index bb65a47508a8..ffb685181dfc 100644
--- a/news/husky-hpt/Makefile
+++ b/news/husky-hpt/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= husky-hpt-devel-[0-9]*
.if !defined(WITHOUT_PERL)
MAKE_ARGS+= PERL=1
-USE_PERL5= yes
+USES= perl5
.else
MAKE_ARGS+= PERL=0
.endif
diff --git a/news/newsgrab/Makefile b/news/newsgrab/Makefile
index b009931efafc..f5876e95aec5 100644
--- a/news/newsgrab/Makefile
+++ b/news/newsgrab/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-NNTPClient>=0:${PORTSDIR}/news/p5-NNTPClient \
p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
post-patch:
@${REINPLACE_CMD} -e 's|^#!/usr/bin/perl|#!${PERL}|' ${WRKSRC}/newsgrab.pl
diff --git a/news/p5-NNML/Makefile b/news/p5-NNML/Makefile
index e7eab997e564..ebb2b6c97c1d 100644
--- a/news/p5-NNML/Makefile
+++ b/news/p5-NNML/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= A minimal NNTP server
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
RESTRICTED= License unknown
diff --git a/news/p5-NNTPClient/Makefile b/news/p5-NNTPClient/Makefile
index 185d0a53bacd..17f2168b3c0c 100644
--- a/news/p5-NNTPClient/Makefile
+++ b/news/p5-NNTPClient/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gary@hayers.org
COMMENT= Client interface to NNTP (RFC977)
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::NNTPClient.3
diff --git a/news/p5-News-Article-NoCeM/Makefile b/news/p5-News-Article-NoCeM/Makefile
index 26d56ef7f82c..dbf6ed8d1b2c 100644
--- a/news/p5-News-Article-NoCeM/Makefile
+++ b/news/p5-News-Article-NoCeM/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-News-Article>=0:${PORTSDIR}/news/p5-News-Article \
p5-PGP-Sign>=0:${PORTSDIR}/security/p5-PGP-Sign
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::Article::NoCeM.3
diff --git a/news/slrnconf/Makefile b/news/slrnconf/Makefile
index fafa2455d026..118dbeefe2d6 100644
--- a/news/slrnconf/Makefile
+++ b/news/slrnconf/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
MAKE_ARGS+= PREFIX=${PREFIX}
do-install:
diff --git a/news/ubh/Makefile b/news/ubh/Makefile
index 704288741358..a6fc9a87e616 100644
--- a/news/ubh/Makefile
+++ b/news/ubh/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= \
p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32
NO_BUILD= YES
-USE_PERL5= YES
+USES= perl5
pre-patch:
@${MV} ${WRKSRC}/ubh ${WRKSRC}/ubh.old