aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/py-nicotine-plus/Makefile24
-rw-r--r--net-p2p/py-nicotine-plus/distinfo3
-rw-r--r--net-p2p/py-nicotine-plus/pkg-descr7
4 files changed, 35 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 031e9a9f762f..fca83dad23f1 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -69,6 +69,7 @@
SUBDIR += p5-WWW-BitTorrent
SUBDIR += phex
SUBDIR += py-libtorrent-rasterbar
+ SUBDIR += py-nicotine-plus
SUBDIR += py-transmission-rpc
SUBDIR += py-tremc
SUBDIR += py-vertex
diff --git a/net-p2p/py-nicotine-plus/Makefile b/net-p2p/py-nicotine-plus/Makefile
new file mode 100644
index 000000000000..c44bb1999077
--- /dev/null
+++ b/net-p2p/py-nicotine-plus/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= nicotine-plus
+DISTVERSION= 3.1.1
+CATEGORIES= net-p2p python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Graphical client for the Soulseek file sharing network
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.42:audio/py-mutagen@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject3>=3.16:devel/py-gobject3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gdbm>=3.6:databases/py-gdbm@${PY_FLAVOR}
+
+USES= python:3.6+ gnome gettext-tools
+USE_GNOME= gtk30
+USE_PYTHON= distutils concurrent autoplist
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -v -m unittest
+
+.include <bsd.port.mk>
diff --git a/net-p2p/py-nicotine-plus/distinfo b/net-p2p/py-nicotine-plus/distinfo
new file mode 100644
index 000000000000..e3f093f61852
--- /dev/null
+++ b/net-p2p/py-nicotine-plus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1628421612
+SHA256 (nicotine-plus-3.1.1.tar.gz) = ce8342fcbc4d6fd50b9c29465eaca45d35c8c7be0a3ef03f5c1d9a594d96ec34
+SIZE (nicotine-plus-3.1.1.tar.gz) = 1556808
diff --git a/net-p2p/py-nicotine-plus/pkg-descr b/net-p2p/py-nicotine-plus/pkg-descr
new file mode 100644
index 000000000000..2f41ba08ad54
--- /dev/null
+++ b/net-p2p/py-nicotine-plus/pkg-descr
@@ -0,0 +1,7 @@
+Nicotine-Plus is a fork of Hyriand's original Nicotine Soulseek client.
+
+Nicotine+ is an attempt to keep Nicotine working with the latest libraries,
+kill bugs, keep current with the Soulseek protocol and add some new features
+that users want and/or need. The main developer now is daelstorm.
+
+WWW: https://github.com/Nicotine-Plus/nicotine-plus/