aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/dovecot-antispam/Makefile3
-rw-r--r--mail/ecartis/Makefile2
-rw-r--r--mail/evolution-mapi/Makefile3
-rw-r--r--mail/exact/Makefile2
-rw-r--r--mail/gnarwl/Makefile3
-rw-r--r--mail/ifile/Makefile2
-rw-r--r--mail/nmzmail/Makefile2
-rw-r--r--mail/p3scan/Makefile2
-rw-r--r--mail/pop3vscan/Makefile2
-rw-r--r--mail/popular/Makefile3
-rw-r--r--mail/postfix-policyd-sf/Makefile2
-rw-r--r--mail/proxsmtp/Makefile2
-rw-r--r--mail/synonym/Makefile2
-rw-r--r--mail/vm/Makefile2
-rw-r--r--mail/xfaces/Makefile3
15 files changed, 15 insertions, 20 deletions
diff --git a/mail/dovecot-antispam/Makefile b/mail/dovecot-antispam/Makefile
index 68f009fe8c02..e2f101fa1ce3 100644
--- a/mail/dovecot-antispam/Makefile
+++ b/mail/dovecot-antispam/Makefile
@@ -17,8 +17,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/mail/dovecot:configure
RUN_DEPENDS= dovecot>=1.1.2:${PORTSDIR}/mail/dovecot
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/dovecot/imap
MAN7= dovecot-antispam.7
diff --git a/mail/ecartis/Makefile b/mail/ecartis/Makefile
index b643c52067ed..4dfcad924280 100644
--- a/mail/ecartis/Makefile
+++ b/mail/ecartis/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.s/-snap/}
MAINTAINER= jtrigg@spamcop.net
COMMENT= The Ecartis Listserver \ Mailing List Manager
-USE_GMAKE= yes
+USES= gmake
NO_PACKAGE= Requires ecartis uid
IS_INTERACTIVE= "Stops to ask to create ecartis user/group"
diff --git a/mail/evolution-mapi/Makefile b/mail/evolution-mapi/Makefile
index 93d10ee6a9cc..74bb9a8d9495 100644
--- a/mail/evolution-mapi/Makefile
+++ b/mail/evolution-mapi/Makefile
@@ -20,8 +20,7 @@ PKGFILES= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin.pc
IGNORE= doesn't build with current libmapi
-USES= gettext tar:bzip2
-USE_GMAKE= yes
+USES= gettext tar:bzip2 gmake
USE_GNOME= evolutiondataserver
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/mail/exact/Makefile b/mail/exact/Makefile
index 62582847dc85..b8ad19d71eed 100644
--- a/mail/exact/Makefile
+++ b/mail/exact/Makefile
@@ -17,7 +17,7 @@ EXACTDIR?= /var/exact
PLIST_SUB+= MAILUSER=${MAILUSER} MAILGROUP=${MAILGROUP} EXACTDIR=${EXACTDIR}
FETCH_CMD= /usr/bin/fetch -Rr
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-user=${MAILUSER} \
--with-group=${MAILGROUP} \
diff --git a/mail/gnarwl/Makefile b/mail/gnarwl/Makefile
index 2120b490c138..06b9a26679e4 100644
--- a/mail/gnarwl/Makefile
+++ b/mail/gnarwl/Makefile
@@ -14,8 +14,7 @@ COMMENT= Email autoresponder that gets data from LDAP
LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
-USE_GMAKE= yes
-USES= iconv
+USES= iconv gmake
USE_OPENLDAP= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
diff --git a/mail/ifile/Makefile b/mail/ifile/Makefile
index acbd3585550a..e6a8a3cafc37 100644
--- a/mail/ifile/Makefile
+++ b/mail/ifile/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://people.csail.mit.edu/jrennie/ifile/
MAINTAINER= ports@FreeBSD.org
COMMENT= An application of machine learning to e-mail filtering
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_CSTD= gnu89
diff --git a/mail/nmzmail/Makefile b/mail/nmzmail/Makefile
index 6c223dc8c48c..fc8a213ec4c1 100644
--- a/mail/nmzmail/Makefile
+++ b/mail/nmzmail/Makefile
@@ -13,7 +13,7 @@ COMMENT= Fast mail searching for mutt
RUN_DEPENDS= namazu:${PORTSDIR}/databases/namazu2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/nmzmail
PORTDOCS= README NEWS
diff --git a/mail/p3scan/Makefile b/mail/p3scan/Makefile
index 69b39915e25d..10fbc93dc83e 100644
--- a/mail/p3scan/Makefile
+++ b/mail/p3scan/Makefile
@@ -17,7 +17,7 @@ PLIST_FILES= etc/p3scan/p3scan.conf.sample etc/p3scan/p3scan.mail.sample \
PLIST_DIRS= etc/p3scan
USE_GCC= any
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= _LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" GMAKE=${GMAKE}
SCRIPTS_ENV= PKG_PREFIX=${PREFIX} NONEXISTENT=${NONEXISTENT} PASSWD=/etc/passwd
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
index c16851d74609..5c09038f5d61 100644
--- a/mail/pop3vscan/Makefile
+++ b/mail/pop3vscan/Makefile
@@ -12,7 +12,7 @@ COMMENT= A transparent POP3-Proxy with virus-scanning capabilities
LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= _LDFLAGS="${LDFLAGS}"
SCRIPTS_ENV= PKG_PREFIX=${PREFIX} NONEXISTENT=${NONEXISTENT} PASSWD=/etc/passwd
diff --git a/mail/popular/Makefile b/mail/popular/Makefile
index 7fee39171c37..2ad4df0abdc0 100644
--- a/mail/popular/Makefile
+++ b/mail/popular/Makefile
@@ -14,9 +14,8 @@ BUILD_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
CONFLICTS= pserv-[0-9]* synce-librapi2-[0-9]*
-USES= perl5
+USES= perl5 gmake
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
PDM_MODULES= any master
diff --git a/mail/postfix-policyd-sf/Makefile b/mail/postfix-policyd-sf/Makefile
index 4e689d17a6d8..07336e5f0f54 100644
--- a/mail/postfix-policyd-sf/Makefile
+++ b/mail/postfix-policyd-sf/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= kiwi@oav.net
COMMENT= Anti-spam plugin for Postfix (written in C)
USE_MYSQL= yes
-USE_GMAKE= yes
+USES= gmake
USE_RC_SUBR= policyd
REALNAME= ${PKGNAME:C/-${PORTVERSION}.*//}
diff --git a/mail/proxsmtp/Makefile b/mail/proxsmtp/Makefile
index 35379b41489a..977d85d8a701 100644
--- a/mail/proxsmtp/Makefile
+++ b/mail/proxsmtp/Makefile
@@ -11,7 +11,7 @@ COMMENT= Flexible SMTP filter which can act also as transparent proxy
LICENSE= BSD
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_RC_SUBR= proxsmtpd
diff --git a/mail/synonym/Makefile b/mail/synonym/Makefile
index 820787897158..281463d165b4 100644
--- a/mail/synonym/Makefile
+++ b/mail/synonym/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-0.4-3
MAINTAINER= ports@FreeBSD.org
COMMENT= Synonym, the email message archiver
-USE_GMAKE= yes
+USES= gmake
USE_GNOME= libxml2
WRKSRC= ${WRKDIR}/${PORTNAME}-0.4
diff --git a/mail/vm/Makefile b/mail/vm/Makefile
index 14ca57f6fcc7..91e4f3346562 100644
--- a/mail/vm/Makefile
+++ b/mail/vm/Makefile
@@ -14,7 +14,7 @@ COMMENT= A mail reader running inside Emacs or XEmacs
GNU_CONFIGURE= yes
USE_EMACS= yes
-USE_GMAKE= yes
+USES= gmake
CONFIGURE_ARGS+= --with-emacs=${EMACS_CMD}
MAKE_ARGS= prefix=${PREFIX} \
lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME} \
diff --git a/mail/xfaces/Makefile b/mail/xfaces/Makefile
index 5d3a93db0aa1..47aa1d474390 100644
--- a/mail/xfaces/Makefile
+++ b/mail/xfaces/Makefile
@@ -24,8 +24,7 @@ LIB_DEPENDS= compface:${PORTSDIR}/mail/faces
# GNU make properly processes some overridden rules in the makefile that
# imake generates. Specifically, installing the html docs.
-USES= imake
-USE_GMAKE= yes
+USES= imake gmake
USE_XORG= ice sm x11 xaw xext xmu xt xpm
MAN1= xfaces.1