aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/postgresql84-server/Makefile12
-rw-r--r--databases/postgresql90-server/Makefile12
-rw-r--r--databases/postgresql91-server/Makefile7
-rw-r--r--databases/postgresql92-server/Makefile7
4 files changed, 30 insertions, 8 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 68823aee796a..a158bfacc932 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -83,8 +83,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-openssl
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(SLAVE_ONLY)
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
@@ -103,6 +101,8 @@ OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
+.include <bsd.port.pre.mk>
+
. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
@@ -161,8 +161,12 @@ INSTALL_TARGET= install-strip
.if defined(WITH_GSSAPI)
CONFIGURE_ARGS+=--with-gssapi
-.if ${OSVERSION} >= 900000
-BROKEN= does not link on FreeBSD 9.X
+.if !defined(WITH_MIT_KRB5) && !defined(WITH_HEIMDAL_KRB5)
+# Kerberos libraries will pull the proper GSSAPI library
+# via linker dependencies, but otherwise we must specify
+# it explicitely: ld --as-needed is used for compilation,
+# so configure's -lgssapi_krb5 won't go.
+LDFLAGS+= -lgssapi
.endif
.else
CONFIGURE_ARGS+=--without-gssapi
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 4bb749227a69..ef3d549e6be9 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -82,8 +82,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-openssl
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(SLAVE_ONLY)
OPTIONS+= DTRACE "Build with DTrace probes (server only)" off
OPTIONS+= PAM "Build with PAM support (server only)" off
@@ -103,6 +101,8 @@ OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
+.include <bsd.port.pre.mk>
+
. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
@@ -168,8 +168,12 @@ INSTALL_TARGET= install-strip
.if !defined(WITHOUT_GSSAPI)
CONFIGURE_ARGS+=--with-gssapi
-.if ${OSVERSION} >= 900000
-BROKEN= does not link on FreeBSD 9.X
+.if !defined(WITH_MIT_KRB5) && !defined(WITH_HEIMDAL_KRB5)
+# Kerberos libraries will pull the proper GSSAPI library
+# via linker dependencies, but otherwise we must specify
+# it explicitely: ld --as-needed is used for compilation,
+# so configure's -lgssapi_krb5 won't go.
+LDFLAGS+= -lgssapi
.endif
.else
CONFIGURE_ARGS+=--without-gssapi
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index deaf9a186029..b0de91e02921 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -178,6 +178,13 @@ INSTALL_TARGET= install-strip
.if (${OSVERSION} >= 700000) && !defined(WITHOUT_GSSAPI)
CONFIGURE_ARGS+=--with-gssapi
+.if !defined(WITH_MIT_KRB5) && !defined(WITH_HEIMDAL_KRB5)
+# Kerberos libraries will pull the proper GSSAPI library
+# via linker dependencies, but otherwise we must specify
+# it explicitely: ld --as-needed is used for compilation,
+# so configure's -lgssapi_krb5 won't go.
+LDFLAGS+= -lgssapi
+.endif
.endif
. if defined(WITH_MIT_KRB5)
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index deaf9a186029..b0de91e02921 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -178,6 +178,13 @@ INSTALL_TARGET= install-strip
.if (${OSVERSION} >= 700000) && !defined(WITHOUT_GSSAPI)
CONFIGURE_ARGS+=--with-gssapi
+.if !defined(WITH_MIT_KRB5) && !defined(WITH_HEIMDAL_KRB5)
+# Kerberos libraries will pull the proper GSSAPI library
+# via linker dependencies, but otherwise we must specify
+# it explicitely: ld --as-needed is used for compilation,
+# so configure's -lgssapi_krb5 won't go.
+LDFLAGS+= -lgssapi
+.endif
.endif
. if defined(WITH_MIT_KRB5)