aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libbs2b/Makefile30
-rw-r--r--audio/libbs2b/distinfo3
-rw-r--r--audio/libbs2b/pkg-descr3
-rw-r--r--audio/libbs2b/pkg-plist12
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index dc14298f4c8a..3362514614c6 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -344,6 +344,7 @@
SUBDIR += libao
SUBDIR += libaudiofile
SUBDIR += libbpm
+ SUBDIR += libbs2b
SUBDIR += libcanberra
SUBDIR += libcdaudio
SUBDIR += libcddb
diff --git a/audio/libbs2b/Makefile b/audio/libbs2b/Makefile
new file mode 100644
index 000000000000..85ed66867a08
--- /dev/null
+++ b/audio/libbs2b/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libbs2b
+# Date created: 22 May 2010
+# Whom: SimaMoto,RyoTa <liangtai.s4@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbs2b
+PORTVERSION= 3.1.0
+CATEGORIES= audio
+MASTER_SITES= SF/bs2b/bs2b/${PORTVERSION}
+
+MAINTAINER= liangtai.s4@gmail.com
+COMMENT= Bauer Stereophonic-to-Binaural DSP
+
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+
+USE_PKGCONFIG= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= CFLAGS=`pkg-config --cflags sndfile` \
+ LDFLAGS=`pkg-config --libs-only-L sndfile`
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's@^\(pkgconfigdir = \).*@\1$${prefix}/libdata/pkgconfig@' \
+ ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/libbs2b/distinfo b/audio/libbs2b/distinfo
new file mode 100644
index 000000000000..295e0dcf1bfc
--- /dev/null
+++ b/audio/libbs2b/distinfo
@@ -0,0 +1,3 @@
+MD5 (libbs2b-3.1.0.tar.bz2) = c1486531d9e23cf34a1892ec8d8bfc06
+SHA256 (libbs2b-3.1.0.tar.bz2) = 4799974becdeeedf0db00115bc63f60ea3fe4b25f1dfdb6903505839a720e46f
+SIZE (libbs2b-3.1.0.tar.bz2) = 606283
diff --git a/audio/libbs2b/pkg-descr b/audio/libbs2b/pkg-descr
new file mode 100644
index 000000000000..3b13a2da3395
--- /dev/null
+++ b/audio/libbs2b/pkg-descr
@@ -0,0 +1,3 @@
+The Bauer stereophonic-to-binaural DSP (bs2b) is designed
+to improve headphone listening of stereo audio records.
+WWW: http://bs2b.sourceforge.net/
diff --git a/audio/libbs2b/pkg-plist b/audio/libbs2b/pkg-plist
new file mode 100644
index 000000000000..736498aa2b57
--- /dev/null
+++ b/audio/libbs2b/pkg-plist
@@ -0,0 +1,12 @@
+lib/libbs2b.a
+lib/libbs2b.la
+lib/libbs2b.so
+lib/libbs2b.so.0
+bin/bs2bconvert
+bin/bs2bstream
+include/bs2b/bs2b.h
+include/bs2b/bs2bclass.h
+include/bs2b/bs2btypes.h
+include/bs2b/bs2bversion.h
+libdata/pkgconfig/libbs2b.pc
+@dirrm include/bs2b