aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/snownews/Makefile7
-rw-r--r--www/snownews/distinfo4
-rw-r--r--www/snownews/files/patch-Makefile.inc21
-rw-r--r--www/snownews/files/patch-doc::man::Makefile10
4 files changed, 29 insertions, 13 deletions
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index a342c4586f01..1a43bd2f5d82 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= snownews
-PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTVERSION= 1.5.1
CATEGORIES= www
MASTER_SITES= http://home.kcore.de/~kiza/software/snownews/download/
@@ -20,8 +19,12 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
+USE_REINPLACE= yes
MAN1= snownews.1
MANLANG= "" de nl fr it
+post-patch:
+ @${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS +=|g' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/www/snownews/distinfo b/www/snownews/distinfo
index dae70bb2ebee..bdaf079ac010 100644
--- a/www/snownews/distinfo
+++ b/www/snownews/distinfo
@@ -1,2 +1,2 @@
-MD5 (snownews-1.4.4.tar.gz) = 67b6d2baaea20561fb828b431b39b77c
-SIZE (snownews-1.4.4.tar.gz) = 99098
+MD5 (snownews-1.5.1.tar.gz) = e5c36a0199e7b18ddfc6ad0df6da9330
+SIZE (snownews-1.5.1.tar.gz) = 111095
diff --git a/www/snownews/files/patch-Makefile.inc b/www/snownews/files/patch-Makefile.inc
index 61a81ef30f26..7090e8b9900b 100644
--- a/www/snownews/files/patch-Makefile.inc
+++ b/www/snownews/files/patch-Makefile.inc
@@ -1,14 +1,17 @@
---- Makefile.inc.orig Fri Jan 23 20:13:29 2004
-+++ Makefile.inc Tue Jan 27 15:46:37 2004
-@@ -1,5 +1,5 @@
- CC = gcc
+--- Makefile.inc.orig Sun Mar 7 22:41:07 2004
++++ Makefile.inc Sat Apr 3 09:05:38 2004
+@@ -1,10 +1,11 @@
+-CC = gcc
-MAKE = make
++CC ?= gcc
+MAKE = gmake
INSTALL = install
- PREFIX = /usr/local
+-PREFIX = /usr/local
++#PREFIX = /usr/local
LOCALEPATH = $(PREFIX)/share/locale
-@@ -8,3 +8,4 @@
- doc po \
- main.c interface.c netio.c xmlparse.c updatecheck.c os-support.c conversions.c dialog.c ui-support.c categories.c about.c cookies.c \
- config.h version.h main.h interface.h netio.h xmlparse.h updatecheck.h os-support.h conversions.h dialog.h ui-support.h categories.h about.h cookies.h
+ DISTFILES = AUTHOR COPYING CREDITS Changelog README README.de README.colors README.patching INSTALL INSTALL.solaris INSTALL.FreeOpenNetBSD opml2snow \
+ Makefile Makefile.inc Makefile.solaris \
+ doc po scripts \
+ main.c interface.c netio.c xmlparse.c updatecheck.c os-support.c conversions.c dialog.c ui-support.c categories.c about.c cookies.c setup.c net-support.c digcalc.c md5.c filters.c \
+ config.h version.h main.h interface.h netio.h xmlparse.h updatecheck.h os-support.h conversions.h dialog.h ui-support.h categories.h about.h cookies.h setup.h net-support.h digcalc.h md5.h filters.h
+EXTRA_LDFLAGS = -lintl -liconv
diff --git a/www/snownews/files/patch-doc::man::Makefile b/www/snownews/files/patch-doc::man::Makefile
new file mode 100644
index 000000000000..a6a8c38511ba
--- /dev/null
+++ b/www/snownews/files/patch-doc::man::Makefile
@@ -0,0 +1,10 @@
+--- doc/man/Makefile.orig Sat Apr 3 09:11:44 2004
++++ doc/man/Makefile Sat Apr 3 09:11:54 2004
+@@ -17,7 +17,6 @@
+ mkdir -p $(PREFIX)/man/man1; \
+ fi
+ $(INSTALL) -m 0644 snownews.1 $(PREFIX)/man/man1
+- $(INSTALL) -m 0644 opml2snow.1 $(PREFIX)/man/man1
+ $(MAKE) -C de install-man
+ $(MAKE) -C nl install-man
+ $(MAKE) -C fr install-man