aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/drac/Makefile4
-rw-r--r--mail/drac/files/patch-ad10
2 files changed, 13 insertions, 1 deletions
diff --git a/mail/drac/Makefile b/mail/drac/Makefile
index bce684a77e15..f55ab96f36b2 100644
--- a/mail/drac/Makefile
+++ b/mail/drac/Makefile
@@ -7,7 +7,7 @@
PORTNAME= drac
PORTVERSION= 1.12
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cc.umanitoba.ca/src/ \
ftp://ftp.parodius.com/pub/umanitoba/ \
@@ -29,8 +29,10 @@ LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
NO_WRKSUBDIR= yes
USE_RC_SUBR= dracd.sh
+.if !defined(NOPORTDOCS)
MAN3= dracauth.3
MAN1= rpc.dracd.1
+.endif
.include <bsd.port.pre.mk>
diff --git a/mail/drac/files/patch-ad b/mail/drac/files/patch-ad
new file mode 100644
index 000000000000..fc9b9d64f68a
--- /dev/null
+++ b/mail/drac/files/patch-ad
@@ -0,0 +1,10 @@
+--- testing.c.orig 1998-08-10 18:36:14.000000000 -0700
++++ testing.c 2008-06-04 04:50:08.000000000 -0700
+@@ -3,6 +3,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>