aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/openjpeg/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 00f8e12f97fc..d811361b5321 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -18,6 +18,15 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
USES= cmake cpe localbase:ldflags jpeg pathfix pkgconfig
+# Clean up bundled libraries
+EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/astyle \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/include \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/liblcms2 \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/libpng \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/libtiff \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/libz \
+ --no-same-owner --no-same-permissions
+
CMAKE_OFF= BUILD_DOC \
BUILD_JAVA \
BUILD_JPIP \
@@ -40,13 +49,4 @@ USE_GITHUB= yes
CPE_VENDOR= uclouvain
-post-patch:
-# Clean up bundled libraries
- @${RM} -r ${WRKSRC}/thirdparty/astyle/
- @${RM} -r ${WRKSRC}/thirdparty/include/
- @${RM} -r ${WRKSRC}/thirdparty/liblcms2/
- @${RM} -r ${WRKSRC}/thirdparty/libpng/
- @${RM} -r ${WRKSRC}/thirdparty/libtiff/
- @${RM} -r ${WRKSRC}/thirdparty/libz/
-
.include <bsd.port.mk>