aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/wwwoffle/Makefile6
-rw-r--r--www/wwwoffle/distinfo6
-rw-r--r--www/wwwoffle/files/patch-aa54
-rw-r--r--www/wwwoffle/files/patch-conf::wwwoffle.conf12
-rw-r--r--www/wwwoffle/pkg-plist147
5 files changed, 114 insertions, 111 deletions
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index dc384f1b32db..6aebf9ca4e5a 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= wwwoffle
-PORTVERSION= 2.8e
-PORTREVISION= 1
+PORTVERSION= 2.9
CATEGORIES= www ipv6
MASTER_SITES= http://www.gedanken.freeserve.co.uk/download-wwwoffle/
EXTRACT_SUFX= .tgz
@@ -28,6 +27,7 @@ PLIST_SUB+= WWWOFFLE_SPOOL=${WWWOFFLE_SPOOL}
HAS_CONFIGURE= yes
CONFIGURE_ENV= LIBS=-lmd
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc --with-ipv6 \
+ --with-gnutls=${PREFIX} \
--with-spooldir=${WWWOFFLE_SPOOL}
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
@@ -48,8 +48,6 @@ post-configure:
.endif
post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/conf/upgrade-config-2.5-2.6.pl ${WWWOFFLE_SPOOL}
- @${INSTALL_SCRIPT} ${WRKSRC}/conf/upgrade-config-2.x-2.5.pl ${WWWOFFLE_SPOOL}
@${INSTALL_SCRIPT} ${WRKSRC}/conf/upgrade-config.pl ${WWWOFFLE_SPOOL}
@${CAT} ${PKGMESSAGE}
diff --git a/www/wwwoffle/distinfo b/www/wwwoffle/distinfo
index c7377c0d3bad..c81133203f57 100644
--- a/www/wwwoffle/distinfo
+++ b/www/wwwoffle/distinfo
@@ -1,3 +1,3 @@
-MD5 (wwwoffle-2.8e.tgz) = 30828cc5a8a459f04f719bbb220003e7
-SHA256 (wwwoffle-2.8e.tgz) = 3b5ed02d144ea8651524544a6621ca9cfd693189b8f661b1a44956e00978c515
-SIZE (wwwoffle-2.8e.tgz) = 1015694
+MD5 (wwwoffle-2.9.tgz) = e8e7f3bdf1ff0a9baa26e5aebd6ad396
+SHA256 (wwwoffle-2.9.tgz) = ac5e779beae963cf2f3b0dd44f7ed64114a1c15aa2fb6f41ad7db9bc0f096df3
+SIZE (wwwoffle-2.9.tgz) = 1074108
diff --git a/www/wwwoffle/files/patch-aa b/www/wwwoffle/files/patch-aa
index f38635f839f6..91331e2dea6f 100644
--- a/www/wwwoffle/files/patch-aa
+++ b/www/wwwoffle/files/patch-aa
@@ -1,55 +1,37 @@
---- src/Makefile.in.orig Tue Sep 2 19:24:28 2003
-+++ src/Makefile.in Tue Oct 7 13:49:09 2003
-@@ -136,7 +136,7 @@
+--- src/Makefile.in~ Wed Feb 1 04:02:32 2006
++++ src/Makefile.in Mon Apr 3 10:21:07 2006
+@@ -140,7 +140,7 @@
document.o html.o css.o xml.o vrml.o javaclass.o \
configrdwr.o configmisc.o configdata.o configfunc.o \
- io.o iopriv.o iozlib.o iochunk.o \
-- errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o md5.o
-+ errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o
+ io.o iopriv.o iozlib.o iognutls.o iochunk.o \
+- errors.o miscurl.o miscencdec.o headbody.o proto.o certificates.o sockets.o md5.o
++ errors.o miscurl.o miscencdec.o headbody.o proto.o certificates.o sockets.o
wwwoffle : $(WWWOFFLE_OBJ)
$(LINK) $(WWWOFFLE_OBJ) -o $@ $(LIBRARY)
-@@ -152,7 +152,7 @@
- parse.o purge.o refresh.o spool.o \
+@@ -156,7 +156,7 @@
+ parse.o purge.o refresh.o spool.o \
configrdwr.o configmisc.o configdata.o configfunc.o configedit.o \
- io.o iopriv.o iozlib.o iochunk.o \
-- errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o md5.o
-+ errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o
+ io.o iopriv.o iozlib.o iognutls.o iochunk.o \
+- errors.o miscurl.o miscencdec.o headbody.o proto.o certificates.o sockets.o md5.o
++ errors.o miscurl.o miscencdec.o headbody.o proto.o certificates.o sockets.o
wwwoffled : $(WWWOFFLED_OBJ)
$(LINK) $(WWWOFFLED_OBJ) -o $@ $(LIBRARY)
-@@ -166,7 +166,7 @@
+@@ -170,7 +170,7 @@
parse.o \
configrdwr.o configmisc.o configdata.o configfunc.o \
- io.o iopriv.o iozlib.o iochunk.o \
-- errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o md5.o
-+ errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o
+ io.o iopriv.o iozlib.o iognutls.o iochunk.o \
+- errors.o miscurl.o miscencdec.o headbody.o proto.o certificates.o sockets.o md5.o
++ errors.o miscurl.o miscencdec.o headbody.o proto.o certificates.o sockets.o
wwwoffle-tools : $(WWWOFFLE_TOOLS_OBJ)
$(LINK) $(WWWOFFLE_TOOLS_OBJ) -o $@ $(LIBRARY)
-@@ -179,7 +179,7 @@
- parse.o \
- configrdwr.o configmisc.o configdata.o configfunc.o \
- io.o iopriv.o iozlib.o iochunk.o \
-- errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o spool.o md5.o
-+ errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o spool.o
-
- convert-cache : $(CONVERT_OBJ)
- $(LINK) $(CONVERT_OBJ) -o $@ $(LIBRARY)
-@@ -192,7 +192,7 @@
- parse.o \
- configrdwr.o configmisc.o configdata.o configfunc.o \
- io.o iopriv.o iozlib.o iochunk.o \
-- errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o spool.o md5.o
-+ errors.o miscurl.o miscencdec.o headbody.o proto.o sockets.o spool.o
-
- uncompress-cache : $(UNCOMPRESS_OBJ)
- $(LINK) $(UNCOMPRESS_OBJ) -o $@ $(LIBRARY)
-@@ -269,7 +269,6 @@
- sockets.o : sockets.c autoconfig.h errors.h sockets.h \
+@@ -249,7 +249,6 @@
+ sockets.o : sockets.c autoconfig.h errors.h sockets.h \
sockets4.c sockets6.c
--md5.o : md5.c md5.h
+-md5.o : md5.c md5.h
######## SOURCE FILES ########
diff --git a/www/wwwoffle/files/patch-conf::wwwoffle.conf b/www/wwwoffle/files/patch-conf::wwwoffle.conf
index 580cb8c1de83..fdadb74aef47 100644
--- a/www/wwwoffle/files/patch-conf::wwwoffle.conf
+++ b/www/wwwoffle/files/patch-conf::wwwoffle.conf
@@ -1,10 +1,12 @@
---- conf/wwwoffle.conf.template.orig Sat Nov 2 17:50:39 2002
-+++ conf/wwwoffle.conf.template Thu Jul 17 17:08:19 2003
-@@ -13,6 +13,7 @@
+--- conf/wwwoffle.conf.template.orig Sat Feb 4 06:41:35 2006
++++ conf/wwwoffle.conf.template Mon Apr 3 10:23:41 2006
+@@ -12,7 +12,8 @@
+ StartUp
{
bind-ipv4 = 0.0.0.0
- #bind-ipv6 = ::
+- bind-ipv6 = ::
++#bind-ipv6 = ::
+ bind-ipv6 = none
http-port = 8080
- wwwoffle-port = 8081
+ https-port = 8443
diff --git a/www/wwwoffle/pkg-plist b/www/wwwoffle/pkg-plist
index 5762e3591a18..cc4bb0c807a2 100644
--- a/www/wwwoffle/pkg-plist
+++ b/www/wwwoffle/pkg-plist
@@ -1,4 +1,7 @@
bin/wwwoffle
+bin/wwwoffle-fsck
+bin/wwwoffle-gunzip
+bin/wwwoffle-gzip
bin/wwwoffle-hash
bin/wwwoffle-ls
bin/wwwoffle-mv
@@ -10,7 +13,6 @@ bin/wwwoffle-write
etc/wwwoffle.conf.install
sbin/wwwoffled
share/doc/wwwoffle/CHANGES.CONF
-share/doc/wwwoffle/CONVERT
share/doc/wwwoffle/COPYING
share/doc/wwwoffle/FAQ
share/doc/wwwoffle/INSTALL
@@ -22,6 +24,8 @@ share/doc/wwwoffle/README.PWD
share/doc/wwwoffle/README.URL
share/doc/wwwoffle/README.compress
share/doc/wwwoffle/README.htdig
+share/doc/wwwoffle/README.https
+share/doc/wwwoffle/README.hyperestraier
share/doc/wwwoffle/README.lang
share/doc/wwwoffle/README.mnogosearch
share/doc/wwwoffle/README.namazu
@@ -31,10 +35,9 @@ share/doc/wwwoffle/de/INSTALL
share/doc/wwwoffle/de/LSM
share/doc/wwwoffle/de/NEWS
share/doc/wwwoffle/de/README.1st
-share/doc/wwwoffle/de/README.CONF.html
share/doc/wwwoffle/de/README.CONF
+share/doc/wwwoffle/de/README.CONF.html
share/doc/wwwoffle/de/README.html
-share/doc/wwwoffle/es/CONVERT
share/doc/wwwoffle/es/INSTALL
share/doc/wwwoffle/es/LSM
share/doc/wwwoffle/es/README
@@ -161,6 +164,13 @@ html/en/local/dontget/replacement.png
html/en/local/index.html
html/en/messages/AddCacheInfo.html
html/en/messages/CantRefreshPosted.html
+html/en/messages/CertIllegal.html
+html/en/messages/CertIndex-Body.html
+html/en/messages/CertIndex-Head.html
+html/en/messages/CertIndex-Tail.html
+html/en/messages/CertInfo-Body.html
+html/en/messages/CertInfo-Head.html
+html/en/messages/CertInfo-Tail.html
html/en/messages/ConfigurationAuthFail.html
html/en/messages/ConfigurationChange.html
html/en/messages/ConfigurationIllegal.html
@@ -270,6 +280,8 @@ html/en/search/htdig/index.html
html/en/search/htdig/search.html
html/en/search/htdig/star.gif
html/en/search/htdig/star_blank.gif
+html/en/search/hyperestraier/index.html
+html/en/search/hyperestraier/search.html
html/en/search/mnogosearch/index.html
html/en/search/mnogosearch/m-search.gif
html/en/search/mnogosearch/result.html
@@ -285,6 +297,7 @@ html/en/search/start3.html
html/en/search/start4.html
html/en/search/udmsearch
html/en/wwwoffle.css
+html/en/wwwoffle.js
html/en/wwwoffle.pac
html/es/FAQ.html
html/es/README.CONF.html
@@ -799,6 +812,11 @@ search/htdig/scripts/wwwoffle-htdig-incr
search/htdig/scripts/wwwoffle-htdig-lasttime
search/htdig/scripts/wwwoffle-htfuzzy
search/htdig/scripts/wwwoffle-htsearch
+search/hyperestraier/conf/estseek.conf
+search/hyperestraier/conf/estseek.tmpl
+search/hyperestraier/conf/estseek.top
+search/hyperestraier/scripts/wwwoffle-estcmd-full
+search/hyperestraier/scripts/wwwoffle-estseek
search/mnogosearch/conf/indexer-full.conf
search/mnogosearch/conf/indexer-full.old.conf
search/mnogosearch/conf/indexer-incr.conf
@@ -819,72 +837,75 @@ search/namazu/scripts/wwwoffle-mknmz-full
search/namazu/scripts/wwwoffle-mknmz-lasttime
search/namazu/scripts/wwwoffle-namazu
search/udmsearch
-upgrade-config-2.5-2.6.pl
-upgrade-config-2.x-2.5.pl
upgrade-config.pl
-@dirrm lastout
+@dirrm search/namazu/scripts
+@dirrm search/namazu/db
+@dirrm search/namazu/conf
+@dirrm search/namazu
+@dirrm search/mnogosearch/scripts
+@dirrm search/mnogosearch/db
+@dirrm search/mnogosearch/conf
+@dirrm search/mnogosearch
+@dirrm search/hyperestraier/scripts
+@dirrm search/hyperestraier/db
+@dirrm search/hyperestraier/conf
+@dirrm search/hyperestraier
+@dirrm search/htdig/tmp
+@dirrm search/htdig/scripts
+@dirrm search/htdig/db-lasttime
+@dirrm search/htdig/db
+@dirrm search/htdig/conf
+@dirrm search/htdig
+@dirrm search
+@dirrm prevtime1
+@dirrm outgoing
+@dirrm monitor
@dirrm local
-@dirrm html/de/local
-@dirrm html/de/messages
-@dirrm html/de/search/htdig
-@dirrm html/de/search
-@dirrm html/de
-@dirrm html/en/local/dontget
-@dirrm html/en/local
-@dirrm html/en/messages
-@dirrm html/en/search/htdig
-@dirrm html/en/search/mnogosearch
-@dirrm html/en/search/namazu
-@dirrm html/en/search
-@dirrm html/en
-@dirrm html/es/messages
-@dirrm html/es/search/htdig
-@dirrm html/es/search/mnogosearch
-@dirrm html/es/search
-@dirrm html/es
-@dirrm html/fr/messages
-@dirrm html/fr/search/mnogosearch
-@dirrm html/fr/search/namazu
-@dirrm html/fr/search/htdig
-@dirrm html/fr/search
-@dirrm html/fr
-@dirrm html/it/messages
-@dirrm html/it/search/htdig
-@dirrm html/it/search/mnogosearch
-@dirrm html/it/search
-@dirrm html/it
-@dirrm html/nl/messages
-@dirrm html/nl
-@dirrm html/pl/local
-@dirrm html/pl/messages
-@dirrm html/pl/search/htdig
+@dirrm lasttime
+@dirrm lastout
+@dirrm http
+@dirrm html/ru/messages
+@dirrm html/ru/local
+@dirrm html/ru
@dirrm html/pl/search/namazu
@dirrm html/pl/search/mnogosearch
+@dirrm html/pl/search/htdig
@dirrm html/pl/search
+@dirrm html/pl/messages
+@dirrm html/pl/local
@dirrm html/pl
-@dirrm html/ru/local
-@dirrm html/ru/messages
-@dirrm html/ru
+@dirrm html/nl/messages
+@dirrm html/nl
+@dirrm html/it/search/mnogosearch
+@dirrm html/it/search/htdig
+@dirrm html/it/search
+@dirrm html/it/messages
+@dirrm html/it
+@dirrm html/fr/search/namazu
+@dirrm html/fr/search/mnogosearch
+@dirrm html/fr/search/htdig
+@dirrm html/fr/search
+@dirrm html/fr/messages
+@dirrm html/fr
+@dirrm html/es/search/mnogosearch
+@dirrm html/es/search/htdig
+@dirrm html/es/search
+@dirrm html/es/messages
+@dirrm html/es
+@dirrm html/en/search/namazu
+@dirrm html/en/search/mnogosearch
+@dirrm html/en/search/hyperestraier
+@dirrm html/en/search/htdig
+@dirrm html/en/search
+@dirrm html/en/messages
+@dirrm html/en/local/dontget
+@dirrm html/en/local
+@dirrm html/en
+@dirrm html/de/search/htdig
+@dirrm html/de/search
+@dirrm html/de/messages
+@dirrm html/de/local
+@dirrm html/de
@dirrm html
-@dirrm http
-@dirrm lasttime
-@dirrm monitor
-@dirrm outgoing
-@dirrm prevtime1
-@dirrm search/htdig/conf
-@dirrm search/htdig/db
-@dirrm search/htdig/db-lasttime
-@dirrm search/htdig/scripts
-@dirrm search/htdig/tmp
-@dirrm search/htdig
-@dirrm search/mnogosearch/conf
-@dirrm search/mnogosearch/scripts
-@dirrm search/mnogosearch/db
-@dirrm search/mnogosearch
-@dirrm search/namazu/scripts
-@dirrm search/namazu/db
-@dirrm search/namazu/conf
-@dirrm search/namazu
-@dirrm search
@cwd /
@dirrm %%WWWOFFLE_SPOOL%%