aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/linphone/Makefile2
-rw-r--r--net/linphone/files/patch-CMakeLists.txt11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 78b167c1ed8a..42e3345905a3 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -1,6 +1,6 @@
PORTNAME= linphone
PORTVERSION= 4.4.8
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
diff --git a/net/linphone/files/patch-CMakeLists.txt b/net/linphone/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1b68c310fbb9
--- /dev/null
+++ b/net/linphone/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2022-08-24 10:17:10 UTC
++++ CMakeLists.txt
+@@ -487,7 +487,7 @@ if(APPLE)
+ set(MSPLUGINS_DIR "Frameworks/mediastreamer2.framework/Versions/A/Libraries")
+ endif()
+ else()
+- set(MSPLUGINS_DIR "plugins/mediastreamer")
++ set(MSPLUGINS_DIR "lib/mediastreamer/plugins")
+ endif()
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/src/config.h.cmake" "${CMAKE_CURRENT_BINARY_DIR}/config.h")
+ # ------------------------------------------------------------------------------