aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/blas/Makefile12
-rw-r--r--math/calc/Makefile9
-rw-r--r--math/eispack/Makefile12
-rw-r--r--math/fudgit/Makefile12
-rw-r--r--math/gnuplot/Makefile11
-rw-r--r--math/hexcalc/Makefile9
-rw-r--r--math/linpack/Makefile11
-rw-r--r--math/oleo/Makefile7
-rw-r--r--math/xgraph/Makefile11
9 files changed, 82 insertions, 12 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 1cb77ecadce9..ab2c9f5d11a4 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -1,13 +1,25 @@
+# New ports collection makefile for: blas
+# Version required: ?
+# Date created: 27 October 1994
+# Whom: ljo
+#
+# $Id$
+#
+
DISTNAME= blas
+
DISTDIR=${PORTSDIR}/distfiles/${DISTNAME}
+
MASTER_SITES= ftp://netlib.att.com/netlib/blas/
.if defined(MASTER_SITE_OVERRIDE)
MASTER_SITES:= ${MASTER_SITE_OVERRIDE}/blas/
.undef MASTER_SITE_OVERRIDE
.endif
+
EXTRACT_CMD=${.CURDIR}/scripts/uncomp
EXTRACT_SUFX=.Z
EXTRACT_ARGS= ${WRKDIR}
+
WRKSRC=${WRKDIR}
SRCS = caxpy.f cblas1.f cblas2.f ccopy.f cdotc.f cdotu.f cgbmv.f cgemv.f \
diff --git a/math/calc/Makefile b/math/calc/Makefile
index b4ce6b597e28..b4dcb15d09fb 100644
--- a/math/calc/Makefile
+++ b/math/calc/Makefile
@@ -1,4 +1,13 @@
+# New ports collection makefile for: calc
+# Version required: 2.9.3t6
+# Date created: 3 October 1994
+# Whom: jmz
+#
+# $Id$
+#
+
DISTNAME= calc-2.9.3t6
+PKGNAME= calc-2.9.3
MASTER_SITES= ftp://ftp.cs.uni-sb.de/pub/misc/4.4BSD-Lite/contrib/
pre-install:
diff --git a/math/eispack/Makefile b/math/eispack/Makefile
index 5506892f0f93..756ca7af8abd 100644
--- a/math/eispack/Makefile
+++ b/math/eispack/Makefile
@@ -1,13 +1,25 @@
+# New ports collection makefile for: eispack
+# Version required: ?
+# Date created: 31 October 1994
+# Whom: ljo
+#
+# $Id$
+#
+
DISTNAME= eispack
+
DISTDIR=${PORTSDIR}/distfiles/${DISTNAME}
+
MASTER_SITES= ftp://netlib.att.com/netlib/eispack/
.if defined(MASTER_SITE_OVERRIDE)
MASTER_SITES:= ${MASTER_SITE_OVERRIDE}/eispack/
.undef MASTER_SITE_OVERRIDE
.endif
+
EXTRACT_CMD=${.CURDIR}/scripts/uncomp
EXTRACT_SUFX=.Z
EXTRACT_ARGS= ${WRKDIR}
+
WRKSRC=${WRKDIR}
SRCS = csroot.f epslon.f pythag.f bakvec.f balanc.f balbak.f bandr.f \
diff --git a/math/fudgit/Makefile b/math/fudgit/Makefile
index 16c844d22c3b..2a2d8e14e006 100644
--- a/math/fudgit/Makefile
+++ b/math/fudgit/Makefile
@@ -1,6 +1,16 @@
+# New ports collection makefile for: Fudgit
+# Version required: 2.41
+# Date created: 17 November 1994
+# Whom: jmz
+#
+# $Id$
+#
+
DISTNAME= Fudgit_2.41
-DISTFILES= fudgit_2.41.tar.gz
+PKGNAME= Fudgit-2.41
MASTER_SITES= ftp://ftp.physics.mcgill.ca/pub/Fudgit/
+DISTFILES= fudgit_2.41.tar.gz
+
USE_GMAKE= yes
pre-install:
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index bfaa75dfd4ec..6c3fd329da27 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -1,6 +1,15 @@
+# New ports collection makefile for: gnuplot
+# Version required: 3.5
+# Date created: 6 October 1994
+# Whom: jmz
+#
+# $Id$
+#
+
DISTNAME= gnuplot
-DISTFILES= gnuplot3.5.tar.Z
+PKGNAME= gnuplot-3.5
MASTER_SITES= ftp://ftp.dartmouth.edu/pub/gnuplot/
+DISTFILES= gnuplot3.5.tar.Z
pre-install:
@mkdir -p ${PREFIX}/bin
diff --git a/math/hexcalc/Makefile b/math/hexcalc/Makefile
index 55b6ce5b0a0c..b6bfa29da209 100644
--- a/math/hexcalc/Makefile
+++ b/math/hexcalc/Makefile
@@ -1,14 +1,17 @@
# New ports collection makefile for: hexcalc
-# Version required: ?
+# Version required: 1.11 (taken from sccsid in hexcalc.c)
# Date created: 5 December 1994
# Whom: asami
#
-# $Id: Makefile,v 1.2 1995/02/11 13:50:05 asami Exp $
+# $Id: Makefile,v 1.3 1995/03/24 11:10:19 asami Exp $
#
DISTNAME= hexcalc
-USE_IMAKE= yes
+PKGNAME= hexcalc-1.11
MASTER_SITES= ftp://ftp.cs.columbia.edu/archives/X11R5/contrib/
+
MAINTAINER= asami@FreeBSD.ORG
+USE_IMAKE= yes
+
.include <bsd.port.mk>
diff --git a/math/linpack/Makefile b/math/linpack/Makefile
index 71c6cd1845bf..e112e1d5d4bd 100644
--- a/math/linpack/Makefile
+++ b/math/linpack/Makefile
@@ -1,13 +1,24 @@
+# New ports collection makefile for: linpack
+# Version required: ?
+# Date created: 31 October 1994
+# Whom: ljo
+#
+# $Id$
+#
+
DISTNAME= linpack
+
DISTDIR=${PORTSDIR}/distfiles/${DISTNAME}
MASTER_SITES= ftp://netlib.att.com/netlib/linpack/
.if defined(MASTER_SITE_OVERRIDE)
MASTER_SITES:= ${MASTER_SITE_OVERRIDE}/linpack/
.undef MASTER_SITE_OVERRIDE
.endif
+
EXTRACT_CMD=${.CURDIR}/scripts/uncomp
EXTRACT_SUFX=.Z
EXTRACT_ARGS= ${WRKDIR}
+
WRKSRC=${WRKDIR}
SRCS = cchdc.f cchdd.f cchex.f cchud.f cgbco.f cgbdi.f cgbfa.f cgbsl.f \
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 8e99e6de57d1..650b783ef120 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -1,14 +1,15 @@
# New ports collection makefile for: oleo
-# Version required: 3.90
-# Date created: 03 September 1994
+# Version required: 1.6
+# Date created: 3 September 1994
# Whom: mr
#
-# $Id: Makefile,v 1.2 1994/11/10 19:10:57 ljo Exp $
+# $Id: Makefile,v 1.3 1995/03/24 11:10:22 asami Exp $
#
DISTNAME= oleo-1.6
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
EXTRACT_SUFX=.tar.gz
+
HAS_CONFIGURE=yes
.include <bsd.port.mk>
diff --git a/math/xgraph/Makefile b/math/xgraph/Makefile
index 68eaa5a289cf..7fb441e60225 100644
--- a/math/xgraph/Makefile
+++ b/math/xgraph/Makefile
@@ -1,15 +1,18 @@
# New ports collection makefile for: xgraph
-# Version required: 11
+# Version required: 11.3.2
# Date created: 24 November 1994
# Whom: asami
#
-# $Id: Makefile,v 1.2 1994/12/12 04:32:02 gpalmer Exp $
+# $Id: Makefile,v 1.3 1995/03/24 11:10:25 asami Exp $
#
DISTNAME= xgraph-11
-USE_IMAKE= yes
+PKGNAME= xgraph-11.3.2
MASTER_SITES= ftp://ftp.cs.orst.edu/pub/src/Xclients.local/
-MAINTAINER= asami@FreeBSD.ORG
EXTRACT_SUFX= .tar.Z
+MAINTAINER= asami@FreeBSD.ORG
+
+USE_IMAKE= yes
+
.include <bsd.port.mk>