aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/rsgain/Makefile12
-rw-r--r--audio/rsgain/distinfo6
-rw-r--r--audio/rsgain/files/patch-src_tag.cpp25
3 files changed, 8 insertions, 35 deletions
diff --git a/audio/rsgain/Makefile b/audio/rsgain/Makefile
index cd2e204e77f5..efd9d0ffcd66 100644
--- a/audio/rsgain/Makefile
+++ b/audio/rsgain/Makefile
@@ -1,7 +1,8 @@
PORTNAME= rsgain
-DISTVERSIONPREFIX= v
-DISTVERSION= 3.0.1
+DISTVERSION= 3.1
+DISTVERSIONSUFFIX= -source
CATEGORIES= audio
+MASTER_SITES= https://github.com/complexlogic/rsgain/releases/download/v${DISTVERSION}/
MAINTAINER= jhale@FreeBSD.org
COMMENT= ReplayGain 2.0 tagging utility
@@ -16,12 +17,9 @@ LIB_DEPENDS= libebur128.so:audio/libebur128 \
libinih.so:devel/inih \
libavcodec.so:multimedia/ffmpeg
-USES= cmake compiler:c++2b-lang pkgconfig
+USES= cmake compiler:c++2b-lang pkgconfig tar:xz
-USE_GITHUB= yes
-GH_ACCOUNT= complexlogic
-
-CXXFLAGS+= -pthread
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= DOCS
diff --git a/audio/rsgain/distinfo b/audio/rsgain/distinfo
index 1e05beb41299..814d7084a410 100644
--- a/audio/rsgain/distinfo
+++ b/audio/rsgain/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1666113201
-SHA256 (complexlogic-rsgain-v3.0.1_GH0.tar.gz) = 928a0d5aefb0e2d195c44a7571425d39f0e5065050c534032ee746d91596f22d
-SIZE (complexlogic-rsgain-v3.0.1_GH0.tar.gz) = 47435
+TIMESTAMP = 1667576811
+SHA256 (rsgain-3.1-source.tar.xz) = c1ab2c2162c1046786254090f939d60da87994efad5715dde68aa5247f33eaa3
+SIZE (rsgain-3.1-source.tar.xz) = 44904
diff --git a/audio/rsgain/files/patch-src_tag.cpp b/audio/rsgain/files/patch-src_tag.cpp
deleted file mode 100644
index 4967905acf88..000000000000
--- a/audio/rsgain/files/patch-src_tag.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
-/wrkdirs/usr/ports/audio/rsgain/work/rsgain-3.0.1/src/tag.cpp:254:5: error: no member named 'round' in namespace 'std'
- GAIN_TO_Q78(track.result.album_gain) : GAIN_TO_Q78(track.result.track_gain);
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-/wrkdirs/usr/ports/audio/rsgain/work/rsgain-3.0.1/src/tag.hpp:35:38: note: expanded from macro 'GAIN_TO_Q78'
-#define GAIN_TO_Q78(gain) (int) std::round(gain * 256.f)
- ~~~~~^
-
---- src/tag.cpp.orig 2022-10-19 02:49:19 UTC
-+++ src/tag.cpp
-@@ -28,7 +28,7 @@
- * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <math.h>
-+#include <cmath>
- #include <stdio.h>
- #include <string.h>
- #include <string>
-@@ -506,4 +506,4 @@ void taglib_get_version(std::string &buffer)
- void taglib_get_version(std::string &buffer)
- {
- buffer = fmt::format("{}.{}.{}", TAGLIB_MAJOR_VERSION, TAGLIB_MINOR_VERSION, TAGLIB_PATCH_VERSION);
--}
-\ No newline at end of file
-+}