aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Compare/Makefile22
-rw-r--r--devel/p5-Data-Compare/distinfo1
-rw-r--r--devel/p5-Data-Compare/pkg-comment1
-rw-r--r--devel/p5-Data-Compare/pkg-descr5
-rw-r--r--devel/p5-Data-Compare/pkg-plist5
6 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8913d58da969..1be90cdf0884 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -267,6 +267,7 @@
SUBDIR += p5-Class-Tom
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Curses
+ SUBDIR += p5-Data-Compare
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-ShowTable
SUBDIR += p5-Date-Calc
diff --git a/devel/p5-Data-Compare/Makefile b/devel/p5-Data-Compare/Makefile
new file mode 100644
index 000000000000..54cb28da3686
--- /dev/null
+++ b/devel/p5-Data-Compare/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Data-Compare
+# Date created: 25 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Compare
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Compare.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Compare/distinfo b/devel/p5-Data-Compare/distinfo
new file mode 100644
index 000000000000..8d3bd5d4e59e
--- /dev/null
+++ b/devel/p5-Data-Compare/distinfo
@@ -0,0 +1 @@
+MD5 (Data-Compare-0.02.tar.gz) = 785f5c49529a8053642b5eb9c49107f7
diff --git a/devel/p5-Data-Compare/pkg-comment b/devel/p5-Data-Compare/pkg-comment
new file mode 100644
index 000000000000..df83ab621fad
--- /dev/null
+++ b/devel/p5-Data-Compare/pkg-comment
@@ -0,0 +1 @@
+Data::Compare - compare perl data structures
diff --git a/devel/p5-Data-Compare/pkg-descr b/devel/p5-Data-Compare/pkg-descr
new file mode 100644
index 000000000000..f22fa83effae
--- /dev/null
+++ b/devel/p5-Data-Compare/pkg-descr
@@ -0,0 +1,5 @@
+Compare two perl data structures recursively. Returns 0 if the
+structures differ, else returns 1.
+
+-Anton
+<tobez@tobez.org>
diff --git a/devel/p5-Data-Compare/pkg-plist b/devel/p5-Data-Compare/pkg-plist
new file mode 100644
index 000000000000..10cb9cd66f0a
--- /dev/null
+++ b/devel/p5-Data-Compare/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/Compare/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Data/Compare.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/Compare
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Data 2>/dev/null || true