aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/geoid/Makefile2
-rw-r--r--devel/py-game/Makefile2
-rw-r--r--games/fs2open/Makefile2
-rw-r--r--games/openage/Makefile2
-rw-r--r--games/supertux2/Makefile2
-rw-r--r--games/vegastrike/Makefile2
-rw-r--r--graphics/aeskulap/Makefile2
-rw-r--r--graphics/dcmtk/Makefile2
-rw-r--r--graphics/electricsheep/Makefile2
-rw-r--r--graphics/flif/Makefile2
-rw-r--r--graphics/libheif/Makefile2
-rw-r--r--graphics/luminance-qt5/Makefile2
-rw-r--r--graphics/magnum-extras/Makefile2
-rw-r--r--graphics/magnum-plugins/Makefile2
-rw-r--r--graphics/open3d/Makefile2
-rw-r--r--graphics/vv/Makefile2
-rw-r--r--graphics/yafaray/Makefile2
-rw-r--r--java/openjdk11/Makefile2
-rw-r--r--java/openjdk12/Makefile2
-rw-r--r--misc/libemos/Makefile2
-rw-r--r--misc/visp/Makefile2
-rw-r--r--misc/zygrib/Makefile2
-rw-r--r--multimedia/cinelerra-gg/Makefile2
-rw-r--r--multimedia/emby-server/Makefile2
-rw-r--r--net-im/telegram-purple/Makefile2
-rw-r--r--science/coot/Makefile2
-rw-r--r--science/lammps/Makefile2
-rw-r--r--science/liggghts/Makefile2
-rw-r--r--science/molscript/Makefile2
-rw-r--r--science/octopus/Makefile2
-rw-r--r--science/teem/Makefile2
-rw-r--r--sysutils/tracker-miners/Makefile2
-rw-r--r--www/dillo2/Makefile2
33 files changed, 33 insertions, 33 deletions
diff --git a/comms/geoid/Makefile b/comms/geoid/Makefile
index a05eeb3b12d3..745ecaeec3b2 100644
--- a/comms/geoid/Makefile
+++ b/comms/geoid/Makefile
@@ -17,7 +17,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= gmake jpeg
USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index 38245ae12d3d..cda834d649fa 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/docs/LGPL
BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsmpeg.so:multimedia/smpeg
RUN_DEPENDS= ${PYNUMPY} \
v4l_compat>0:multimedia/v4l_compat
diff --git a/games/fs2open/Makefile b/games/fs2open/Makefile
index 555263d9900c..b6a93e8051c3 100644
--- a/games/fs2open/Makefile
+++ b/games/fs2open/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror auto-accept
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++11-lang lua:51 jpeg openal pkgconfig sdl
LLD_UNSAFE= yes
diff --git a/games/openage/Makefile b/games/openage/Makefile
index 9714793e1268..551247ef5667 100644
--- a/games/openage/Makefile
+++ b/games/openage/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libogg.so:audio/libogg \
libopus.so:audio/opus \
libopusfile.so:audio/opusfile \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libnyan.so:lang/nyan
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
diff --git a/games/supertux2/Makefile b/games/supertux2/Makefile
index 80a7b3eaaa01..c9f3738c0a2c 100644
--- a/games/supertux2/Makefile
+++ b/games/supertux2/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
libphysfs.so:devel/physfs \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libcurl.so:ftp/curl \
libvorbis.so:audio/libvorbis
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index aeadcda09672..aea854828549 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/${DATADIR_REL}/vegastrike.ico:games/vegastrike-data
LIB_DEPENDS= ${PY_BOOST} \
libexpat.so:textproc/expat2 \
libogg.so:audio/libogg \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libvorbis.so:audio/libvorbis \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
diff --git a/graphics/aeskulap/Makefile b/graphics/aeskulap/Makefile
index 70c1ac0e63cd..3226c979c021 100644
--- a/graphics/aeskulap/Makefile
+++ b/graphics/aeskulap/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libdcmimage.so:graphics/dcmtk \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libglademm-2.4.so:devel/libglademm24 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= compiler:c++11-lang autoreconf desktop-file-utils gettext \
diff --git a/graphics/dcmtk/Makefile b/graphics/dcmtk/Makefile
index ade8b4fa0d8c..aef0640b6b03 100644
--- a/graphics/dcmtk/Makefile
+++ b/graphics/dcmtk/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libicuuc.so:devel/icu \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= compiler:c++11-lang cmake gnome jpeg ssl
diff --git a/graphics/electricsheep/Makefile b/graphics/electricsheep/Makefile
index 52057aecc421..719d0be97a9f 100644
--- a/graphics/electricsheep/Makefile
+++ b/graphics/electricsheep/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libavcodec.so:multimedia/ffmpeg \
libGLee.so:graphics/glee \
libgtop-2.0.so:devel/libgtop \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtinyxml.so:textproc/tinyxml
RUN_DEPENDS= flam3-animate:graphics/flam3
diff --git a/graphics/flif/Makefile b/graphics/flif/Makefile
index 672a860128d6..90c13cc37948 100644
--- a/graphics/flif/Makefile
+++ b/graphics/flif/Makefile
@@ -12,7 +12,7 @@ COMMENT= Free Lossless Image Format
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../LICENSE_Apache2
-LIB_DEPENDS= libpng16.so:graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
USES= cmake compiler:c++11-lang gettext-runtime gnome localbase:ldflags pkgconfig sdl shared-mime-info
USE_GITHUB= yes
diff --git a/graphics/libheif/Makefile b/graphics/libheif/Makefile
index 61bc98126e29..884ff1cdb323 100644
--- a/graphics/libheif/Makefile
+++ b/graphics/libheif/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= libde265.so:multimedia/libde265
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= libpng16.so:graphics/png
+LIB_DEPENDS+= libpng.so:graphics/png
.endif
.if ${PORT_OPTIONS:MX265}
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index ac23600f36e2..be8730a1e59d 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libgsl.so:math/gsl \
libexiv2.so:graphics/exiv2 \
liblcms2.so:graphics/lcms2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libIlmImf.so:graphics/openexr \
libboost_date_time.so:devel/boost-libs
diff --git a/graphics/magnum-extras/Makefile b/graphics/magnum-extras/Makefile
index d1bb7ca80484..dcc8f3ee17e4 100644
--- a/graphics/magnum-extras/Makefile
+++ b/graphics/magnum-extras/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
libfreetype.so:print/freetype2 \
libIL.so:graphics/devil \
libMagnum.so:graphics/magnum \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++14-lang gl
USE_GITHUB= yes
diff --git a/graphics/magnum-plugins/Makefile b/graphics/magnum-plugins/Makefile
index 1f3eb5b1772d..537ac2123d00 100644
--- a/graphics/magnum-plugins/Makefile
+++ b/graphics/magnum-plugins/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
libfreetype.so:print/freetype2 \
libIL.so:graphics/devil \
libMagnum.so:graphics/magnum \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++14-lang gl jpeg openal
USE_GITHUB= yes
diff --git a/graphics/open3d/Makefile b/graphics/open3d/Makefile
index 67dd77085348..27fed48fef2e 100644
--- a/graphics/open3d/Makefile
+++ b/graphics/open3d/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
LIB_DEPENDS= libglfw.so:graphics/glfw \
libjsoncpp.so:devel/jsoncpp \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++14-lang eigen:3 jpeg localbase:ldflags pkgconfig
USE_GITHUB= yes
diff --git a/graphics/vv/Makefile b/graphics/vv/Makefile
index 86fe32ec8dd1..f473a7761a85 100644
--- a/graphics/vv/Makefile
+++ b/graphics/vv/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libgdcmCommon.so:devel/gdcm \
libhdf5_cpp.so:science/hdf5 \
libITKLabelMap-4.13.so:science/InsightToolkit \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsz.so:science/szip \
libtiff.so:graphics/tiff \
libvtkIOSQL-8.1.so:math/vtk8
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index ff2411e58d87..e272bb25c18b 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libIlmImf.so:graphics/openexr \
libopencv_photo.so:graphics/opencv \
libopencv_core.so:graphics/opencv-core \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= cmake gnome jpeg
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index a25a55eaba5c..42d79695c4a3 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfreetype.so:print/freetype2 \
libgif.so:graphics/giflib \
liblcms2.so:graphics/lcms2 \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= compiler:features gmake iconv jpeg pkgconfig
USE_XORG= x11 xext xi xrender xt xtst
diff --git a/java/openjdk12/Makefile b/java/openjdk12/Makefile
index dfba2e9b82bf..77dbc17c7101 100644
--- a/java/openjdk12/Makefile
+++ b/java/openjdk12/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfreetype.so:print/freetype2 \
libgif.so:graphics/giflib \
liblcms2.so:graphics/lcms2 \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= compiler:features gmake iconv jpeg pkgconfig
USE_XORG= x11 xext xi xrandr xrender xt xtst
diff --git a/misc/libemos/Makefile b/misc/libemos/Makefile
index 9fc0bca475c4..2dc5d8f09932 100644
--- a/misc/libemos/Makefile
+++ b/misc/libemos/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libeccodes.so:science/eccodes \
libfftw3.so:math/fftw3 \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake:noninja fortran
diff --git a/misc/visp/Makefile b/misc/visp/Makefile
index aa455bb188ba..dae9489cb685 100644
--- a/misc/visp/Makefile
+++ b/misc/visp/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libopencv_videoio.so:graphics/opencv \
libpcl_common.so:graphics/pcl-pointclouds \
libqhull.so:math/qhull5 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libv4l2.so:multimedia/libv4l
USES= cmake compiler:c++11-lang eigen:3 fortran gnome jpeg
diff --git a/misc/zygrib/Makefile b/misc/zygrib/Makefile
index d229728ed869..c49562992969 100644
--- a/misc/zygrib/Makefile
+++ b/misc/zygrib/Makefile
@@ -17,7 +17,7 @@ BROKEN_i386= g2clib/libg2c.a: could not read symbols: File format not recognized
FETCH_DEPENDS= curl:ftp/curl
LIB_DEPENDS= libjasper.so:graphics/jasper \
libnova.so:astro/libnova \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libproj.so:graphics/proj \
libqwt6.so:x11-toolkits/qwt6
diff --git a/multimedia/cinelerra-gg/Makefile b/multimedia/cinelerra-gg/Makefile
index 3c431feea80f..29edad551556 100644
--- a/multimedia/cinelerra-gg/Makefile
+++ b/multimedia/cinelerra-gg/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libogg.so:audio/libogg \
libopenjp2.so:graphics/openjpeg \
libopus.so:audio/opus \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsndfile.so:audio/libsndfile \
libtheoraenc.so:multimedia/libtheora \
libtiff.so:graphics/tiff \
diff --git a/multimedia/emby-server/Makefile b/multimedia/emby-server/Makefile
index 44d51e7d414a..b5718c29c910 100644
--- a/multimedia/emby-server/Makefile
+++ b/multimedia/emby-server/Makefile
@@ -36,7 +36,7 @@ LIB_DEPENDS= libass.so:multimedia/libass \
libgnutls.so:security/gnutls \
libogg.so:audio/libogg \
libopus.so:audio/opus \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtheora.so:multimedia/libtheora \
libva.so:multimedia/libva \
libvorbis.so:audio/libvorbis \
diff --git a/net-im/telegram-purple/Makefile b/net-im/telegram-purple/Makefile
index ca01515c4bc7..e8110c4b4ece 100644
--- a/net-im/telegram-purple/Makefile
+++ b/net-im/telegram-purple/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= pidgin:net-im/pidgin
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libwebp.so:graphics/webp \
libpurple.so:net-im/libpurple \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
diff --git a/science/coot/Makefile b/science/coot/Makefile
index 8c7264176e12..5f18ccd6b5d8 100644
--- a/science/coot/Makefile
+++ b/science/coot/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libccp4c.so:science/libccp4 \
libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libgsl.so:math/gsl \
libmmdb2.so:science/mmdb2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsfftw.so:math/fftw-float \
libssm.so:science/libssm
RUN_DEPENDS= bash:shells/bash
diff --git a/science/lammps/Makefile b/science/lammps/Makefile
index 6c9434298b43..bc6cdd95bff1 100644
--- a/science/lammps/Makefile
+++ b/science/lammps/Makefile
@@ -42,7 +42,7 @@ JPEG_CMAKE_BOOL= WITH_JPEG
JPEG_USES= jpeg
PNG_CMAKE_BOOL= WITH_PNG
-PNG_LIB_DEPENDS= libpng16.so:graphics/png
+PNG_LIB_DEPENDS= libpng.so:graphics/png
GZIP_CMAKE_BOOL= WITH_GZIP
diff --git a/science/liggghts/Makefile b/science/liggghts/Makefile
index b6eb633e7b38..c9bbce6aa1a4 100644
--- a/science/liggghts/Makefile
+++ b/science/liggghts/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
libmpi.so:net/openmpi \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libvtkViewsCore-8.1.so:math/vtk8
diff --git a/science/molscript/Makefile b/science/molscript/Makefile
index 6ed86f2e41db..15c2d11aa609 100644
--- a/science/molscript/Makefile
+++ b/science/molscript/Makefile
@@ -10,7 +10,7 @@ COMMENT= Display 3D molecules in schematic and detailed representations
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
-LIB_DEPENDS= libpng16.so:graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
RUN_DEPENDS= render:graphics/raster3d # molscript use requires the executable 'render' to be present
USES= gl gmake jpeg localbase:ldflags
diff --git a/science/octopus/Makefile b/science/octopus/Makefile
index 3a4440b0d04c..b303ebccddd6 100644
--- a/science/octopus/Makefile
+++ b/science/octopus/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libarpack.so:math/arpack-ng \
libgsl.so:math/gsl \
liblapack.so:math/lapack \
libnlopt.so:math/nlopt \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsymspg.so:science/spglib \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
diff --git a/science/teem/Makefile b/science/teem/Makefile
index 8859e9b50e6a..961f8e6be805 100644
--- a/science/teem/Makefile
+++ b/science/teem/Makefile
@@ -12,7 +12,7 @@ COMMENT= Libraries for representing, processing and visualizing scientific data
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libpng16.so:graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
USES= cmake
USE_LDCONFIG= yes
diff --git a/sysutils/tracker-miners/Makefile b/sysutils/tracker-miners/Makefile
index d625c1b28aba..895210893376 100644
--- a/sysutils/tracker-miners/Makefile
+++ b/sysutils/tracker-miners/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libFLAC.so:audio/flac \
libtotem-plparser.so:multimedia/totem-pl-parser \
libpoppler-glib.so:graphics/poppler-glib \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtag.so:audio/taglib \
libtiff.so:graphics/tiff \
libgif.so:graphics/giflib \
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 5f15950ff372..13cb586694c5 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -51,7 +51,7 @@ JPEG_CONFIGURE_ENABLE= jpeg
JPEG_USES= jpeg
PNG_CONFIGURE_ENABLE= png
-PNG_LIB_DEPENDS= libpng16.so:graphics/png
+PNG_LIB_DEPENDS= libpng.so:graphics/png
SSL_USES= ssl
SSL_CONFIGURE_ENABLE= ssl