aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/datovka/Makefile8
-rw-r--r--mail/datovka/files/patch-src_crypto_crypto.c12
2 files changed, 13 insertions, 7 deletions
diff --git a/mail/datovka/Makefile b/mail/datovka/Makefile
index 7e956c32bbf8..b9b2c561db02 100644
--- a/mail/datovka/Makefile
+++ b/mail/datovka/Makefile
@@ -19,10 +19,4 @@ USE_GL= gl
USE_QT= buildtools core gui network printsupport sql svg websockets \
widgets
-.include <bsd.port.pre.mk>
-
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-CXXFLAGS+= -DOPENSSL_API_COMPAT=0x30000000L
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/datovka/files/patch-src_crypto_crypto.c b/mail/datovka/files/patch-src_crypto_crypto.c
new file mode 100644
index 000000000000..098dd144f94c
--- /dev/null
+++ b/mail/datovka/files/patch-src_crypto_crypto.c
@@ -0,0 +1,12 @@
+--- src/crypto/crypto.c.orig 2023-08-07 16:26:04 UTC
++++ src/crypto/crypto.c
+@@ -312,7 +312,9 @@ int crypto_init(void)
+ OpenSSL_add_all_algorithms();
+
+ ERR_load_crypto_strings();
++#if OPENSSL_VERSION_NUMBER < 0x30000000L
+ ERR_load_CMS_strings();
++#endif
+ //ERR_free_strings();
+
+ if (NULL != ca_certs) {