aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dspdfviewer/Makefile36
-rw-r--r--graphics/dspdfviewer/distinfo3
-rw-r--r--graphics/dspdfviewer/pkg-descr9
4 files changed, 49 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e98c3e51b935..ac7973c4b5dd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -146,6 +146,7 @@
SUBDIR += dmtx-utils
SUBDIR += dri
SUBDIR += driconf
+ SUBDIR += dspdfviewer
SUBDIR += duhdraw
SUBDIR += dynamechs
SUBDIR += easypaint
diff --git a/graphics/dspdfviewer/Makefile b/graphics/dspdfviewer/Makefile
new file mode 100644
index 000000000000..842df9e3c87d
--- /dev/null
+++ b/graphics/dspdfviewer/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= dspdfviewer
+PORTVERSION= 1.15.1
+CATEGORIES= graphics
+
+MAINTAINER= santhosh.raju@gmail.com
+COMMENT= Dual-screen PDF viewer for LaTeX-beamer
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5 \
+ libboost_program_options.so:devel/boost-libs
+
+BUILD_WRKSRC= ${WRKSRC}/build
+CONFIGURE_WRKSRC= ${WRKSRC}/build
+INSTALL_WRKSRC= ${WRKSRC}/build
+
+USES= cmake pkgconfig
+USE_QT5= buildtools_build core gui qmake_build linguisttools widgets xml
+CMAKE_ARGS= -DPOPPLER_LIBRARIES=${LOCALBASE}/lib/libpoppler-qt5.so -DBuildTests=OFF
+USE_LDCONFIG= yes
+
+CMAKE_VERBOSE= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= dannyedel
+GH_PROJECT= dspdfviewer
+GH_TAGNAME= v1.15.1
+
+PLIST_FILES= bin/dspdfviewer \
+ share/applications/dspdfviewer.desktop \
+ share/man/man1/dspdfviewer.1
+
+.include <bsd.port.mk>
diff --git a/graphics/dspdfviewer/distinfo b/graphics/dspdfviewer/distinfo
new file mode 100644
index 000000000000..1977bf7c804f
--- /dev/null
+++ b/graphics/dspdfviewer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492284790
+SHA256 (dannyedel-dspdfviewer-1.15.1-v1.15.1_GH0.tar.gz) = c5b6f8c93d732e65a27810286d49a4b1c6f777d725e26a207b14f6b792307b03
+SIZE (dannyedel-dspdfviewer-1.15.1-v1.15.1_GH0.tar.gz) = 165202
diff --git a/graphics/dspdfviewer/pkg-descr b/graphics/dspdfviewer/pkg-descr
new file mode 100644
index 000000000000..cce05da38efd
--- /dev/null
+++ b/graphics/dspdfviewer/pkg-descr
@@ -0,0 +1,9 @@
+dspdfviewer a simple viewer for latex-beamer presentations that are built with
+the show notes on second screen option of latex-beamer. It will take your PDF
+file, split it in a left and right half and render the two halves individually
+to the screens.
+
+In addition, your laptop screen will contain some counters and a wall-clock,
+which may help you time your presentation right.
+
+WWW: https://github.com/dannyedel/dspdfviewer