aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/libressl-devel/Makefile3
-rw-r--r--security/libressl/Makefile3
-rw-r--r--security/openssl-devel/Makefile6
-rw-r--r--security/openssl/Makefile3
4 files changed, 11 insertions, 4 deletions
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index 279d2f916a6e..e42689066d60 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -22,7 +22,8 @@ NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl-[0-9]* \
openssl-[0-9]* \
- openssl-devel-[0-9]*
+ openssl-devel-[0-9]* \
+ openssl111-[0-9]*
NC_CONFIGURE_ENABLE= nc
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 3a63390cb4f2..6967707677a5 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -21,7 +21,8 @@ NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl-devel-[0-9]* \
openssl-[0-9]* \
- openssl-devel-[0-9]*
+ openssl-devel-[0-9]* \
+ openssl111-[0-9]*
NC_CONFIGURE_ENABLE= nc
diff --git a/security/openssl-devel/Makefile b/security/openssl-devel/Makefile
index e0fbfb0efaa3..66ccb8277ba5 100644
--- a/security/openssl-devel/Makefile
+++ b/security/openssl-devel/Makefile
@@ -16,7 +16,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS_INSTALL= libressl-[0-9]* \
libressl-devel-[0-9]* \
- openssl-[0-9]*
+ openssl-[0-9]* \
+ openssl111-[0-9]*
+
+DEPRECATED= Upstream support ends 2019-09-11
+EXPIRATION_DATE= 2019-09-11
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index d00e133e18c3..3230f7ccbef3 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -18,7 +18,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS_INSTALL= libressl-[0-9]* \
libressl-devel-[0-9]* \
- openssl-devel-[0-9]*
+ openssl-devel-[0-9]* \
+ openssl111-[0-9]*
OPTIONS_DEFINE= DOCS MAN3 PADLOCK RFC3779 SHARED THREADS ZLIB
OPTIONS_DEFAULT= ASM MD2 MAN3 SCTP SHARED SSE2 SSL2 SSL3 THREADS