aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-PkgConfig/Makefile24
-rw-r--r--devel/p5-ExtUtils-PkgConfig/distinfo1
-rw-r--r--devel/p5-ExtUtils-PkgConfig/pkg-descr12
-rw-r--r--devel/p5-ExtUtils-PkgConfig/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aa3c7451362a..9ed903e4fc66 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -634,6 +634,7 @@
SUBDIR += p5-Exporter-Lite
SUBDIR += p5-ExtUtils-Depends
SUBDIR += p5-ExtUtils-ParseXS
+ SUBDIR += p5-ExtUtils-PkgConfig
SUBDIR += p5-ExtUtils-XSBuilder
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
diff --git a/devel/p5-ExtUtils-PkgConfig/Makefile b/devel/p5-ExtUtils-PkgConfig/Makefile
new file mode 100644
index 000000000000..b9f55980cc81
--- /dev/null
+++ b/devel/p5-ExtUtils-PkgConfig/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ExtUtils-PkgConfig
+# Date created: 18 October 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-PkgConfig
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Simplistic interface to pkg-config
+
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::PkgConfig.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-PkgConfig/distinfo b/devel/p5-ExtUtils-PkgConfig/distinfo
new file mode 100644
index 000000000000..751d7cf155a9
--- /dev/null
+++ b/devel/p5-ExtUtils-PkgConfig/distinfo
@@ -0,0 +1 @@
+MD5 (ExtUtils-PkgConfig-1.00.tar.gz) = 1257bba008178c209149a1e76c0389b3
diff --git a/devel/p5-ExtUtils-PkgConfig/pkg-descr b/devel/p5-ExtUtils-PkgConfig/pkg-descr
new file mode 100644
index 000000000000..387906591d56
--- /dev/null
+++ b/devel/p5-ExtUtils-PkgConfig/pkg-descr
@@ -0,0 +1,12 @@
+The pkg-config program retrieves information about installed libraries,
+usually for the purposes of compiling against and linking to them.
+
+ExtUtils::PkgConfig is a very simplistic interface to this utility,
+intended for use in the Makefile.PL of perl extensions which bind
+libraries that pkg-config knows. It is really just boilerplate code
+that you would've written yourself.
+
+WWW: http://search.cpan.org/dist/ExtUtils-PkgConfig/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-ExtUtils-PkgConfig/pkg-plist b/devel/p5-ExtUtils-PkgConfig/pkg-plist
new file mode 100644
index 000000000000..9fbe0ae1f9ad
--- /dev/null
+++ b/devel/p5-ExtUtils-PkgConfig/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/PkgConfig/.packlist
+%%SITE_PERL%%/ExtUtils/PkgConfig.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/PkgConfig
+@unexec rmdir %D/%%SITE_PERL%%/ExtUtils 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils 2>/dev/null || true