aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--UPDATING9
-rw-r--r--devel/libpeas/Makefile2
-rw-r--r--mail/py-milter/Makefile2
-rw-r--r--math/py-matplotlib/Makefile2
-rw-r--r--textproc/py-enchant/Makefile2
6 files changed, 14 insertions, 5 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index d2d9bd5850ef..62ff721af6d4 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -82,7 +82,7 @@ PGSQL_DEFAULT?= 9.5
# Possible values: 7.1, 7.2, 7.3
PHP_DEFAULT?= 7.2
# Possible values: 2.7, 3.5, 3.6, 3.7
-PYTHON_DEFAULT?= 2.7
+PYTHON_DEFAULT?= 3.6
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
# Possible values: 3.5, 3.6, 3.7
diff --git a/UPDATING b/UPDATING
index 140b15758f03..b2628b449e6d 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20190410:
+ AFFECTS: users of python
+ AUTHOR: antoine@FreeBSD.org
+
+ Default version of python was switched to 3.6.
+
+ For ports users wanting to keep version 2.7 as default,
+ add DEFAULT_VERSIONS+= python=2.7 to make.conf
+
20190328:
AFFECTS: www/firefox-i18n, www/firefox-esr-i18n, mail/thunderbird-i18n, www/seamonkey-i18n
AUTHOR: gecko@FreeBSD.org
diff --git a/devel/libpeas/Makefile b/devel/libpeas/Makefile
index 689c94f308d6..168604776cbb 100644
--- a/devel/libpeas/Makefile
+++ b/devel/libpeas/Makefile
@@ -38,7 +38,7 @@ PLIST= ${.CURDIR}/pkg-plist
USES+= python
USE_PYTHON= flavors
USE_GNOME+= pygobject3
-.if ${FLAVOR:Upy27:Mpy2*}
+.if ${FLAVOR:Upy36:Mpy2*}
CONFIGURE_ARGS+= --disable-python3
BUILD_WRKSRC= ${WRKSRC}/loaders/python
INSTALL_WRKSRC= ${WRKSRC}/loaders/python
diff --git a/mail/py-milter/Makefile b/mail/py-milter/Makefile
index 49068b301ff3..a3a927ac99c7 100644
--- a/mail/py-milter/Makefile
+++ b/mail/py-milter/Makefile
@@ -31,7 +31,7 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${FLAVOR:Upy27:Mpy3*}
+.if ${FLAVOR:Upy36:Mpy3*}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-miltermodule.c
.endif
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 9d7667ffcc57..03d2cd174538 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -35,7 +35,7 @@ OPTIONS_DEFINE= EXAMPLES GTKBACKEND GTKAGGBACKEND \
QT5AGGBACKEND TKAGGBACKEND WXAGGBACKEND
OPTIONS_DEFAULT= GTKBACKEND GTKAGGBACKEND TKAGGBACKEND
OPTIONS_SUB= yes
-.if ${FLAVOR:U:Mpy3*}
+.if ${FLAVOR:Upy36:Mpy3*}
# x11-toolkits/py-gtk2, x11-toolkits/py-wxPython28 do not support Python 3
OPTIONS_EXCLUDE= GTKBACKEND GTKAGGBACKEND WXAGGBACKEND
.endif
diff --git a/textproc/py-enchant/Makefile b/textproc/py-enchant/Makefile
index 6b5b26b99c42..084929866d20 100644
--- a/textproc/py-enchant/Makefile
+++ b/textproc/py-enchant/Makefile
@@ -20,7 +20,7 @@ OPTIONS_DEFINE= WX
OPTIONS_DEFAULT=WX
WX_DESC= Provide a wxSpellCheckerDialog
OPTIONS_SUB= yes
-.if ${FLAVOR:U:Mpy3*}
+.if ${FLAVOR:Upy36:Mpy3*}
OPTIONS_EXCLUDE= WX
.endif