aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/php81-intl/Makefile1
-rw-r--r--devel/php81-intl/files/patch-config.m422
-rw-r--r--devel/php82-intl/Makefile2
-rw-r--r--devel/php82-intl/files/patch-config.m422
-rw-r--r--devel/php83-intl/Makefile2
-rw-r--r--devel/php83-intl/files/patch-config.m422
6 files changed, 69 insertions, 2 deletions
diff --git a/devel/php81-intl/Makefile b/devel/php81-intl/Makefile
index 1ccc80b52ca4..9b26b350679d 100644
--- a/devel/php81-intl/Makefile
+++ b/devel/php81-intl/Makefile
@@ -1,3 +1,4 @@
+PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php81
diff --git a/devel/php81-intl/files/patch-config.m4 b/devel/php81-intl/files/patch-config.m4
new file mode 100644
index 000000000000..e78dbf7844e7
--- /dev/null
+++ b/devel/php81-intl/files/patch-config.m4
@@ -0,0 +1,22 @@
+https://github.com/php/php-src/commit/037855fcd3f2
+
+--- config.m4.orig 2024-04-09 18:46:23 UTC
++++ config.m4
+@@ -80,7 +80,16 @@ if test "$PHP_INTL" != "no"; then
+ breakiterator/codepointiterator_methods.cpp"
+
+ PHP_REQUIRE_CXX()
+- PHP_CXX_COMPILE_STDCXX(11, mandatory, PHP_INTL_STDCXX)
++
++ AC_MSG_CHECKING([if intl requires -std=gnu++17])
++ AS_IF([test "$PKG_CONFIG icu-uc --atleast-version=74"],[
++ AC_MSG_RESULT([yes])
++ PHP_CXX_COMPILE_STDCXX(17, mandatory, PHP_INTL_STDCXX)
++ ],[
++ AC_MSG_RESULT([no])
++ PHP_CXX_COMPILE_STDCXX(11, mandatory, PHP_INTL_STDCXX)
++ ])
++
+ PHP_INTL_CXX_FLAGS="$INTL_COMMON_FLAGS $PHP_INTL_STDCXX $ICU_CXXFLAGS"
+ case $host_alias in
+ *cygwin*) PHP_INTL_CXX_FLAGS="$PHP_INTL_CXX_FLAGS -D_POSIX_C_SOURCE=200809L"
diff --git a/devel/php82-intl/Makefile b/devel/php82-intl/Makefile
index 345c2d19f89c..ee29a2235e91 100644
--- a/devel/php82-intl/Makefile
+++ b/devel/php82-intl/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php82
diff --git a/devel/php82-intl/files/patch-config.m4 b/devel/php82-intl/files/patch-config.m4
new file mode 100644
index 000000000000..e78dbf7844e7
--- /dev/null
+++ b/devel/php82-intl/files/patch-config.m4
@@ -0,0 +1,22 @@
+https://github.com/php/php-src/commit/037855fcd3f2
+
+--- config.m4.orig 2024-04-09 18:46:23 UTC
++++ config.m4
+@@ -80,7 +80,16 @@ if test "$PHP_INTL" != "no"; then
+ breakiterator/codepointiterator_methods.cpp"
+
+ PHP_REQUIRE_CXX()
+- PHP_CXX_COMPILE_STDCXX(11, mandatory, PHP_INTL_STDCXX)
++
++ AC_MSG_CHECKING([if intl requires -std=gnu++17])
++ AS_IF([test "$PKG_CONFIG icu-uc --atleast-version=74"],[
++ AC_MSG_RESULT([yes])
++ PHP_CXX_COMPILE_STDCXX(17, mandatory, PHP_INTL_STDCXX)
++ ],[
++ AC_MSG_RESULT([no])
++ PHP_CXX_COMPILE_STDCXX(11, mandatory, PHP_INTL_STDCXX)
++ ])
++
+ PHP_INTL_CXX_FLAGS="$INTL_COMMON_FLAGS $PHP_INTL_STDCXX $ICU_CXXFLAGS"
+ case $host_alias in
+ *cygwin*) PHP_INTL_CXX_FLAGS="$PHP_INTL_CXX_FLAGS -D_POSIX_C_SOURCE=200809L"
diff --git a/devel/php83-intl/Makefile b/devel/php83-intl/Makefile
index 347b1c99552a..fa5f5245ebaf 100644
--- a/devel/php83-intl/Makefile
+++ b/devel/php83-intl/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php83
diff --git a/devel/php83-intl/files/patch-config.m4 b/devel/php83-intl/files/patch-config.m4
new file mode 100644
index 000000000000..e78dbf7844e7
--- /dev/null
+++ b/devel/php83-intl/files/patch-config.m4
@@ -0,0 +1,22 @@
+https://github.com/php/php-src/commit/037855fcd3f2
+
+--- config.m4.orig 2024-04-09 18:46:23 UTC
++++ config.m4
+@@ -80,7 +80,16 @@ if test "$PHP_INTL" != "no"; then
+ breakiterator/codepointiterator_methods.cpp"
+
+ PHP_REQUIRE_CXX()
+- PHP_CXX_COMPILE_STDCXX(11, mandatory, PHP_INTL_STDCXX)
++
++ AC_MSG_CHECKING([if intl requires -std=gnu++17])
++ AS_IF([test "$PKG_CONFIG icu-uc --atleast-version=74"],[
++ AC_MSG_RESULT([yes])
++ PHP_CXX_COMPILE_STDCXX(17, mandatory, PHP_INTL_STDCXX)
++ ],[
++ AC_MSG_RESULT([no])
++ PHP_CXX_COMPILE_STDCXX(11, mandatory, PHP_INTL_STDCXX)
++ ])
++
+ PHP_INTL_CXX_FLAGS="$INTL_COMMON_FLAGS $PHP_INTL_STDCXX $ICU_CXXFLAGS"
+ case $host_alias in
+ *cygwin*) PHP_INTL_CXX_FLAGS="$PHP_INTL_CXX_FLAGS -D_POSIX_C_SOURCE=200809L"