aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/lapack/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index 3e7f3ad4827d..34ba355db8a0 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -80,6 +80,10 @@ PICFLAG?= -fpic
FFLAGS_PROFILE?= -pg
FFLAGS_SHARED ?= ${PICFLAG}
+.if ${PORT_OPTIONS:MPROFILE}
+LDFLAGS+= -static
+.endif
+
.if ${PORT_OPTIONS:MPROFILE} && !exists(/usr/lib/libc_p.a)
IGNORE= you have chosen WITH_PROFILE, but have not installed the\
base system profiling libraries