aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/linux-vmware-toolbox/Makefile18
-rw-r--r--emulators/linux-vmware-toolbox2/Makefile18
-rw-r--r--emulators/linux-vmware-toolbox4/Makefile18
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile18
-rw-r--r--emulators/linux-vmware-toolbox6/Makefile18
5 files changed, 70 insertions, 20 deletions
diff --git a/emulators/linux-vmware-toolbox/Makefile b/emulators/linux-vmware-toolbox/Makefile
index 0700d94f7652..31e279badb01 100644
--- a/emulators/linux-vmware-toolbox/Makefile
+++ b/emulators/linux-vmware-toolbox/Makefile
@@ -18,6 +18,7 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+IS_INTERACTIVE= yes
RESTRICTED= "Not sure if we can redistribute this."
@@ -45,16 +46,25 @@ MOUNT= /sbin/mount
UMOUNT= /sbin/umount
pre-fetch:
+.if !exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please do one of these:"
+ @${ECHO} "To install this port, please:"
@${ECHO} ""
- @${ECHO} " 1. Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
+ @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
@${ECHO} " and choose the file \"linux.flp\"."
@${ECHO} ""
- @${ECHO} " 2. Manually put the file \"linux.flp\" in ${DISTDIR}."
- @${ECHO} ""
@${ECHO} "========================================================================"
+ @${ECHO} ""
+ @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+ @(read line; \
+ case "$${line}" in \
+ [Nn]*) \
+ ${FALSE} ;; \
+ *) \
+ ${TRUE} ;; \
+ esac)
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")
diff --git a/emulators/linux-vmware-toolbox2/Makefile b/emulators/linux-vmware-toolbox2/Makefile
index 0700d94f7652..31e279badb01 100644
--- a/emulators/linux-vmware-toolbox2/Makefile
+++ b/emulators/linux-vmware-toolbox2/Makefile
@@ -18,6 +18,7 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+IS_INTERACTIVE= yes
RESTRICTED= "Not sure if we can redistribute this."
@@ -45,16 +46,25 @@ MOUNT= /sbin/mount
UMOUNT= /sbin/umount
pre-fetch:
+.if !exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please do one of these:"
+ @${ECHO} "To install this port, please:"
@${ECHO} ""
- @${ECHO} " 1. Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
+ @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
@${ECHO} " and choose the file \"linux.flp\"."
@${ECHO} ""
- @${ECHO} " 2. Manually put the file \"linux.flp\" in ${DISTDIR}."
- @${ECHO} ""
@${ECHO} "========================================================================"
+ @${ECHO} ""
+ @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+ @(read line; \
+ case "$${line}" in \
+ [Nn]*) \
+ ${FALSE} ;; \
+ *) \
+ ${TRUE} ;; \
+ esac)
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")
diff --git a/emulators/linux-vmware-toolbox4/Makefile b/emulators/linux-vmware-toolbox4/Makefile
index 0700d94f7652..31e279badb01 100644
--- a/emulators/linux-vmware-toolbox4/Makefile
+++ b/emulators/linux-vmware-toolbox4/Makefile
@@ -18,6 +18,7 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+IS_INTERACTIVE= yes
RESTRICTED= "Not sure if we can redistribute this."
@@ -45,16 +46,25 @@ MOUNT= /sbin/mount
UMOUNT= /sbin/umount
pre-fetch:
+.if !exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please do one of these:"
+ @${ECHO} "To install this port, please:"
@${ECHO} ""
- @${ECHO} " 1. Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
+ @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
@${ECHO} " and choose the file \"linux.flp\"."
@${ECHO} ""
- @${ECHO} " 2. Manually put the file \"linux.flp\" in ${DISTDIR}."
- @${ECHO} ""
@${ECHO} "========================================================================"
+ @${ECHO} ""
+ @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+ @(read line; \
+ case "$${line}" in \
+ [Nn]*) \
+ ${FALSE} ;; \
+ *) \
+ ${TRUE} ;; \
+ esac)
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
index 0700d94f7652..31e279badb01 100644
--- a/emulators/linux-vmware-toolbox5/Makefile
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -18,6 +18,7 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+IS_INTERACTIVE= yes
RESTRICTED= "Not sure if we can redistribute this."
@@ -45,16 +46,25 @@ MOUNT= /sbin/mount
UMOUNT= /sbin/umount
pre-fetch:
+.if !exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please do one of these:"
+ @${ECHO} "To install this port, please:"
@${ECHO} ""
- @${ECHO} " 1. Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
+ @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
@${ECHO} " and choose the file \"linux.flp\"."
@${ECHO} ""
- @${ECHO} " 2. Manually put the file \"linux.flp\" in ${DISTDIR}."
- @${ECHO} ""
@${ECHO} "========================================================================"
+ @${ECHO} ""
+ @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+ @(read line; \
+ case "$${line}" in \
+ [Nn]*) \
+ ${FALSE} ;; \
+ *) \
+ ${TRUE} ;; \
+ esac)
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")
diff --git a/emulators/linux-vmware-toolbox6/Makefile b/emulators/linux-vmware-toolbox6/Makefile
index 0700d94f7652..31e279badb01 100644
--- a/emulators/linux-vmware-toolbox6/Makefile
+++ b/emulators/linux-vmware-toolbox6/Makefile
@@ -18,6 +18,7 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+IS_INTERACTIVE= yes
RESTRICTED= "Not sure if we can redistribute this."
@@ -45,16 +46,25 @@ MOUNT= /sbin/mount
UMOUNT= /sbin/umount
pre-fetch:
+.if !exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please do one of these:"
+ @${ECHO} "To install this port, please:"
@${ECHO} ""
- @${ECHO} " 1. Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
+ @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
@${ECHO} " and choose the file \"linux.flp\"."
@${ECHO} ""
- @${ECHO} " 2. Manually put the file \"linux.flp\" in ${DISTDIR}."
- @${ECHO} ""
@${ECHO} "========================================================================"
+ @${ECHO} ""
+ @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+ @(read line; \
+ case "$${line}" in \
+ [Nn]*) \
+ ${FALSE} ;; \
+ *) \
+ ${TRUE} ;; \
+ esac)
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")