aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/links/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index 7e09b5dada87..7c4199f97001 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -16,7 +16,7 @@ MAINTAINER?= demon@FreeBSD.org
COMMENT= Lynx-like text WWW browser
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-javascript --with-ssl --without-svgalib
+CONFIGURE_ARGS+= --enable-javascript --with-ssl
CONFIGURE_ENV+= CPPFLAGS='-I${LOCALBASE}/include'
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,19 +26,33 @@ USE_REINPLACE= yes
.include <bsd.port.pre.mk>
+.if defined(WITH_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+CONFIGURE_ARGS+= --enable-graphics
+.else
+CONFIGURE_ARGS+= --without-svgalib
+.endif
+
.if !defined(WITHOUT_X11)
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
USE_XLIB= yes
CONFIGURE_ARGS+= --enable-graphics --with-x
+.else
+USE_XLIB= no
+CONFIGURE_ARGS+= --without-x
.endif
MAN1= links.1
PLIST_FILES= bin/links
pre-everything::
- @${ECHO_MSG} "Define WITHOUT_X11 to disable graphics support."
+ @${ECHO_MSG} "Use 'make -DWITH_SVGALIB' to enable svgalib (non-X11) graphics support."
+ @${ECHO_MSG} "Use 'make -DWITHOUT_X11' to disable X11 graphics support."
post-patch:
@${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/default.c