aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/flac/Makefile11
-rw-r--r--audio/flac/distinfo4
-rw-r--r--audio/flac/files/patch-Makefile.in16
-rw-r--r--audio/flac/files/patch-configure39
-rw-r--r--audio/flac/files/patch-doc_Makefile.in12
-rw-r--r--audio/flac/files/patch-doc_html_Makefile.in33
-rw-r--r--audio/flac/files/patch-doc_html_images_Makefile.in12
-rw-r--r--audio/flac/files/patch-doc_html_ru_Makefile.in12
-rw-r--r--audio/flac/files/patch-man_flac.16
-rw-r--r--audio/flac/files/patch-src_libFLAC_cpu.c15
-rw-r--r--audio/flac/pkg-descr32
-rw-r--r--audio/flac/pkg-plist57
-rw-r--r--audio/xmms-flac/Makefile16
-rw-r--r--audio/xmms-flac/distinfo6
-rw-r--r--audio/xmms-flac/files/patch-configure33
-rw-r--r--audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in30
-rw-r--r--audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c18
17 files changed, 188 insertions, 164 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 1264ef9db1c6..bc592aa61516 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= flac
-PORTVERSION= 1.1.0
-PORTREVISION= 4
+PORTVERSION= 1.1.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,13 +22,13 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_ICONV= yes
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-sse --enable-3dnow \
+CONFIGURE_ARGS= --enable-sse \
--with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}"
CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/include" \
- XMMS_CONFIG=/usr/bin/false # must be absolute path
+ ac_cv_path_XMMS_CONFIG=no
.if defined(NOPORTDOCS)
MAKE_ENV= DOC=""
@@ -48,6 +47,6 @@ post-build:
${REINPLACE_CMD} 's:%%PREFIX%%:${PREFIX}:' ${WRKSRC}/man/flac.1
test: build
- @cd ${WRKSRC}; make check
+ @cd ${WRKSRC}; ${MAKE} check
.include <bsd.port.mk>
diff --git a/audio/flac/distinfo b/audio/flac/distinfo
index 3e97e09b4f78..a6d2b4b2f674 100644
--- a/audio/flac/distinfo
+++ b/audio/flac/distinfo
@@ -1,2 +1,2 @@
-MD5 (flac-1.1.0.tar.gz) = 19b456a27b5fcf502c76cc33f33e1490
-SIZE (flac-1.1.0.tar.gz) = 1201861
+MD5 (flac-1.1.2.tar.gz) = 2bfc127cdda02834d0491ab531a20960
+SIZE (flac-1.1.2.tar.gz) = 1516235
diff --git a/audio/flac/files/patch-Makefile.in b/audio/flac/files/patch-Makefile.in
index 14d5d917a9c3..b0a73cdc9a22 100644
--- a/audio/flac/files/patch-Makefile.in
+++ b/audio/flac/files/patch-Makefile.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- Makefile.in.orig Wed Sep 25 06:53:31 2002
-+++ Makefile.in Sat Oct 5 01:29:53 2002
-@@ -144,7 +144,7 @@
- am__quote = @am__quote@
- install_sh = @install_sh@
-
+--- Makefile.in.orig
++++ Makefile.in
+@@ -258,7 +258,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
-SUBDIRS = doc include man src test build flac.pbproj obj
+SUBDIRS = $(DOC) include man src test build flac.pbproj
-
DISTCLEANFILES = libtool-disable-static
-
+ EXTRA_DIST = \
+ COPYING.FDL \
diff --git a/audio/flac/files/patch-configure b/audio/flac/files/patch-configure
index b16793a26fae..e335f4533ff4 100644
--- a/audio/flac/files/patch-configure
+++ b/audio/flac/files/patch-configure
@@ -1,40 +1,17 @@
$FreeBSD$
---- configure.orig Sun Feb 23 01:11:25 2003
-+++ configure Sun Feb 23 01:11:27 2003
-@@ -7817,6 +7817,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -9818,6 +9819,8 @@
- fi
-
-
-+# Disable id3lib detection
-+if false; then
-
- # Check whether --with-id3lib or --without-id3lib was given.
- if test "${with_id3lib+set}" = set; then
-@@ -10006,6 +10009,8 @@
-
- rm -f conf.id3libtest
-
-+fi
-+have_id3lib=no
-
-
- if test x$have_id3lib = xyes; then
-@@ -11713,7 +11718,7 @@
+--- configure.orig
++++ configure
+@@ -10541,9 +10541,9 @@
if test x$debug = xtrue; then
OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -g -O0 -DDEBUG"
else
-- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O3 -DNDEBUG"
+- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O2 -DNDEBUG"
+ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -DNDEBUG"
if test x$GCC = xyes; then
- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -fomit-frame-pointer -funroll-loops -finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__"
+- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O3 -fomit-frame-pointer -funroll-loops -finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__"
++ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -Wall -W -DFLaC__INLINE=__inline__"
fi
+ fi
+ CFLAGS="$OUR_CFLAGS_HEAD $CFLAGS"
diff --git a/audio/flac/files/patch-doc_Makefile.in b/audio/flac/files/patch-doc_Makefile.in
index 496e05d20bc5..7d82b0fba502 100644
--- a/audio/flac/files/patch-doc_Makefile.in
+++ b/audio/flac/files/patch-doc_Makefile.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- doc/Makefile.in.orig Sat Oct 5 01:22:15 2002
-+++ doc/Makefile.in Sat Oct 5 01:23:02 2002
-@@ -135,7 +135,7 @@
-
+--- doc/Makefile.in.orig
++++ doc/Makefile.in
+@@ -236,7 +236,7 @@
+ target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = foreign
SUBDIRS = . html
-
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+docdir = $(datadir)/doc/$(PACKAGE)
-
doc_DATA = \
FLAC.tag
+
diff --git a/audio/flac/files/patch-doc_html_Makefile.in b/audio/flac/files/patch-doc_html_Makefile.in
index 84ecda3a4988..b63d9e76e82d 100644
--- a/audio/flac/files/patch-doc_html_Makefile.in
+++ b/audio/flac/files/patch-doc_html_Makefile.in
@@ -1,14 +1,35 @@
$FreeBSD$
---- doc/html/Makefile.in.orig Sat Oct 5 01:22:20 2002
-+++ doc/html/Makefile.in Sat Oct 5 01:23:09 2002
-@@ -135,7 +135,7 @@
-
+--- doc/html/Makefile.in.orig
++++ doc/html/Makefile.in
+@@ -236,7 +236,7 @@
+ target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = foreign
SUBDIRS = ru images
-
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/html
+docdir = $(datadir)/doc/$(PACKAGE)/html
-
doc_DATA = \
+ changelog.html \
comparison.html \
+@@ -577,13 +577,13 @@
+
+ # The install targets don't copy whole directories so we have to
+ # handle 'api/' specially:
+-@FLaC__HAS_DOXYGEN_TRUE@install-data-local:
+-@FLaC__HAS_DOXYGEN_TRUE@ $(mkinstalldirs) $(DESTDIR)$(docdir)/api
+-@FLaC__HAS_DOXYGEN_TRUE@ (cd api && $(INSTALL_DATA) * $(DESTDIR)$(docdir)/api)
+-@FLaC__HAS_DOXYGEN_TRUE@uninstall-local:
+-@FLaC__HAS_DOXYGEN_TRUE@ rm -rf $(DESTDIR)$(docdir)/api
+-@FLaC__HAS_DOXYGEN_TRUE@maintainer-clean-local:
+-@FLaC__HAS_DOXYGEN_TRUE@ rm -rf api
++install-data-local:
++ $(mkinstalldirs) $(DESTDIR)$(docdir)/api
++ (cd api && $(INSTALL_DATA) * $(DESTDIR)$(docdir)/api)
++uninstall-local:
++ rm -rf $(DESTDIR)$(docdir)/api
++maintainer-clean-local:
++ rm -rf api
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/audio/flac/files/patch-doc_html_images_Makefile.in b/audio/flac/files/patch-doc_html_images_Makefile.in
index 57589f31dc80..e0eef34182bc 100644
--- a/audio/flac/files/patch-doc_html_images_Makefile.in
+++ b/audio/flac/files/patch-doc_html_images_Makefile.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- doc/html/images/Makefile.in.orig Sat Oct 5 01:22:31 2002
-+++ doc/html/images/Makefile.in Sat Oct 5 01:23:21 2002
-@@ -133,7 +133,7 @@
-
+--- doc/html/images/Makefile.in.orig
++++ doc/html/images/Makefile.in
+@@ -226,7 +226,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
AUTOMAKE_OPTIONS = foreign
-
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/html/images
+docdir = $(datadir)/doc/$(PACKAGE)/html/images
-
doc_DATA = \
1x1.gif \
+ cafebug.gif \
diff --git a/audio/flac/files/patch-doc_html_ru_Makefile.in b/audio/flac/files/patch-doc_html_ru_Makefile.in
index c0ddee3a669d..7843a0cc5469 100644
--- a/audio/flac/files/patch-doc_html_ru_Makefile.in
+++ b/audio/flac/files/patch-doc_html_ru_Makefile.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- doc/html/ru/Makefile.in.orig Sat Oct 5 01:22:27 2002
-+++ doc/html/ru/Makefile.in Sat Oct 5 01:23:15 2002
-@@ -133,7 +133,7 @@
-
+--- doc/html/ru/Makefile.in.orig
++++ doc/html/ru/Makefile.in
+@@ -226,7 +226,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
AUTOMAKE_OPTIONS = foreign
-
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/html/ru
+docdir = $(datadir)/doc/$(PACKAGE)/html/ru
-
doc_DATA = \
authors.html \
+ comparison.html \
diff --git a/audio/flac/files/patch-man_flac.1 b/audio/flac/files/patch-man_flac.1
index 2f41f9cacb68..58bb5ceaabb0 100644
--- a/audio/flac/files/patch-man_flac.1
+++ b/audio/flac/files/patch-man_flac.1
@@ -1,9 +1,9 @@
$FreeBSD$
---- man/flac.1.orig Wed Apr 16 00:53:22 2003
-+++ man/flac.1 Wed Apr 16 00:54:05 2003
-@@ -353,8 +353,7 @@
+--- man/flac.1.orig
++++ man/flac.1
+@@ -397,8 +397,7 @@
.PP
The programs are documented fully by HTML format
documentation, available in
diff --git a/audio/flac/files/patch-src_libFLAC_cpu.c b/audio/flac/files/patch-src_libFLAC_cpu.c
index 36a52ecc2fb8..adc10c2ec480 100644
--- a/audio/flac/files/patch-src_libFLAC_cpu.c
+++ b/audio/flac/files/patch-src_libFLAC_cpu.c
@@ -3,7 +3,7 @@ $FreeBSD$
--- src/libFLAC/cpu.c.orig
+++ src/libFLAC/cpu.c
-@@ -25,6 +25,11 @@
+@@ -37,6 +37,11 @@
#include <config.h>
#endif
@@ -12,22 +12,21 @@ $FreeBSD$
+#include <sys/sysctl.h>
+#endif
+
- const unsigned FLAC__CPUINFO_IA32_CPUID_CMOV = 0x00008000;
- const unsigned FLAC__CPUINFO_IA32_CPUID_MMX = 0x00800000;
- const unsigned FLAC__CPUINFO_IA32_CPUID_FXSR = 0x01000000;
-@@ -52,6 +57,15 @@
+ #if defined FLAC__CPU_PPC
+ #if !defined FLAC__NO_ASM
+ #if defined FLAC__SYS_DARWIN
+@@ -95,6 +100,14 @@
#ifndef FLAC__SSE_OS
info->data.ia32.fxsr = info->data.ia32.sse = info->data.ia32.sse2 = false;
-+#else
-+#if defined(__FreeBSD__)
++#elif defined(__FreeBSD__)
++ /* on FreeBSD we can double-check via sysctl whether the OS supports SSE */
+ {
+ int sse;
+ size_t len = sizeof(sse);
+ if (sysctlbyname("hw.instruction_sse", &sse, &len, NULL, 0) || !sse)
+ info->data.ia32.fxsr = info->data.ia32.sse = info->data.ia32.sse2 = false;
+ }
-+#endif
#endif
#ifdef FLAC__USE_3DNOW
diff --git a/audio/flac/pkg-descr b/audio/flac/pkg-descr
index 03576ee314da..84ebeba47487 100644
--- a/audio/flac/pkg-descr
+++ b/audio/flac/pkg-descr
@@ -1,24 +1,14 @@
-FLAC stands for Free Lossless Audio Codec. The FLAC project consists of:
+FLAC is an Open Source lossless audio codec.
- - the stream format
- - libFLAC, a library which implements a reference encoder, stream decoder,
- and file decoder
- - flac, which is a command-line wrapper around libFLAC to encode and
- decode .flac files
- - input plugins for various music players (Winamp, XMMS, and more in the
- works)
-
-What FLAC is:
- - FLAC is patent free
- - FLAC is lossless
- - FLAC is designed to compress audio data
- - The compression capabilities of FLAC are extendable
- - The currently implemented compression methods in the reference encoder
- yield streams smaller than shorten
- - FLAC is asymmetric in favor of decode speed
- - FLAC is suitable for archiving
- - FLAC is suitable for streaming
- - FLAC supports fast sample-accurate seeking
- - FLAC has an extendable metadata system
+FLAC is comprised of
+* libFLAC, a library which implements reference encoders and
+ decoders, and a metadata interface
+* libFLAC++, a C++ object wrapper library around libFLAC
+* libOggFLAC and libOggFLAC++, which provide encoders and
+ decoders for FLAC streams in an Ogg container
+* flac, a command-line program for encoding and decoding files
+* metaflac, a command-line program for viewing and editing FLAC
+ metadata
+* user and API documentation
WWW: http://flac.sourceforge.net/
diff --git a/audio/flac/pkg-plist b/audio/flac/pkg-plist
index a3e831097453..7b515e95fd38 100644
--- a/audio/flac/pkg-plist
+++ b/audio/flac/pkg-plist
@@ -8,6 +8,7 @@ include/FLAC++/export.h
include/FLAC++/metadata.h
include/FLAC/all.h
include/FLAC/assert.h
+include/FLAC/callback.h
include/FLAC/export.h
include/FLAC/file_decoder.h
include/FLAC/file_encoder.h
@@ -24,20 +25,24 @@ include/OggFLAC++/encoder.h
include/OggFLAC++/export.h
include/OggFLAC/all.h
include/OggFLAC/export.h
+include/OggFLAC/file_decoder.h
+include/OggFLAC/file_encoder.h
+include/OggFLAC/seekable_stream_decoder.h
+include/OggFLAC/seekable_stream_encoder.h
include/OggFLAC/stream_decoder.h
include/OggFLAC/stream_encoder.h
lib/libFLAC++.a
lib/libFLAC++.so
-lib/libFLAC++.so.3
+lib/libFLAC++.so.5
lib/libFLAC.a
lib/libFLAC.so
-lib/libFLAC.so.5
+lib/libFLAC.so.7
lib/libOggFLAC++.a
lib/libOggFLAC++.so
-lib/libOggFLAC++.so.0
+lib/libOggFLAC++.so.2
lib/libOggFLAC.a
lib/libOggFLAC.so
-lib/libOggFLAC.so.1
+lib/libOggFLAC.so.3
share/aclocal/libFLAC++.m4
share/aclocal/libFLAC.m4
share/aclocal/libOggFLAC++.m4
@@ -53,6 +58,10 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC++_2export_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2all_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2export_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2file__encoder_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2file__encoder_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2seekable__stream__encoder_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2seekable__stream__encoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2stream__decoder_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2stream__decoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/FLAC_2stream__encoder_8h-source.html
@@ -65,12 +74,18 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC++_2export_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2all_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2export_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2file__encoder_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2file__encoder_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2seekable__stream__encoder_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2seekable__stream__encoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2stream__decoder_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2stream__decoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2stream__encoder_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/OggFLAC_2stream__encoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/assert_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/callback_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/callback_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classFLAC_1_1Decoder_1_1File-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classFLAC_1_1Decoder_1_1File.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classFLAC_1_1Decoder_1_1SeekableStream-members.html
@@ -117,8 +132,16 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/classFLAC_1_1Metadata_1_1VorbisComment.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classFLAC_1_1Metadata_1_1VorbisComment_1_1Entry-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classFLAC_1_1Metadata_1_1VorbisComment_1_1Entry.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Decoder_1_1File-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Decoder_1_1File.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Decoder_1_1SeekableStream-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Decoder_1_1SeekableStream.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Decoder_1_1Stream-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Decoder_1_1Stream.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Encoder_1_1File-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Encoder_1_1File.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Encoder_1_1SeekableStream-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Encoder_1_1SeekableStream.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Encoder_1_1Stream-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classOggFLAC_1_1Encoder_1_1Stream.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/classes.html
@@ -126,14 +149,13 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/doxygen.gif
%%PORTDOCS%%%%DOCSDIR%%/html/api/file__decoder_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/file__decoder_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/file__encoder_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/file__encoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/files.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/format_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/format_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/functions.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/globals.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__flac.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__flac__callbacks.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__flac__decoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__flac__encoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__flac__file__decoder.html
@@ -165,11 +187,17 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac__decoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac__encoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac__file__encoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac__seekable__stream__encoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac__stream__decoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflac__stream__encoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__decoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__encoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__file__decoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__file__encoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__seekable__stream__decoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__seekable__stream__encoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__stream__decoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/group__oggflacpp__stream__encoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/hierarchy.html
@@ -180,8 +208,6 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/ordinals_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/seekable__stream__decoder_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/seekable__stream__decoder_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/seekable__stream__encoder_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/seekable__stream__encoder_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____EntropyCodingMethod-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____EntropyCodingMethod.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____EntropyCodingMethod__PartitionedRice-members.html
@@ -198,6 +224,8 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____FrameFooter.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____FrameHeader-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____FrameHeader.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____IOCallbacks-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____IOCallbacks.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____SeekableStreamDecoder-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____SeekableStreamDecoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____SeekableStreamEncoder-members.html
@@ -240,23 +268,34 @@ share/aclocal/libOggFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____Subframe__LPC.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____Subframe__Verbatim-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structFLAC____Subframe__Verbatim.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____FileEncoder-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____FileEncoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____SeekableStreamEncoder-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____SeekableStreamEncoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____StreamDecoder-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____StreamDecoder.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____StreamEncoder-members.html
%%PORTDOCS%%%%DOCSDIR%%/html/api/structOggFLAC____StreamEncoder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/changelog.html
%%PORTDOCS%%%%DOCSDIR%%/html/comparison.html
%%PORTDOCS%%%%DOCSDIR%%/html/developers.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation.html
%%PORTDOCS%%%%DOCSDIR%%/html/download.html
+%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/html/favicon.ico
%%PORTDOCS%%%%DOCSDIR%%/html/features.html
%%PORTDOCS%%%%DOCSDIR%%/html/format.html
%%PORTDOCS%%%%DOCSDIR%%/html/goals.html
%%PORTDOCS%%%%DOCSDIR%%/html/id.html
%%PORTDOCS%%%%DOCSDIR%%/html/images/1x1.gif
%%PORTDOCS%%%%DOCSDIR%%/html/images/cafebug.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/images/logo.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/logo100.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/images/logo130.gif
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/license.html
+%%PORTDOCS%%%%DOCSDIR%%/html/links.html
%%PORTDOCS%%%%DOCSDIR%%/html/news.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ogg_mapping.html
%%PORTDOCS%%%%DOCSDIR%%/html/ru/authors.html
%%PORTDOCS%%%%DOCSDIR%%/html/ru/comparison.html
%%PORTDOCS%%%%DOCSDIR%%/html/ru/developers.html
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 3d579e910578..a94acd76e41a 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -6,26 +6,20 @@
#
PORTNAME= xmms-flac
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.1.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= flac
DISTNAME= flac-${PORTVERSION}
-PATCH_SITES= ${MASTER_SITE_DEBIAN}
-PATCH_SITE_SUBDIR= pool/main/f/flac
-PATCHFILES= flac_1.1.0-11.diff.gz
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= naddy@FreeBSD.org
COMMENT= XMMS input plugin for playing FLAC files
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- FLAC.5:${PORTSDIR}/audio/flac
+ FLAC.7:${PORTSDIR}/audio/flac
USE_X_PREFIX= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER=15
CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${X11BASE}"
@@ -36,4 +30,8 @@ MAKEFILE= ${FILESDIR}/Makefile
post-configure:
@${RM} -rf ${WRKSRC}/obj
+# XXX
+post-install:
+ @${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la
+
.include <bsd.port.mk>
diff --git a/audio/xmms-flac/distinfo b/audio/xmms-flac/distinfo
index f29bc49bf982..a6d2b4b2f674 100644
--- a/audio/xmms-flac/distinfo
+++ b/audio/xmms-flac/distinfo
@@ -1,4 +1,2 @@
-MD5 (flac-1.1.0.tar.gz) = 19b456a27b5fcf502c76cc33f33e1490
-SIZE (flac-1.1.0.tar.gz) = 1201861
-MD5 (flac_1.1.0-11.diff.gz) = 56285480c9a3c029bdad6d3226e6eaa2
-SIZE (flac_1.1.0-11.diff.gz) = 51614
+MD5 (flac-1.1.2.tar.gz) = 2bfc127cdda02834d0491ab531a20960
+SIZE (flac-1.1.2.tar.gz) = 1516235
diff --git a/audio/xmms-flac/files/patch-configure b/audio/xmms-flac/files/patch-configure
index b16793a26fae..21b1a45cd09e 100644
--- a/audio/xmms-flac/files/patch-configure
+++ b/audio/xmms-flac/files/patch-configure
@@ -1,9 +1,9 @@
$FreeBSD$
---- configure.orig Sun Feb 23 01:11:25 2003
-+++ configure Sun Feb 23 01:11:27 2003
-@@ -7817,6 +7817,7 @@
+--- configure.orig
++++ configure
+@@ -7976,6 +7976,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -11,30 +11,15 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -9818,6 +9819,8 @@
- fi
-
-
-+# Disable id3lib detection
-+if false; then
-
- # Check whether --with-id3lib or --without-id3lib was given.
- if test "${with_id3lib+set}" = set; then
-@@ -10006,6 +10009,8 @@
-
- rm -f conf.id3libtest
-
-+fi
-+have_id3lib=no
-
-
- if test x$have_id3lib = xyes; then
-@@ -11713,7 +11718,7 @@
+@@ -10541,9 +10542,9 @@
if test x$debug = xtrue; then
OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -g -O0 -DDEBUG"
else
-- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O3 -DNDEBUG"
+- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O2 -DNDEBUG"
+ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -DNDEBUG"
if test x$GCC = xyes; then
- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -fomit-frame-pointer -funroll-loops -finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__"
+- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O3 -fomit-frame-pointer -funroll-loops -finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__"
++ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -Wall -W -DFLaC__INLINE=__inline__"
fi
+ fi
+ CFLAGS="$OUR_CFLAGS_HEAD $CFLAGS"
diff --git a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
index 7c784eaa96b1..5470ca6c20bd 100644
--- a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
+++ b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
@@ -1,25 +1,25 @@
$FreeBSD$
---- src/plugin_xmms/Makefile.in.orig Tue Jun 10 00:24:23 2003
-+++ src/plugin_xmms/Makefile.in Tue Jun 10 00:25:16 2003
-@@ -173,8 +173,7 @@
+--- src/plugin_xmms/Makefile.in.orig
++++ src/plugin_xmms/Makefile.in
+@@ -77,8 +77,7 @@
$(top_builddir)/src/share/grabbag/libgrabbag.la \
- $(top_builddir)/src/share/gain_analysis/libgain_analysis.la \
+ $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
+ $(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
+- $(top_builddir)/src/share/utf8/libutf8.la \
+- $(top_builddir)/src/libFLAC/libFLAC.la
++ $(top_builddir)/src/share/utf8/libutf8.la
+ am__objects_1 = charset.lo configure.lo fileinfo.lo http.lo plugin.lo \
+ tag.lo
+ am_libxmms_flac_la_OBJECTS = $(am__objects_1)
+@@ -296,8 +295,7 @@
+ $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
+ $(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
$(top_builddir)/src/share/utf8/libutf8.la \
- $(top_builddir)/src/libFLAC/libFLAC.la \
- -L$(top_builddir)/src/libFLAC/.libs \
+ -lFLAC \
@XMMS_LIBS@ \
- @ID3LIB_LIBS@
+ @LIBICONV@
-@@ -189,8 +188,7 @@
- $(top_builddir)/src/plugin_common/libplugin_common.la \
- $(top_builddir)/src/share/grabbag/libgrabbag.la \
- $(top_builddir)/src/share/gain_analysis/libgain_analysis.la \
-- $(top_builddir)/src/share/utf8/libutf8.la \
-- $(top_builddir)/src/libFLAC/libFLAC.la
-+ $(top_builddir)/src/share/utf8/libutf8.la
- am__objects_1 = charset.lo configure.lo plugin.lo wrap_id3.lo \
- fileinfo.lo
- @FLaC__HAS_ID3LIB_TRUE@am_libxmms_flac_la_OBJECTS = $(am__objects_1)
diff --git a/audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c b/audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c
new file mode 100644
index 000000000000..9cc9f8ed6995
--- /dev/null
+++ b/audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- src/plugin_xmms/plugin.c.orig
++++ src/plugin_xmms/plugin.c
+@@ -259,6 +259,12 @@
+
+ /* stream */
+
++ /* XXX allow indiscriminate use of g_free() */
++ flac_cfg.stream.proxy_host = g_strdup("");
++ flac_cfg.stream.proxy_user = g_strdup("");
++ flac_cfg.stream.proxy_pass = g_strdup("");
++ flac_cfg.stream.save_http_path = g_strdup("");
++
+ xmms_cfg_read_int(cfg, "flac", "stream.http_buffer_size", &flac_cfg.stream.http_buffer_size);
+ xmms_cfg_read_int(cfg, "flac", "stream.http_prebuffer", &flac_cfg.stream.http_prebuffer);
+ xmms_cfg_read_boolean(cfg, "flac", "stream.use_proxy", &flac_cfg.stream.use_proxy);