aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-dionysus/Makefile32
-rw-r--r--math/py-dionysus/distinfo3
-rw-r--r--math/py-dionysus/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 28e7a7334fdd..0a4d874cc722 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -826,6 +826,7 @@
SUBDIR += py-cyipopt
SUBDIR += py-cypari2
SUBDIR += py-deap
+ SUBDIR += py-dionysus
SUBDIR += py-ducc0
SUBDIR += py-ecos
SUBDIR += py-faiss
diff --git a/math/py-dionysus/Makefile b/math/py-dionysus/Makefile
new file mode 100644
index 000000000000..4f15c7499bf2
--- /dev/null
+++ b/math/py-dionysus/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= dionysus
+PORTVERSION= g20210521
+CATEGORIES= math
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -topology-library
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for computing persistent homology
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/adaptors.hpp:devel/boost-libs
+
+USES= cmake python
+
+USE_GITHUB= yes
+GH_ACCOUNT= mrzv
+GH_TAGNAME= ae27bb1
+
+CMAKE_ARGS= -DPython_EXECUTABLE:STRING=${PYTHON_CMD}
+CMAKE_OFF= build_examples
+
+PLIST_FILES= ${PYTHON_SITELIBDIR}/dionysus/__init__.py \
+ ${PYTHON_SITELIBDIR}/dionysus/_dionysus${PYTHON_EXT_SUFFIX}.so \
+ ${PYTHON_SITELIBDIR}/dionysus/_version.py \
+ ${PYTHON_SITELIBDIR}/dionysus/plot.py
+
+do-install:
+ cd ${BUILD_WRKSRC}/bindings/python && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/math/py-dionysus/distinfo b/math/py-dionysus/distinfo
new file mode 100644
index 000000000000..48cc59a2dba2
--- /dev/null
+++ b/math/py-dionysus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643774964
+SHA256 (mrzv-dionysus-g20210521-ae27bb1_GH0.tar.gz) = 36940e1f094115fc3f23e70a03e8a4c68352a602f9133540b10e04117391be2f
+SIZE (mrzv-dionysus-g20210521-ae27bb1_GH0.tar.gz) = 1226395
diff --git a/math/py-dionysus/pkg-descr b/math/py-dionysus/pkg-descr
new file mode 100644
index 000000000000..187afd51bea3
--- /dev/null
+++ b/math/py-dionysus/pkg-descr
@@ -0,0 +1,4 @@
+Dionysus is a computational topology package focused on persistent
+homology. It is written in C++, with Python bindings.
+
+WWW: https://mrzv.org/software/dionysus2/